Donnerstag, 21. März 2019, 15:05 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.


Freitag, 13. Mai 2011, 18:49

Newbie :), with a bricked MRT NAS R200

Hi, first post ;), so i,ll try to give as much info as possible

Just picked up a NAS unit, which by googling, i have identified it as an MRT NAS R200.

It was given to me as bricked, so i'm under no assumptions its an easy fix :#

The motherboard is identified as G5A520A23A2

The unit powers up, with the power light lit, and the access light blinking when connected to my network

The original owner has said that the unit worked fine, but when he tried to reflash to install a squeezebox server it went wrong..

So what we have is:

The unit cannot be found on the network.

The NAS setup utility wont see it & Telnet wont play ball either.

I have tried using the icybox telnet tool, but thats a bit slooow, (although it could be the vista lappy im running from)

I will try on the XP machine tonight.

Next steps:-

Is the unit bricked?

Can it be accessed via a telnet ctrl C command (subject to timing), or will it need to be accessed via a Jtag method (Thats going to be a learning curve)

also where can i find the original firmware , to take me back to a stable start point? MRT dont seem to list firmwares

I now have a Jtag cable, with all 6 wires connected

BLack / Ground
Brown / 3.3v
Red / 5v
Orange / 3.3v
Yellow / 3.3v
Green / 3.3v

I'm guessing the 5V needs isolating, and one or more of the 3.3v ones does as well

I'll see if i can hunt down a bootloader and see if that will give me a start point

Im then going to see if i can get a firmware that works, although MRT, has nothing on there web site




Freitag, 13. Mai 2011, 21:54

Well ive followed the unbricking guide with no success :(

Ive connected the lead as follows

FT232R - Black pin 1
Nothing pin 2
Brown Pin 3
Yellow Pin 4

I have left the Vcc pin free

I set up putty, turned on the NAs, and get 3 lines of garbage and nothing else

ive tried swapping pins 3 & 4 but that gives nothing from putty

Ive also noticed that the small led on the NAS motherboard used to flash red green red, but now it just flashes red

there was another 6 pin jumper on the motherboard, so i tried that one as above, the nas wouldnt even light up using that terminal




Freitag, 13. Mai 2011, 23:04

We have interface :)

found out the problem was the connection speed between the NAS and the Jtag/pc the unbricking guide says use 19200 8 1 , and i needed to use 15200 8 1

so now i can speak to the NAS, but it just asks for a tftps upload mode, and i'm stuck :(

nothing i do will make it do anything, ctrl+c dosent work, nor do any other keys

any ideas? im guessing i need to put a bootloader on



Freitag, 13. Mai 2011, 23:35

This is what i getr from the NAS

Boot Loader [LOADER32 1.20e]
Press <ESC> to enter extra mode

SB PCI reg 0x48 = 00078006
GPIO18 = 0
Active to LAN Disk.
CPU ID: 0x0
Default MAC: 00:B3:F6:00:56:03
Initialize MAC & PHY...OK.
Default IP:

<Enter> or <New IP> or wait 1 Seconds:
Enter tftps upload mode:

but i dont know what to do now, the keyboard is inactive within putty




Beiträge: 1 001

Wohnort: Wien


Samstag, 14. Mai 2011, 10:37

Hi Mart!
The problem is that the MRT NAS R200 bootloader is different to the other NAS devices based on SL3316 or 3516 from MRT, Raidsonic or other brands.

Therefore the unbricking guide does not fit for you and I am afraid that we cannot help you because we don't own such a kind of hardware.

Do you see what type of processor is used on the board?

But I would not try to change the bootloader as it contains hardware dependant code like the BIOS of a PC.
If you take the wrong one it will be a complete brick!


P.S. I read your post at the MRT forum, too ...
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!


Samstag, 14. Mai 2011, 12:57

thanks for the reply :):(

I managed to get a tftp programme to sort of speak to the unit, but it kept reporting wrong size kernal, and wouldnt play ball

MRT / Sumvision who make / distribute the unt, dont repond to requests for replacement fimware, so i'm a bit stuck down that avenue...

I could try to dump an alternate os on it and see if that worked

oh well



Samstag, 14. Mai 2011, 12:59

where would i find the bootloader chip?

i have some piccys of the board if that would help



Samstag, 14. Mai 2011, 14:24

We move on...

nothing ventured nothing gained

did some digging and found the loader was linked to "patriot" devices..

some judicious googling later gave me some firmwares..

i tried one...

it installed, this is the dump

Boot Loader [LOADER32 1.20e]
Press <ESC> to enter extra mode

SB PCI reg 0x48 = 00078006
GPIO18 = 0
Active to LAN Disk.
CPU ID: 0x0
Default MAC: 00:B3:F6:00:56:03
Initialize MAC & PHY...OK.
Default IP:

<Enter> or <New IP> or wait 1 Seconds:
Enter tftps upload mode:
Upload filename: R3282_1_59b_NAS903.bin
Expected Total Size: 683306.
All data receive to RAM, Wait 3 seconds to continue.
Start Erase Kernel OK.
Start Write Kernel (len: 524284) .........................ok.

Start Erase Web OK.
Start Write Web (len: 158974) ....... ok.
Boot the kernel from 0x00F51000 ...

CodeTek R32XX [NET Disk] R3282-1.59b
Hardware Version : 1007 Speed 150MHz
System running!....
PPP software module initialization
HTTPS_Task(): HTTPS Initial done, port 80.
Line print server listening at port 515...
SEARCH_Task(): SEARCH Initial done.
Wait IDE device ready...ppp0 New Phase[INITIALIZE]
PPPOE send PADI...
retry! PPPOE send PADI...

DHCPC: discovery 3 times, Enter AUTO IP Mode.
CMD>ITUNES_Task: Initial done.
SOAP_Task(): SOAP Initial done.
UPNP_Task(): UPNP AV Initial done.
FS_OpenDir: device not found!
SMB_Task(): SMB Initial done.
<FTPS> create C:\PUBLIC folder fail! -1021
retry! PPPOE send PADI...
DHCPS_Start: Enable DHCP Server!
retry! PPPOE send PADI...
Timeout waiting for PADO packets
ppp0 New Phase[DEAD]
NET_PppEvent(): lower layer device down!
PPPOE_Stop(): ppp0 already stop.
ppp0 Same Phase[DEAD]

not sure yet what can be done from here, but its a step one way or the other



Samstag, 14. Mai 2011, 14:27

I have a NAS :):):)

It can connect to the ip addy

asks for & accepts the password :)

its an icybox nas (i dont think it is, but.....)

not the right one mind, but its a start

screen dumps shortly


Samstag, 14. Mai 2011, 15:41

OK screendumps

This is the frmware & OS i believe it should have

This is what it has now

Just going to install a hard drive and see if it plays ball

One more question, is it an MRT box or an icybox now ?



Samstag, 14. Mai 2011, 20:41

OK this firmware is not going to be suitable, as its a single drive.. :(

back on the hunt for a dual drive firmware



Sonntag, 27. November 2011, 15:41

OK this firmware is not going to be suitable, as its a single drive.. :(

back on the hunt for a dual drive firmware



Sonntag, 27. November 2011, 15:41

OK this firmware is not going to be suitable, as its a single drive.. :(

back on the hunt for a dual drive firmware



Sonntag, 27. November 2011, 15:50

dual firmware

Hi mate, noticed your post and thought ths might help, I downloaded it a few years ago now (2008 I think) and installed it on my dual NAS box, worked fine.

Cant remember how I installed it tho at the moment ! ( old age is a bitch ! lol) but it is a starting point, provides a web user interface plus loads more features to share and configure your hard drives.

hope its of some use to you ..


right little addendum here for some reason its telling me the files are too large, (285k for the firmware and 2380k for the manual ?? ) so i#m not sure what to do to be honest .. maybe the admins know or let me have your email addy and I'll mail them direct if you like ..



Beiträge: 467

Wohnort: Zu Hause


Montag, 28. November 2011, 15:15

Hi and welcome!

Use our Database:

Are this executable files? Then it is not the size, it is the content type. Try to put it in a arcive (in special cases it needs a password, like 1234 - to prevent online-scanners from unzipping)

Ps. It is an Icybox 903. If this works You might try out the OS from a dual Nas, like NAS4220 or 2000 (at Your own risk). The IcyBox Os are based on pretty the same Kernel. The 4220 OS provides the RAID support (guess that is what You want ;) ) .. see -> support -> firmware

Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)