Samstag, 25. November 2017, 08:24 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Sonntag, 31. Juli 2011, 23:27

3.3V TTL to USB converter for DIR685 storage router

Hi,

Can someone please suggest a good 3.3V TTL to USB converter?

I googled and only see USB-TTL converter. I want to connect the console port ( 3.3V TTL ) to my laptop USB port.

TIA

2

Dienstag, 2. August 2011, 21:08


HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

3

Donnerstag, 4. August 2011, 09:43

Hi,
the best would be one with a FTDI FT232R or RL chip. You should be able to find one at ebay in the range from 7 to 20€.
This offers you the opportunity to use it for the JTAG unbricking in case of a destroyed bootloader.

Have a look at the wiki guide or HowTos

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

4

Freitag, 5. August 2011, 04:47

Thanks guys...

I got FTDI 6pin TTL-232R-3V3 USB adapter which has FT232RQ chip. Since USB port on the laptop would provide VCC +5VDC, I guess I don't need to connect VCC +3.3VDC connection available on the router DIR-685 board, just TX, RX and GND would suffice. Am I right?

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »samurai_ttl« (5. August 2011, 06:01)


HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

5

Freitag, 5. August 2011, 12:01

Hi,
you are right.
The chip has a built in 3.3V voltage regulator and does not need to be powered from the target hardware.

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

6

Freitag, 5. August 2011, 17:59

Thank you for your time and replies, appreciate it. :thumbsup:

7

Samstag, 6. August 2011, 07:01

So I tried the adapter cable but I don't see any console output. Tried at different speeds in putty and reversing tx and rx didn't help either.
I know the cable is working ( tested by shorting tx and rx ). I tried the connection per the pinout in the wiki. The cpu is SL3516 and Spansion flash.

AQUAR

Schüler

Beiträge: 100

Wohnort: Australia

8

Samstag, 6. August 2011, 09:24

Hi,

Maybe you are connecting the adapter to the NAS before NAS power up?
Have everything setup: ie console running and able to communicate with adapter(loop back test).
Remove loop back bridge and get ready to quickly plug the adapter on to the NAS shortly after powering it up.

Aquar

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

9

Samstag, 6. August 2011, 10:43

I think we need some more information ...

- which NAS?
- does it boot and is accessible?
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

AQUAR

Schüler

Beiträge: 100

Wohnort: Australia

10

Samstag, 6. August 2011, 12:18

I think he is talking about a fancy router/ NAS combination from Dlink.
But we definitely need more info about the problem/purpose for
this serial console access requirement.

11

Samstag, 6. August 2011, 19:58

I tried by connecting the device after and before power up but no avail.

This is DIR685 storage router. It does boot and I can telnet to it. It's SL3516 based and has Spansion flash.
The console serial connection is 4 pin header and followed the signal connections per wiki ( hopefully there are same for this device )..

This devices has an issue of noisy fan. I thought to look into this and see if I can find out the reason and see if there is a way to fix it.
It has 2x10 maybe JTAG connector but without header.

Thanks

AQUAR

Schüler

Beiträge: 100

Wohnort: Australia

12

Sonntag, 7. August 2011, 05:00

Hi,

It would be most improbable if the firmware has some built in fan controller software.
Fan noise is a mechanical issue so if it spins to fast then just slow it down with some series resistance.
If the bearings are noisy then oil them.
Best of all you could just buy a better quality fan.

Fiddling with JTAG or serial port are for unbricking and could just as easily do the reverse for you.
If you want to delve into the firmware a bit more then use SSH and look for log files.

:beer: but I think HWguru will probably want to do this :closed:

Aquar

13

Sonntag, 7. August 2011, 08:30

Well the noisy fan issue is basically spinning at full speed when you put the drive inside the router. This router has an internal drive bay and also 2x USB port for connecting external drives. The fan is meant for cooling off the drive. The fan spinning at high or full speed most of the time if not all the time means to me is a poor thermal design of the device which apparently the case here. The firmware has smart monitor and provides the drive temperature to the fan controller driver. I don't see a separate drive for fan control but maybe it's inbuilt in the kernel either acpi or something. It seems there is a defined threshold of 46-47F and as soon this is crossed, the driver spins the fan at full speed causing irritating noise. I couldn't find what that driver is and any command to see the fan status etc. Other option I can think of is to put an extra fan/blower in series or parallel but I got to know power supply setting/capability of the fan controller. Need to see what electronics and driver plays here. Also there are other issues with this router which says a buggy firmware.


BTW, I tried the other connection pinout of the serial console but still don't see console output.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »samurai_ttl« (8. August 2011, 03:14)


14

Montag, 8. August 2011, 02:25

Ok.. I go the connection working. Happy camper now.... :)

AQUAR

Schüler

Beiträge: 100

Wohnort: Australia

15

Montag, 8. August 2011, 11:49

Hi,

Curious for others that have this device:
What was the issue with the connection?
What is the serial port pinout of this device?

Success in finding a way to alter the temperature trigger point for full fan speed.
Please share it if you do ;) .

Aquar

16

Montag, 8. August 2011, 18:14

Here is the serial port pinout:

Quellcode

1
2
3
4
5
6
7
8
PINS:

o o o _ o
| | |   |
| | |   RX
| | VCC
| GND
TX


Serial connection config: 19200 baud, 8 bits, 1 stop bit, no parity, no flow control. I used putty.

For the FTDI adapter, I had to reverse the TX, RX at the connector end.

I'll share the information about fan speed as soon as I find a way out.

AQUAR

Schüler

Beiträge: 100

Wohnort: Australia

17

Dienstag, 9. August 2011, 12:53

Hi,

As you noticed, both PC and NAS are considered DTE and require a null modem connection to talk to each other.

I am sure there will be an interest in your findings re quietting the fan through firmware patching.
You should start a new topic when you wish to share your effort ;) .

Aquar

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

18

Mittwoch, 10. August 2011, 09:54

Hi,
it is always the same - an Rx (receive) pin needs to be connected to a Tx (transmit) pin.

As Aquar said I will close now as this problem is solved.
We would be very glad if you start a new thread and share other tweaks with us :lean:

HWguru

Note: I extended the title and added a code section for the pinout for better readability.
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!