Freitag, 17. November 2017, 18:28 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Dienstag, 11. Oktober 2011, 15:38

Unbricking with usb2serial weird chars

Hi all

i'm trying to unbrick my GIGANAS with a self build usb to ttl cable, made cutting a Samsung E710 data cable.

When i connect with putty terminal shows random chars and ctrl+c doesnt respond.



Anyone has a similar problem? what can be the cause?

The cable seems to be correctly detected (it's a sandard chinese mobile phone usb2ttl based on PL2303)



thank you in advance for support

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

2

Mittwoch, 12. Oktober 2011, 09:30

Hi and welcome!
Check if the ground connection is ok and if have not exchanged the wires.
If you have a multimeter you could check the USB connector which metal case should be ground against the wire ends.

HWguru

P.S. moved the thread to "Hardware related"
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

3

Mittwoch, 12. Oktober 2011, 16:57

Hello, thank you for welcome :)

Just tested all the 9 wires coming out of the original cable end (the side where i cutted the Siemens proprietary plug).

Well, didnt find any cable that is directly connected to the usb side ground (metal external part of the plug). Maybe this Siemens cellphone cable worked on that cellphone without ground?!? This sounds a little weird to me.

Anyway ground is ground so I'll try a bypass connecting directly from usb plug to jtag endings.

Will update you as soon as I'll have some news.

Thanks

Davide

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

4

Mittwoch, 12. Oktober 2011, 17:14

Hi,
maybe the cage is not connected but the minus pin inside the USB connector should be at least.
I don't think there is an isolation between USB and serial.

JTAG? With a PL2303 you cannot run our JTAG tool but for serial connection it is ok.

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

5

Mittwoch, 12. Oktober 2011, 17:28

Sorry i meant the serial programming with icsp strips on board. In facts i'm trying to connect with a terminal.

Tested the gnd pin and it's connected to the gnd cable ending. So only the cage is isolated.

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

6

Mittwoch, 12. Oktober 2011, 17:44

I checked the Samsung E710 schematic.
If you still have the connector you could find the corresponding wires.

The pinout for the phone's connector:

Quellcode

1
2
3
GND - 8, 11 (19, 20)
Tx  - 2 (would be Rx of the cable)
Rx  - 3
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

7

Dienstag, 22. November 2011, 17:20

Hello there again.

I cutted all and restarted from scratch.

After following the board paths (hard work, they're really small and I'm not an "eagle eye"). I connected GND and TX/RX correctly.

Now can read all correctly with GND + RX (TX on NAS), weird chars disappeared (was a GND issue as you figured out).

But cannot send. If I plug the TX pin (RX on nas) it doesnt work anymore, and cannot even read. Tried may times to follow the paths and looks it's the correct pin.

Is it correct that between GND and TX there's +3.25Vcc always?

I noticed that RX works correctly without Vcc connected. Is Vcc necessary for TX?

thank you again,

Davide

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

8

Dienstag, 22. November 2011, 17:47

Hi,
maybe we missed one important thing.
The USB/Serial chip of the cable needs to be powered with the correct IO voltage.
The phone has its VCCD on pin 6 of the phone connector.
This will probably be the reason why Tx of the cable does not work.

This wire needs to be connected with the NAS VCC.

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

9

Dienstag, 22. November 2011, 18:47

Oh...so you mean that Vcc power from USB is not ok, and I have to take it from JTAG Vcc pin on NAS?
I thought it was an input pin. .. ?(

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

10

Mittwoch, 23. November 2011, 08:20

Yes, VCC Pin on the NAS is directly connected to the NAS's internal 3.3V Power supply and is an "output" therefore.
The NAS powers itself and Rx/Tx is directly connected to the CPU without any electronics.
So you have to be careful what you are doing for not destroying the chip.

Did you have a look at or the MRT unbricking guide or our HowTos at our NAS2000 Wiki where there is an article about soldering a RS232 port to a NAS2000 (is different to your NAS but the basics are the same).

If the USB cable/adapter needs external power depends on its construction.
In your case it seems to need external 3.3V for supplying the PL2302 I/O buffer. With this voltage the output pin is driven and sets the input threshold.
(For other electronics it could also be 2.5 or 1.8V)

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!