Montag, 18. Dezember 2017, 17:36 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

vlad21

Anfänger

Beiträge: 7

Wohnort: Hungary

1

Mittwoch, 27. November 2013, 19:44

Firmware upgrade and crash

Hi AQUAR!

I tried to change the original (ver. 1.1.1) firmware to Opengemini 1.4. I did everything step by step as you described, except, so I use fixed IP ( 192.168.0.100 ) for my Box. I pushed "Upgrade" button and I'm waiting for reboot about 5 minutes, but no action. Only three leds was on ( POWER, LAN, STATUS ), no blinks, no nothing.
I pushed my Firefox's refresh button. It send something to the box ...
After few seconds, all leds became on and that was all. 10 minutes later I switched off the Box and now I have a scrap.

Is possible to rewrite flash?

I don't have an expensive level shifter cable and I don't have/use windows. In Linux ( my op. system is Debian 7 KDE ), not to easy to use serial ports or virtual ( usb to serial ) serial ports.
Could you give me some help or tip?
Regards: -=L=-

AQUAR

Schüler

Beiträge: 100

Wohnort: Australia

2

Donnerstag, 28. November 2013, 11:26

Hi vlad21,

Sorry to hear you bricked your NAS box in the process to flash to OpenWRT.
I take it from the firmware version that you maybe have an MvixBOX NAS?

Are you referring to the article on flashing to OpenWRT in this forum?
Or are you referring to the developers instructions on the OpenGemini site?

Did you reflash from the web page that only appears if you remove the HDD's?
Does the box respond to a ping on ip address 192.168.1.250 at all?
Check that first, but note you need to change the PC NIC's subnet address range from 192.168.0.xxx to 192.168.1.xxx.

Hopefully you did better than bricking.

vlad21

Anfänger

Beiträge: 7

Wohnort: Hungary

3

Dienstag, 3. Dezember 2013, 12:44

Hi!
Thank you for your help.

What did I do:

I did everything, as described you.
I set up the NAS IP to a fixed IP ( 192.168.0.100 )
I set up my PC IP to 192.168.0.150
I restarted NAS and PC too, checked IPs again
I swithced off all ( NAS and PC ).
I pulled out the LAN cables ( NAS an PC ) from the router, and pulled out the HDD from the NAS's bay.
I connected the PC directly to the NAS with LAN cable ( not cross cable ).
I powered up all, and checked connection with ping command ( from terminal : ping 192.168.0.100 ).
I started Firefox, called the NAS's rescue page, checked the connection with LED test and checked factory firmware version ( it was 1.1.1 ).
I chose the OpenWRT firmware, which I downloaded from the web site: http://opengemini.free.fr/wiki/doku.php?id=openwrtv ( images-mvixusa2openwrt-mbox_v1.4.bin )
I pushed "Start Upgrade" button.
After not happened nothing...from here, you know the rest of my story.

I tried to discover the actual IP of the Box with nmap, ping, telnet, ssh. I see, so the LAN led blinks, but no result from nmap and so on.
One interesting thing. If I powered on the box with simultaneously pushed down the front switches, the box made a led tests ( leds blinks sequentially ), and few seconds later all leds goes off.

I uploaded a picture, and i marked the RSR232 port. Is it right ? Is possible to use to reflash the MX29LV640 chip?

Best regards : -=L=-
»vlad21« hat folgende Datei angehängt:
  • 20131129272a.jpg (139,36 kB - 6 mal heruntergeladen - zuletzt: 3. Februar 2016, 16:32)

AQUAR

Schüler

Beiträge: 100

Wohnort: Australia

4

Donnerstag, 5. Dezember 2013, 13:07

Like I said, you are in the wrong IP subnet for the initial connection to OpenWRT.
Setup a direct connection between PC and NAS.
Change the subnet as described earlier so that the NIC can communicate with the NAS.

Then bring up the LUCI web interface and setup the network address to suit your LAN.
If you were using a DHCP server for your LAN then you can simply configure OpenWRT for that.

Again, change the IP subnet first.
Ping the NEW NAS IP adress for a response or try the LUCI web interface for a response.
If you get nothing - then we will consider what needs doing next.

vlad21

Anfänger

Beiträge: 7

Wohnort: Hungary

5

Sonntag, 8. Dezember 2013, 19:25

Hi!
I hope, I found it!
root@debian7kde:/home/vlad# nmap -sP 192.168.0.100-254

Starting Nmap 6.00 ( http://nmap.org ) at 2013-12-08 18:42 CET
mass_dns: warning: Unable to determine any DNS servers. Reverse DNS is disabled. Try using --system-dns or specify valid servers with --dns-servers
Nmap scan report for 192.168.0.100
Host is up.
Nmap scan report for 192.168.0.199
Host is up (0.00023s latency).
MAC Address: 00:xx:xx:xx:xx:xx (Eunicorn) [I checked this MAC. It was OK]
Nmap done: 155 IP addresses (2 hosts up) scanned in 5.89 seconds
root@debian7kde:/home/vlad# ping 192.168.0.199
PING 192.168.0.199 (192.168.0.199) 56(84) bytes of data.
64 bytes from 192.168.0.199: icmp_req=1 ttl=64 time=0.153 ms
64 bytes from 192.168.0.199: icmp_req=2 ttl=64 time=0.115 ms
64 bytes from 192.168.0.199: icmp_req=3 ttl=64 time=0.135 ms
64 bytes from 192.168.0.199: icmp_req=4 ttl=64 time=0.184 ms
64 bytes from 192.168.0.199: icmp_req=5 ttl=64 time=0.117 ms
64 bytes from 192.168.0.199: icmp_req=6 ttl=64 time=0.117 ms
^C
--- 192.168.0.199 ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 4997ms
rtt min/avg/max/mdev = 0.115/0.136/0.184/0.029 ms
root@debian7kde:/home/vlad# ssh 192.168.0.199
ssh: connect to host 192.168.0.199 port 22: Connection timed out
root@debian7kde:/home/vlad# telnet 192.168.0.199
Trying 192.168.0.199...
telnet: Unable to connect to remote host: Connection timed out

What is the next step?
Best regards : -=L=-

AQUAR

Schüler

Beiträge: 100

Wohnort: Australia

6

Montag, 9. Dezember 2013, 09:51

Sorry, it is pointless for me to repond any further if you continue to ignore the advice already given.
Once again change the subnet of the direct connection.

Redboot has the ethernet IP address of 192.168.0.199, but it probably should not have replied to packets send to it.

vlad21

Anfänger

Beiträge: 7

Wohnort: Hungary

7

Montag, 9. Dezember 2013, 21:29

Hi!
Sorry, I didn't understand, how should I set up the IP range... ?(
My desktop network config is
:
/etc/network/interfaces
"
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
auto eth0
iface eth0 inet static
address 192.168.0.100
netmask 255.255.255.0
gateway 192.168.0.1
"
How possible to set up better?

Best regards : -=L=-

AQUAR

Schüler

Beiträge: 100

Wohnort: Australia

8

Dienstag, 10. Dezember 2013, 01:42

@vlad21
You are operating your LAN connection in the IP range of 192.168.0.xxx (xxx any figure in the range 1 - 255).
The initial ethernet adress of the OpenWRT firmware is NOT in that range but in the IP range of 192.168.1.xxx.
That is a different LAN subnet (not 0.xxx but 1.xxx).

You need to set the NIC to a static IP address anywhere in the range 192.168.1.xxx such as 192.168.1.100 (NOT 192.168.0.100).
Connect the NAS to that NIC and see if you can ping or bring up the OpenWRT LUCI interface.
I am asking you to do that because I am NOT convinced you have bricked your NAS.

The way to do this depend on your OS IPV4 interface - so can't give specifics and also I am not overly familiar with linux.
It should be very easy to do.

The fact that you got a ping reply on 192.168.0.199 is a concern as maybe you are stuck at redboot.
I don't know this for sure and would have to set up my test NAS to see how it responds to a windows based Nmap.
For now just test your firmware reflash as asked for above.

vlad21

Anfänger

Beiträge: 7

Wohnort: Hungary

9

Mittwoch, 11. Dezember 2013, 14:00

Hi!
What did I do:

MBox powered on and connected directly to my desktop with an RJ45 cable ( no cross cable ).
I edited the network parameters and saved it in 'interfaces' file.
"
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
# allow-hotplug eth0
auto eth0
iface eth0 inet static
address 192.168.1.2
netmask 255.255.255.0
gateway 192.168.1.1
"
PC powered off and on, but MBox remained on state.
After restart, I opened a terminal, and:

vlad@debian7kde:~$ su
Password:
root@debian7kde:/home/vlad# nmap -sP 192.168.1.2-255

Starting Nmap 6.00 ( http://nmap.org ) at 2013-12-11 13:29 CET
mass_dns: warning: Unable to determine any DNS servers. Reverse DNS is disabled. Try using --system-dns or specify valid servers with --dns-servers
Nmap scan report for 192.168.1.2
Host is up.
Nmap done: 254 IP addresses (1 host up) scanned in 10.44 seconds
root@debian7kde:/home/vlad#

No other device on the network, except my desktop ( 192.168.1.2 ), as you see in the scan report.

What is the next?
Best regards : -=L=-

AQUAR

Schüler

Beiträge: 100

Wohnort: Australia

10

Donnerstag, 12. Dezember 2013, 03:34

I don't use Linux myself so not all that familiar with the way things work.
However I think your network configuration file seems to now be setup correctly for working in the OpenWRT subnet.
The fact that Nmap scans and finds the PC seems to suggest the network is working.

I'll have to connect my test unit to see for myself how the NAS responds to a static network connection.

Try to experiment:
1) The MBOX power supply doesn't always start properly when the power to it is turned on.
So try to cycle it by turning it off then back on with the switch at the back.
Make it easier for the power supply by not having any HDD installed.

2) The OpenWRT firmware will give a solid beep during loading when the power supply starts properly.
Are you getting a solid beep? (there is also a weak beep sometimes when the power turns on - ignore that).

3) Turn on the NAS after the PC so that it has a network connection to handshake with.
Maybe you need to add the broadcast address for initial recognition between devices (BROADCAST : 192.168.1.255).

AQUAR

Schüler

Beiträge: 100

Wohnort: Australia

11

Dienstag, 31. Dezember 2013, 10:25

As VLAD21 has not returned, I must assume the NAS box was either not bricked or has been replaced.

For those still interested in the next step (if it was bricked!).
You can install OpenWRT via the onboard serial port and restore the NAS to proper functionality.
It is possible to slip the 4 pin connector onto the serial port without dismantling the box (albeit with a fair bit of fiddling).
The OpenWRT binaries to directly flash the memory are available on the OpenGemini website.

vlad21

Anfänger

Beiträge: 7

Wohnort: Hungary

12

Sonntag, 19. Januar 2014, 23:26

Hi!

Sorry, I was busy last few weeks...

Please, help me, how can I download openwrt ( or redboot ) via serial port.
I bougth a cheap usb to serial device ( http://www.ebay.com/itm/2pcs-PL2303HX-US…t-/171127768483 ).
I connected my usb device to a four pins port on the NAS motherboard, but not happened nothing...
Is the four pin connector the JTAG connector?
What is the basic setting for serial port ( 9600 N81 )?
What kind of terminal program need to use for it? I tried with realterm ( http://realterm.sourceforge.net/ ), Putty, but no connection or not possible to download the file( redboot.bin ).

Regards: -=L=-

AQUAR

Schüler

Beiträge: 100

Wohnort: Australia

13

Montag, 20. Januar 2014, 12:29

Sorry but I am not inclined to engage in "on again - off again" help sessions without appropriate etiquette.

But as some friendly advice:
- make sure that your USB to Serial gadget is wired to present 3.3 volts on the data pins.
The type you purchased is likely to be hard wired for TTL logic levels (ie presents 5.0 volts on the data pins).
If 5 volts then you are likely to damage the MBOX serial port (without appropriate current limiting on these data paths!).
- all binaries are available on the opengimini web site.
- do not use the firmware upgrade in redboot when flashing OpenWRT, use the binaries paired with "kernel" and "ramdisk".
- lastly terminal (baud=115200, Data bits=8, Stop bits=1, no parity, no flow control).