Freitag, 24. November 2017, 11:55 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

1

Sonntag, 6. April 2008, 19:58

ftp-server und passiv-mode

hallo zusammen,
bei mir ist ein problem mit dem ftp-server aufgetreten.
ich kann mich nicht mehr einloggen, der client gibt folgende rueckmeldung:

Quellcode

1
2
3
4
5
6
200 Type set to A
PASV
227 Entering Passive Mode (85,176,149,201,234,109).
Data Socket Error: Connection timed out
421 No Transfer Timeout (300 seconds): closing control connection.
Connection lost: 192.168.10.3


das server-log sagt folgendes:

Quellcode

1
2
3
4
5
6
7
8
Apr 06 17:37:58	 Preparing to chroot to directory '/mnt'
Apr 06 17:37:58	error rewinding scoreboard: Invalid argument
Apr 06 17:42:58	Passive data transfer failed, possibly due to network issues
Apr 06 17:42:58	Check your PassivePorts and MasqueradeAddress settings,
Apr 06 17:42:58	and any router, NAT, and firewall rules in the network path.
Apr 06 17:42:58	FTP no transfer timeout, disconnected
Apr 06 17:42:58	wtmp /var/log/wtmp: No such file or directory
Apr 06 17:42:58	FTP session closed.


hier ist noch meine proftp.conf:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
ServerName "!!!TEST!!!"
ServerType standalone
DefaultServer on
DefaultRoot /mnt

CharsetLocal UTF-8
CharsetRemote CP950

SystemLog /var/log/messages
Port 21
Umask 006
MaxInstances 30

#
# if you want to access the ftpserver 
# from the internet put your dyndns name
# and the portrange here
# make sure your router knows about the portrange too.
MasqueradeAddress klickme.homedns.net
PassivePorts 60000 60100
#
# for more infos about this module check:
# http://www.castaglia.org/proftpd/modules/mod_dynmasq.html
#
<IfModule mod_dynmasq.c>
      # Refresh any configured MasqueradeAddress directives every 8 hours
      DynMasqRefresh 28800
</IfModule>

#
# for more infos about this module check:
# http://www.castaglia.org/proftpd/modules/mod_shaper.html
#
<IfModule mod_shaper.c>
      ShaperEngine off
      ShaperLog /var/log/ftpd_shaper.log
      ShaperTable /var/log/ftpd_shaper.tab

      # An overall rate (in KB/s) must be set.  This line explicitly
      # sets both the download and upload rates to be the same.
      ShaperAll downrate 1500 uprate 1500

      # Allow all system users to see shaper info
      ShaperControlsACLs info allow user *

      # Allow FTP admins to alter settings both overall and per-session
      ShaperControlsACLs all,sess allow group ftpadm
 </IfModule>

#
# if the ftp responcse (for ls ...) is very slow uncomend the next lines 
#
UseReverseDNS off
IdentLookups off 

<IfModule mod_delay.c>
DelayEngine off
</IfModule>

UseSendfile off

User nobody
Group nobody

RequireValidShell off

#receivefile on  ## This parameter is for TSS. You can fill in either "on" or "off". ##

# allow to restart interrupped up-/downloads
AllowStoreRestart on
AllowRetrieveRestart on


ScoreboardFile /var/run/proftpd.pid

# Normally, we want files to be overwriteable.
<Directory /*>
   AllowOverwrite on
</Directory> 
#<Anonymous //mnt/IDE1/guest-share>
#User guest-share
#Group guest-share
#UserAlias guest guest-share
#UserAlias anonymous guest-share
#UserAlias ftp guest-share
#<Directory *>
#<Limit WRITE>
#AllowAll
#</Limit>
#</Directory>
#</Anonymous>
<Directory /mnt/IDE1/admin>
<Limit ALL>
DenyAll
</Limit>
<Limit DIRS READ WRITE>
AllowUser admin
</Limit>
</Directory>
<Directory /mnt/IDE1/guest-share>
<Limit DIRS READ WRITE>
DenyAll
</Limit>
<Limit DIRS READ WRITE>
AllowUser guest-share
</Limit>
</Directory>


vllt kann mir ja jemand helfen und weiss welche einstellungen ich da machen muss..

__
Boo
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

2

Montag, 7. April 2008, 01:04

Änderung?

Hallo,
hast du eine änderug in der proftpd.conf vorgenommen?
Zufällig das Masquerade?
(be mir musste ich das Masquerade wieder deaktivieren, hatte auch keinen zugriff)
Bei mir ist der router fuer das dyndns zuständig.
Hardware Name IB-NAS 1000 Platform / IB-NAS 2000
Firmware Version 2.3.2-mu-02.2 (Tinky)
Hardware Version Rev. B
* und alles an:):)*

BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

3

Montag, 7. April 2008, 13:12

hallo...
also bei mir macht auch der router das dyndns und aenderungen habe ich merkwuerdigerweise auch nicht vorgenommen.
die masq-einstellungen stimmen eigentlich so.
komisch ist, das der fehler auch auftritt, wenn ich ueber die interne ip auf den ftp zugreife.
ich kann meinem ftp-client die einstellung:
"Site uses IP Masq/NAT/Non-Routable IP" mitgeben, dann connected er ohne probleme,
aber leider gibt es diese einstellung nicht bei jedem client.
eigentlich muesste man den server doch so einstellen koennen, das jeder client darauf zureifffen kann, oder?
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »BooStar« (7. April 2008, 13:13)


4

Montag, 7. April 2008, 18:48

versuch mal das Masqurading zu deaktivieren. Einfach das Masqurading auskomentieren.
Danach einen Reboot.


mfg BadRat
Hardware Name IB-NAS 1000 Platform / IB-NAS 2000
Firmware Version 2.3.2-mu-02.2 (Tinky)
Hardware Version Rev. B
* und alles an:):)*

BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

5

Dienstag, 8. April 2008, 15:23

ich habs grad noch nicht ausprobiert,
aber hat denn die abstellung von Masq nicht zur folge das der ftp nicht mehr von aussen erreichbar ist?
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

6

Dienstag, 8. April 2008, 20:51

@ BooStar: Kommt drauf an, hast du einen Router, der das dyndns unterstützt? Dann stelle es dort ein und kommentier den Part aus der conf. (Ports natürlich offen lassen)
Wenn nicht, dann solltest Du es aktiv lassen, es sei denn Du hast noch irgend einen anderen client, der Deine aktuelle IP an dyndns übermittelt - nix anderes macht z.B. der Client für den PC von dyndns.

Grüße. Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

7

Mittwoch, 9. April 2008, 12:54

hallo,
also erstmal danke fuer die antworten,
mein router unterstuetzt dyndns und darum konnte ich die zeilen auch einfach auskommentieren..
gut mein problem mit dem passiv-mode scheint jetzt geloest zu sein.
eine sache waere da aber noch, koennte ihr ueber eure dyndns via browser (hier firefox)
auf euren ftp connecten? hier geht naemlich nicht.
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

8

Mittwoch, 9. April 2008, 17:29

Kurze AW und dann können wir den Threat evtl. auch dicht machen. ;)

Also: Grundlegend ergibt sich ein Konflikt, wenn ein Request und ein recive auf der selben IP operieren - und das wäre in Deinem Fall eben die maskierte IP. Bei mir geht das auch net. Verwende bitte im LAN Deine lokale IP also (ich vermute: 192.168.0.XY) und es klappt. Ich nutze (siehe Signatur) einen D-Link Router. Habe aber schon gehört, das es Router gibt, die das unterstützen. Ich glaube da kommst Du weiter, wenn Du in das Forum zu deinem Router guckst. Es sei denn, Du hast durch zufall auch den D-Link, dann kann ich Dir mit einem Trick weiter helfen. Stichwort XYZ.de.vu 8)

Eine Idee hab ich noch: manche router sperren sich gegen das passive ftp - versuch doch mal Dein Glück mit dem IExplore.exe und stell unter extras mal den passive mode aus (häckchen entfernen).

Bitte berichte was erfolgreich gewesen ist und was nicht.

@HWguru: für die do_it v1.2 sollen wir bei den Mask einstellungen einen Comment einfügen ala wenn dyndns auf Router dann auskommentiert lassen wenn nicht dann aktivieren.

Ahoi!
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

9

Mittwoch, 9. April 2008, 18:01

hi snoopy,
danke fuer die antwort,
das ich nicht auf meine eigene dyndns zugreifen kann ist mir klar, es sei denn es wuerde vom router unterstuetzt, meiner tut es leider nicht :D
das problem ist, das niemand von aussen via browser(zumindest firefox, andere werden noch getestet) auf meinem ftp zugreifen koennen.
also bitte noch nicht dicht machen.
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

10

Mittwoch, 9. April 2008, 18:17

sooo also mit dem internet-explorer geht es, aber nur wenn man die einstellung
"Passives FTP verwenden" ausklickt..
jetzt muesste ich diese einstellung nur noch im mozilla finden, aber das schaffe ich dann noch alleine...
also meinet wegen koennt ihr den thread jetzt schliessen, obwohl ich kein grosser freund davon bin, themen zu schliessen.aber ich bin ja kein mod :D darum macht was ihr wollt, mir wurde zumindest geholfen. danke an alle...
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

11

Mittwoch, 9. April 2008, 18:19

Oh, das macht die Sache interessant. :rolleyes:

Gut. Folgendes Angebot: Richte mal einen testaccount ein und poste (oder PN) deine Adr. - ansonsten geht auch mal ein test via www2ftp.de - nur eben ohne logs.

Grüße. Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »snoopy« (9. April 2008, 18:19)


BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

12

Mittwoch, 9. April 2008, 18:41

was ist interessant?
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

13

Mittwoch, 9. April 2008, 19:09

Ok. Ich glaub ich habs. :D

Wie auch bei mir ist Dein Router evtl. nicht geeignet für den passive-mode. Das musst Du prüfen. Vielleicht gibts ein FW Update was das problem behebt für Deinen Router. Sollte es ein D-Link sein (hab nicht geguckt :P) dann stehen die chancen eher schlecht.

Mit filezilla klappt es (siehe PN - dort ist das log) aber eben nur im active mode.
Setze ich den Mode auf passive (erzwungen) dann offenbart sich das Problem: Anmeldung geht noch jedoch beim listen des verzeichnisinhalts:

Antwort: 227 Entering Passive Mode (192,168,10,3,4,42).
Status: Vom Server gesendete Adresse für den Passiv-Modus ist nicht routingfähig. Passiv-Modus fehlgeschlagen.

Tja. und nicht routingfähig heißt das Übel in der kette ist wohl der der das normalerweise tut: Dein Router.

In Firefox gehts net, weil der kann kein active-mode (von haus aus - evtl. gibts n plugin).
Im Iexplore gehts, wenn man den passive-mode ausschaltet (extras-internetoptionen-erweitert). Im passive halt auch nicht. Per default ist passive aktiviert.

Möge es nützen!
Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »snoopy« (9. April 2008, 19:50)


BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

14

Mittwoch, 9. April 2008, 19:50

...ok... dann berichte mal was du erreicht hast, was evtl zu aendern, oder zu verbessen waere...
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

15

Mittwoch, 9. April 2008, 20:29

Siehe oben. ich war wohl einen Tick schneller :P

Wenn Du mir sagst, welchen router du benutzt, können wir klären, ob der passive unterstützt oder nicht. (hat was mit dem Öffnen und schließen der ports zu tun).

greetz. Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »snoopy« (9. April 2008, 21:00)


BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

16

Donnerstag, 10. April 2008, 13:12

hi snoopy,
dann liegts also am router...naja...dann muss ich wohl damit leben denke ich,
ich habe jedenfalls keine einstellungen dazu in der routerconfig gefunden.
ich benutze einen levleone FBR-1415TX.
das er keinen passiv-mode unterstuetzt ist nicht so schlimm, dann muss ich halt aktives ftp machen. ich dachte halt urspruenglich, das man da noch etwas in der ftpconfig einstellen muesste...
also bis dahin...besten dank...
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »BooStar« (10. April 2008, 13:21)


snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

17

Donnerstag, 10. April 2008, 14:47

Ich tipp mal der router heißt level one FBR-1415TX. Damit gehts halt leider nicht. Evtl. könntest Du versuchen in der Config die Passive Ports zu benennen - schau mal in die do_it proftpd.conf - da sind die ports 60000 und 60100 gesetzt und natürlich auch am Router zu öffnen. Auf diesen ports sollte auch nix anderes laufen, denn die sind ja dann ständig offen. Ein test wäre es wert.

Ansonsten eben active. Ist ja kein Problem, wenn man es weiß. Bei opera geht auch der aktive-mode einzustellen. Firefox hängt da etwas - dafür gibts ein plug in namens fireFTP --> damit wird auch der upload zum kinderspiel.

Thema Schließen?

Greetz. Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)