Samstag, 16. Dezember 2017, 12:08 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Xiberger

Anfänger

Beiträge: 10

Wohnort: 82194 Gröbenzell

1

Dienstag, 8. April 2008, 22:56

Umlaute und proftpd

Hallo zusammen,
bin ein Neuer... und freu mich schon seit längerer Zeit an den super hilfreichen Beiträgen, z.B. bei der Lösung des langsamen FTP Downloads bei BIN Dateien - perfekt, vielen Dank für die kompetenten Beiträge!

Soweit so gut, läuft eigentlich alles.

1 Problem ist noch übrig.

Ich hab das NAS Kastl
IB-NAS2001-B
mit der Firmware 2.3.2.IB.2.RS.2, die war drauf installiert, und dem proftpd 1.3.0.

Die Platte ist mit ext3 formatiert.

Klappt soweit ganz gut, NUR die Umlaute werden im FTP Client (ftp über CMD, fireftp, Winzilla) nicht korrekt angezeigt. Hab viel im Internet gelesen, die meisten Hinweise bezogen sich auf die Einstellung des charsets im FTP Client. Standardmäßig ist da UTF-8 eingestellt, ich habs versuch mit ISO 8859-1 und anderen, leider ohne Erfolg, die Anzeige bleibt verhunzt. Hier im Forum scheint auch niemand das Problem zu haben...
Da ich keine Lust habe, bei all meinen Files die Umlaute rauszunehmen, dachte ich mir, versuch ich's mal mit einer Anfrage hier...

Die proftpd.conf folgt im Anhang.

Wäre super, wenn Ihr mir einen hilfreichen Tipp geben könntet. UNIX Grundkenntnisse sind vorhanden...

Danke schon einmal und viele Grüße,
Stefan

P.S: hier die proftpd.conf

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
ServerName "NAS FTPD"
ServerType standalone
DefaultServer on
DefaultRoot /mnt

CharsetLocal UTF-8
CharsetRemote CP950

SystemLog /var/log/messages
Port 21
Umask 006
MaxInstances 30

User nobody
Group nobody

RequireValidShell off

receivefile on  ## This parameter is for TSS. You can fill in either "on" or "of

<IfModule mod_delay.c>
DelayEngine off
</IfModule>

UseSendfile off

AllowStoreRestart on
AllowRetrieveRestart on


ScoreboardFile /var/run/proftpd.pid

# Normally, we want files to be overwriteable.
<Directory /*>
   AllowOverwrite on
</Directory>

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

2

Mittwoch, 9. April 2008, 00:50

Schön dich bei uns begrüßen zu dürfen!

Also mit ftp aus dem cmd Fenster bekomme ich auch falsche Zeichen.
Mit fireftp (0.95.2) aus dem Firefox (2.0.0.11) klappt es allerdings bei mir.

So habe jetzt was gefunden (mit etwas externer Hilfe - Danke stonki!).
Jetzt hat es bei mir mit dem ftp aus der Dosbox funktioniert.

Prüfe bitte "CharsetRemote 850" und gib uns Feedback. Wenn es bei dir auch klappt sollten wir es ins "do_it" Paket aufnehmen.
Das deckt sich mit der Einstellung der Codepage der Dosbox (graftabl Kommando) und der proftpd Doku.

lG,
HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

Xiberger

Anfänger

Beiträge: 10

Wohnort: 82194 Gröbenzell

3

Mittwoch, 9. April 2008, 22:48

Problem gelöst!

Vielen Dank für den Willkommensgruß !

Und VIELEN Dank für den Tipp mit dem charsetremote - es tut jetzt wie eine 1!

Perfekt 8) =)

Danke noch einmal und einen schönen Abend!
Stefan

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Xiberger« (9. April 2008, 22:48)