Samstag, 25. November 2017, 10:21 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Donnerstag, 1. Mai 2008, 13:00

Kein booten nach dem Bootloader flash (Kernel panic - not syncing: No init found.)

Hallo,

ich habe mein Dual NAS per JTAG geflasht, also redboot neugeschrieben. Hat alles wunderbar geklappt, jetzt wenn ich boote habe ich folgende fehlermeldung (wird ueber den Seriellen Anschluss per HyperTerminal ausgelesen):

md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
RAMDISK: Compressed image found at block 0
RAMDISK: incomplete write (-28 != 32768 ) 16777216
invalid compressed format (err=1)
VFS: Mounted root (ext2 filesystem).
Freeing init memory: 100K
Warning: unable to open an initial console.
Kernel panic - not syncing: No init found. Try passing init= option to kernel

hier beleib es stehen und geht nicht mehr weiter.
Woran koennte es liegen? Den Dual NAS boote ich aber ohne die Festplatten, die sind vollstandig formatiert. Oder muss ich die Festplatten mit bestimmter partitionierung angeschlossen haben?

Danke fuer die Hilfe.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Satrap« (1. Mai 2008, 13:00)


HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

2

Donnerstag, 1. Mai 2008, 14:32

RE: Kein booten nach dem Bootloader flash (Kernel panic - not syncing: No init found.)

Hi,
also mit dem JTAG programmiert man nur den Bootloader neu um wieder booten und auch flashen zu können.
Dann musst du den Rest (Ramdisk, Application,...) oder ein komplettes Image über tftp laden und programmieren - siehe zahlreiche andere Beiträge.

Festplatten brauchst du zum booten keine.
Wenn die Firmware ok ist, kann man sie auch ohne Platten übers Web Interface ansprechen.
Leere Platten kann man übers Web initialisieren. Siehe Herstellerdoku.

Hwguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

3

Freitag, 2. Mai 2008, 16:52

Servus,

danke fuer die Antwort. Nun bin ich weiter. Also nach dem ^C bin ich in das menue, das naechste problem ist, das ich keine option waehlen kann. Also ich habe zum Auswahl 1 bis 6 und X, Y. Wenn ich die tasten drucke passiert nichts. Also sprich ich kann die IP nicht aendern und auch keine der anderen Punkte waehlen. Gibt es da bestimmte einstellungen oder kann es am fehlerhaften flashen liegen (wobei hier sagt mit das FlashTool dass alles ordnunggemaess geflasht wurde)?

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

4

Freitag, 2. Mai 2008, 17:07

Dass man da nix eingeben kann ist schon in einem anderen Beitrag NAS2001 - nach Firmwareupgrade kein Zugriff aufgetaucht.
Ich habe leider kein 2001er.

- Hast du das richtige redboot genommen?
- Versuche mal über telnet ranzukommen - vielleicht geht dort die Eingabe
- Wenn FlashTool sagt Verify Ok dann passt das auch und sonst würde das Teil auch nicht booten
- komisch dass keine Eingabe funktioniert - vielleicht ist da was nicht bestückt oder stimmt die Steckerbelegung nicht?

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!