Samstag, 25. November 2017, 00:47 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

1

Mittwoch, 7. Mai 2008, 18:43

gelöst: Ordner verstecken

problem: meine user sehen Dateien namens aquota.user ..... & lost+found. Das sollen sie nicht, weil die dann andauernd nachfragen: "was issn das? mit welchem player muss ich das abspielen?" und so weiter.

Lösung: Verstecken! Geht ziemlich einfach:

Nach etwas suchen auf der proftpd-Seite bin ich auf "HideFiles" gestoßen. Die unerwünschten Ordner versteckt man so:

--->

Die proftpd.conf aufrufen mit

vi /etc/proftpd.conf


Die Zeile

<Directory /home/httpd/vhosts>

suchen und folgendes in den Directory
Block unter GroupOwner eintragen:

HideFiles (bin|conf|anon_ftp|bin)$

Alle Ordner, die unter HideFiles eingetragen sind werden nicht angezeigt.

Hier sind beispielweise bin und conf eingetragen. In unserem Fall wären das nun die aquota.user und aquota.group und lost+found

Ansonsten wie gehabt: proftpd.conf ändern und danach stop/start der sh.

grüße. Snoopy

Wird wohl auch bestandteil des neuen do_it.

Kurzer Nachtrag: Die Hide Regel bezieht sich (da sie direkt unter der global group steht )konsequenter weise auf alle user, die primär dieser gruppe angehören (z.B. @guest-share) die hide befehle also sparsam verwenden, sonst sieht keiner mehr was ;)
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

2

Freitag, 18. Juli 2008, 18:48

Hi Snoopy,
da ich noch recht unerfahren unter Linux bin kann ich die Zeile: <Directory /home/httpd/vhosts>
leider nicht gleich auf mein IB-NAS 2000 (2.3.2.IB.2.RS.1) umsetzten.

In meiner /system/hddapp/etc/proftpd.conf gibt es den Eintrag : <Directory /home/httpd/vhosts>
leider nicht. Das fängt bei mir an mit :


# Normally, we want files to be overwriteable.
<Directory /*>
...AllowOverwrite on
</Directory>

<Directory /mnt/IDE1/admin>
..<Limit DIRS READ WRITE>
...DenyAll
..</Limit>
..<Limit DIRS READ WRITE>
...AllowUser admin
..</Limit>
</Directory>

....... usw usw .. (halt die ganzen Order & User die ich bisher angelegt habe)
Für Euch ist das ggf ein leichtes das Beispiel auf Euer System anzuwenden. Aber nicht für einen Nicht-Linux-Fachmann :D
(Group-Owner hab ich nicht gefunden :( )

.. Gruß .. Twix ..
mv dau /dev/null

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

3

Freitag, 18. Juli 2008, 19:22

Moin,

jut, das Beispiel ist wohl etwas irreführend, aber die Lösung steht trotzdem schon im Beitrag, so zwischen den Zeilen.

Also:

es ist möglich in bestimmten Verzeichnissen (z.B. <Directory /mnt/IDE1/admin> ) Ordner und Dateien zu verstecken, dann den Eintrag: HideFiles (aquota.user|aquota.group|lost+found)$ unter diesem Platzieren

und es ist möglich diese in allen Verzeichnissen zu verstecken, dann eben einfach den Eintrag wie oben unter <Directory /*>platzieren. Das ist die globale Lösung ... siehe erster Beitrag.

ACHTUNG, das Beispiel versteckt aquota.user|aquota.group|lost+found. Wenn es andere sein sollen entsprechend ändern!

Und noch ein Hinweis: Wie bekannt werden diese Teile der conf beim reboot neu geschrieben (sausalito) also bitte den Prozess stoppen und starten - nicht die Box. ;)

Greetz. Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

4

Montag, 21. Juli 2008, 09:35

... ich gehe davon aus, das Problem ist gelöst :thumbsup: und schließe den Threat wieder.

Greetz. Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

5

Montag, 21. Juli 2008, 15:30

Hi

ich habe versucht mich schlau zu machen. Auf der Seite http://www.proftpd.org/docs/ & google etc, findet man
recht viel zum ProFtpd, denn mit der Eintragung "HideFiles (aquota.user|aquota.group|lost+found)$" sind zwar
die 2 Dateien versteckt, aber nicht der Ordner lost+found..

Da ich mit den Ausdrücken von Linux noch nicht so auskenne dacht ich das ggf ein "//" davor muß?
Also HideFiles (aquota.user|aquota.group|//lost+found)$ ...

Da ich ein bischen vorsichtig bei sowas bin hab ich es noch nicht ausprobiert. Falls man den ProFTPD über die *.conf
(ich mach das alles über die do_it) kaputt patchen würde, käme man immer noch als root auf die Box?

.. Gruß .. Twix ..
mv dau /dev/null

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Twix« (21. Juli 2008, 15:37)


snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

6

Montag, 21. Juli 2008, 16:27

Genau, da kannst Du gar nix verkehrt machen, zumal ja Smba auch noch einen komfortablen zugang zum public ordner bereit hält.

Und als root sowiso. Also feuer frei und mal testen.... aber nicht Deinen vorschlag mit // oder \\ sondern mal versuchen mit HideDir (für Directory)

Ansonsten, ich weiß ja net, was Du vor hast, folgendes gefunden (ja, ja, die google Suche ;) ) :

How can I hide a directory from anonymous clients.
Use the HideUser or HideGroup directive in combination with the proper user/group ownership on the directive. For example, if you have the follow directory in your anonymous ftp directory tree: drwxrwxr-x 3 ftp staff 6144 Apr 21 16:40 private
You can use a directive such as "HideGroup staff" to hide the private directory from a directory listing. For example: <Anonymous ~ftp> ... <Directory Private> HideGroup staff </Directory> ... </Anonymous>
und das hier:
DirFakeGroup -- Hide real file/directory group DirFakeMode -- Hide real file/directory permissions


und das hier: HiddenStor -- Enables more safe file uploadsHiddenStores -- FIXFIXFIXHideFiles -- Enable hiding of files based on regular expressionsHideGroup -- Enable hiding of files based on group ownerHideNoAccess -- Block the listing of directory entries to which the user has no access permissionsHideUser -- FIXME FIXME

Aber wie gesagt, versuche es erstmal mit HideDir ;)

Greetz. Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

7

Montag, 21. Juli 2008, 16:57

Hi, muss auch mal meinen Senf dazugeben...

Mit dem proftpd.conf kannst du ruhig herumspielen. Im schlimmsten Fall geht halt ftp nicht mehr.
Solange du eine Putty-ssh oder winscp Verbindung hast, kannst du nach belieben testen und umkonfigurieren.
Du musst die Kiste auch nicht immer neu starten sondern den ftp Server kann man über die Konsole neu starten:

Quellcode

1
usr/hddapp/etc/rc.d/S91proftpd.sh restart
stop und start ist auch möglich

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

8

Montag, 21. Juli 2008, 17:10

;)


typischerweise wird ja nur der globale teil der proftpd.conf übernommen, der <Directory/*.....> Teil (alles unter dem Eintrag "normally we want ...overwriteable") wird beim reboot überschrieben. Das gilt allerdings NICHT für die zusätzlichen Einträge Hide***.

Um auf nummer sicher zu gehen kannst Du natürlich den ftp server händisch neu starten, mit dem befehl den HWGuru eben liebenswerter weise gepostet hat, dann sollte alles so "stehen bleiben" in der conf unter etc/hddapp

Greetz. Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)