Dienstag, 21. November 2017, 03:17 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

irootsk

Anfänger

Beiträge: 20

Wohnort: Slovakia

1

Montag, 2. Juni 2008, 22:39

NAS1000 & WakeOnLan

Hi guys.

Few days ago i bought new NAS1000. but i found out that there is missing WakeOnLAN function. So if we have power outage, after electricity is again ok, NAS wouldn't start. You have to pres button. So i am at work, i am not able to start server on NAS.
Is there any way how to enable WOL? I've got a router Linksys WRT54G with DD-WRT firmware and there is an option to manualy wake up some devices. You need MAC, IP and port number.
So do you have any ideas?
Thank you ;)

Brano
IcyBox NAS1000 revision B, FW 2.3.2.IB.2.RS.1, 500GB U-ATA - ext3

I have to say big THANK YOU to HWguru for his patiance with me :thumbup:

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

2

Montag, 2. Juni 2008, 22:56

Hello Brano, welcome to the forum!

Sorry, there is no wake on lan functionality.
If there has been a power failure the nas hardware is switched off and therefore the CPU has no power and cannot be woken up.

But have a look at our wiki please. You will find an automatic power on circuit there.

Regards, HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

irootsk

Anfänger

Beiträge: 20

Wohnort: Slovakia

3

Montag, 2. Juni 2008, 23:19

Thank you Guru for quick response and for link. That looks realy simple.
It's shame that RaidSonic din't do NAS with WoL.
Ok, if there is power cut, than CPU is without power. But what if you remotely swich off the server?
Can you start server again? I tried that with my router, but i wont work.
IcyBox NAS1000 revision B, FW 2.3.2.IB.2.RS.1, 500GB U-ATA - ext3

I have to say big THANK YOU to HWguru for his patiance with me :thumbup:

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

4

Montag, 2. Juni 2008, 23:30

Hi, if you turn it off remotely you have a problem ;)
Turn off means power off. You will have to press the on button!
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

irootsk

Anfänger

Beiträge: 20

Wohnort: Slovakia

5

Montag, 2. Juni 2008, 23:36

Hm, but why was yellow LED (NAS) still lighting if power was down? :?:
IcyBox NAS1000 revision B, FW 2.3.2.IB.2.RS.1, 500GB U-ATA - ext3

I have to say big THANK YOU to HWguru for his patiance with me :thumbup:

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

6

Montag, 2. Juni 2008, 23:51

If you turn it off remotely or with the button HDD is stopped first and some seconds later the box is turned off completely.
At least my NAS1000 hardware is doing so...

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

irootsk

Anfänger

Beiträge: 20

Wohnort: Slovakia

7

Dienstag, 3. Juni 2008, 00:06

Anyway thanks for info. I've got one week off from work so i can play with it. Hopefuly the power swich will work.
IcyBox NAS1000 revision B, FW 2.3.2.IB.2.RS.1, 500GB U-ATA - ext3

I have to say big THANK YOU to HWguru for his patiance with me :thumbup:

irootsk

Anfänger

Beiträge: 20

Wohnort: Slovakia

8

Dienstag, 3. Juni 2008, 11:42

I tried to turn OFF server remotely again. Server was OFF but NAS LED was still ON. Only after i pressed the power buton, NAS LED start flashing and after few seconds turned OFF completly. Only power indicator was still ON.
So are you sure, your NAS1000 is completly down after you turn OFF server remotely?

Which firmware do you use? Now I've got FW2.3.2.IB.2.RS.1
IcyBox NAS1000 revision B, FW 2.3.2.IB.2.RS.1, 500GB U-ATA - ext3

I have to say big THANK YOU to HWguru for his patiance with me :thumbup:

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

9

Dienstag, 3. Juni 2008, 12:07

Hi,
firmware is Ok! Regarding your question in the PN: You could install the do_it package at your NAS and run the root password hack to get access again. I think in the message you find the hash value for the standard root password.

It may happen that the shoutdown routine does not finish because of some locked file or process on the NAS.
That matches your description.
If you press the button it only takes some seconds for turn off. First the button creates an event for the kernel/firmware which does the shutdown. If the software does not respond hardware is switched off after some delay (about 30sec).

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!