Mittwoch, 22. November 2017, 19:34 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Montag, 30. Juni 2008, 00:18

[gelöst] Fehlermeldung beim Flashen

Hallo zusammen,

ich habe mich einmal quer durchs Forum gelesen und versuche gerade Tinky in der aktuellsten Version auf mein Nas 2000 zu bekommen. Ich habe mit dem TFTP-Server die Datei hochgeladen, bin über Hyperterminal verbunden, der Flash wird gelöscht, programmiert und im Anschluss validiert (vermute ich - da steht nach einem Punkt immer ein V). Irgendwann bricht das ganze mit einer Fehlermeldung ab. So sieht das Log im Terminal aus:

.V.V.V.V.V.V.V.V.V.V.V.V.V..V.
FAILED!
Can't program region at 0x70e20000: Unknown error
Erase flash ...
... Erase from 0x70000000-0x70e26800: ..........................................
................................................................................
................................................................................
.........................
OK!
... Program from 0x01000000-0x01e26800 at 0x70000000: ..........................
................................................................................
......................V.

Und danach geht es wieder von vorne los. Ich habe die Befürchtung, wenn ich alle vom Strom abklemme, ist die Kiste hinüber.

Hat jemand eine Idee, was ich tun kann? Noch hängt alles in dieser Endlosschleife...

Gruß

Tom

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

2

Montag, 30. Juni 2008, 00:41

Hi, das habe ich noch nicht gesehen :-(

Wenn das immer wieder passiert, fürchte ich dass man da nicht eingreifen kann.
Solange der Bootloader noch lebt ist alles Ok.

Wenn nicht, dann muss JTAG her!
Hat deine Hardware bis jetzt zuverlässig funktioniert?

lG, HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

3

Montag, 30. Juni 2008, 07:53

Bisher lief alles ohne Probleme - bis auf die leidige Uploadbremse, die ich mit Tinky endlich lösen wollte. Aber leider...

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

4

Montag, 30. Juni 2008, 08:23

Sag, was wolltest du in das Flash reinladen?
Hast du da nicht eine falsche Datei erwischt?
Kontrolliere das noch einmal. Hier ist ein Beitrag der beschreibt wie man es macht.

Das V bedeutet verify Fehler. Also beim prüfen ob der Inhalt auch wirklich im Flash steht.

Und wenn ich den Bereich 0x70000000-0x70e26800 hernehme, sind das mehr als 14MB (0xe26800 = 14837760 = 14490k = 14,15MB) obwohl das gesamte Flash ja nur 8MB groß ist ?(

lg HWguru

P.S. wenn du die ftp Uploadbremse meinst, ließe sich das mit der Originalfirmware auch lösen
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

5

Montag, 30. Juni 2008, 09:56

Ich Idiot!
Ich befürchte, ich habe einen typischen Linux-Anfängerfehler gemacht. Gebt mir ein Brett, das ich mir gegen den Kopf schlagen kann.

Ich habe aus dem Downloadbereich die tinky-2_3_2-mu-02.2.tar komplett rübergeschoben. Wäre es ein Zip- oder Rar-File gewesen, wäre mir das nicht passiert. Boahh! Ich nehme an, ich brauche nur aus dem Archiv einen bestimmte Datei. Richtig? Leider sitze ich momentan nicht an meinem Rechner, um direkt mal nachzuschaun, welche Datei benötigt wird. Das mache ich heute Abend direkt.

Grundsätzlich bin ich die Firmwareänderung nur wegen der Uploadbremse angegangen. Ich habe alle Einstellungen aus den Threads (incl. Install der do_it für FTP und SAMBA) vorgenommen, MTU-Patch installiert, was alles nur eine Steigerung aus dem Byte-Bereich in KByte-Bereich gebracht hat. Ich habe hier einen 10MBit-Upload und bekomme bei einer Einzelverbindung nur 5kb hin. Die MTU ist ausgemessen und für meinen Provider korrekt auf 1492 eingestellt. Die Rechner, von denen aus ich das probiert habe, waren alle im Netz des gleichen Providers...

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

6

Montag, 30. Juni 2008, 10:26

Ja, du brauchst "Ramdisk" und "Application".
Nach welcher Anleitung bist du denn vorgegangen? Dort sollten wir vielleicht eine Warnung anbringen!

Im tinky-2_3_2-mu-02.2.tgz sind die Dateien und ein Readme drinnen.

Hoffentlich lebt der bootloader noch!

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

7

Montag, 30. Juni 2008, 11:24

Ich habe nichts vom Netz genommen. Alles läuft noch. Nach 3maligem Flashversucht bricht alles ab und im Hyperterminalfenster steht wieder das Hauptmenü.Von da aus könnte ich den Bootloader jederzeit wieder zurückflashen, oder!?

Ich würde als erstes nochmal die aktuellste Firmware von Raidsonic auf die gleiche Art flashen. Dann wäre ich doch bestimmt auf der sicheren Seite, wieder einen funktionierenden Bootloader zu haben. Und danach das ganze nochmal von vorne - eben nur die ramdisk und die application ersetzen.

Ich bin nicht konkret nach einer Anleitung vorgegangen. Was mich irretiert hat, war die Tatsache, dass die Zusatzapplikationen von Raidsonic als tar-File in ...\new_software zu kopieren waren und von dort aus beim Reboot entpackt/installiert wurden. Also habe ich nicht weiter darüber nachgedacht und das gleiche mit der Firmware gemacht. Mir ist klar, tar-Files sind linuxspezifisch. Wachgerüttelt hätte mich aber eher ein rar- oder zip-File. Bei denen wäre ich nicht auf die Idee gekommen, sie gepackt rüberzuschieben.

Welche Vorteile hat eigentlich die Tinky-Software gegenüber der Standardfirmware genau? (außer einem saubereren Quellcode) Mir war nur der vernünftige Upload wichtig...

Tom

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

8

Montag, 30. Juni 2008, 11:59

Ja, prinzipiell geht das.

ABER: zur Zeit gibt es online kein aktuelles Image der Raidsonic Firmware zu direkten Flashen.
Ein solches Image muss exakt 8MB groß sein. Es gibt nur die ältere für das Update von 1.x auf 2.x wo du dann Ramdisk und Appliaktion noch aktualisieren musst.

Aber ich habe eines zum Download bereitgestellt. Es hat die MAC Adresse 00 14 7d 00 00 00 die du dann wieder auf deine umsetzten musst.

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

9

Montag, 30. Juni 2008, 12:15

Ok. Also verstehe ich das so richtig? Ich update mit der Version von 1.x auf 2.x, was den Bootloader überschreibt (falls der überhaupt kaputt ist) und aktualisiere anschließend Ramdisk und Applikation aus der Tinky-Firmware?


Edit: Müsste eigentlich ja dann auch mit der Rücksicherung der Ramdisk und Applikation funktionieren...

Ich lese in Deinem Footer gerade "Lüfterabschaltung". Ist es möglich den Lüfter parallel zum Spin-Down der Platte zu schalten?


Tom

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »TomMcDuck« (30. Juni 2008, 12:21)


HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

10

Montag, 30. Juni 2008, 12:21

Ja, richtig.
Jetzt warst du schneller. Ich habe meinen vorigen Beitrag editiert...

Es könnte sein, dass der Bootloader im Flash gelöscht ist und das Ding bei einem Reboot nicht mehr startet.
Also wäre das Ersetzten des ganzen Flashes über die Option X ratsam.

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

11

Montag, 30. Juni 2008, 12:28

Ok. Ich werde das heute Abend ausprobieren - sollte ja zu schaffen sein.


Tom

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »TomMcDuck« (30. Juni 2008, 15:32)


12

Montag, 30. Juni 2008, 19:32

Prima! Die Box läuft wieder. Danke!

Nur dieser dämliche Upload will nicht. Der kleckert nach wie vor bei 5kb/s


In Hyperterminal sieht das Log an der Stelle eigenartig aus. Zugriff verweitert? Ich habe die do_it.tar von HWGuru installiert.

found some init scripts
running: ./webserver/init
running: ./streamripper-app/init
running: ./mtu_change/init
running: ./do_it/init
/etc/rc.pkg.start: 59: ././do_it/init: Permission denied
done
Starting syslogd...
Starting inetd...
Starting crond...


Tom

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »TomMcDuck« (30. Juni 2008, 19:47)


HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

13

Montag, 30. Juni 2008, 20:05

Hi, super dass es wieder läuft!

Für neue Fragen bitte ein neues Thema öffnen damit kein Chaos entsteht ;)

Zu dem neuen Thema geht es hier.

lG HWguru

P.S. geschlossen, weil gelöst
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!