Samstag, 25. November 2017, 12:22 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

irootsk

Anfänger

Beiträge: 20

Wohnort: Slovakia

1

Dienstag, 8. Juli 2008, 23:49

Connection problem with IB-NAS1000

Hi guys,

i am having another troble with my system.
I am unable to connect to my system from internet via FTP and SSH.
From LAN is everything work normal.
If i want to connect via SSH i'll receive error message:"Server unexpectedly closed network connectiion."
Connection via FTP is similiar :"Connect call failed."
Firewall is down. Port forwarding is set up correctly.
I can connect to my router via ssh(with different port number), so i thing problem must be somewhere on my NAS.
Only accessible place is Web GUI interface.
Any ideas?
If i do factory reset, do i lose all my data stored on HDD or only system settings?
Thanks a lot.

Brano

PS: i tried to use older config file, but no progress. So maybe i have to back up all my data and do firmware upgrade. :S
IcyBox NAS1000 revision B, FW 2.3.2.IB.2.RS.1, 500GB U-ATA - ext3

I have to say big THANK YOU to HWguru for his patiance with me :thumbup:

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »irootsk« (9. Juli 2008, 01:18)


HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

2

Mittwoch, 9. Juli 2008, 08:09

Hello Brano!

I don't think it is a problem with NAS1000. For the NAS there is no difference if it is accessed locally or through the Internet.
Although I have no solution in my pocket :(
How is your network setup exactly?
Modem (+firewall) - Wlan Router (+firewall +switch) - Switch - NAS (That's my setup): in that case you have to set port forwarding on Modem to Router IP and on Router to NAS IP.

Try using a network sniffng tool likeWireshark for checking if your NAS gets accessed through network.
You may use web2ftp for ftp tests from within your interent browser.

Your system uses most recent firmware version, so upgrade will not help. Don't do a factory reset, you may loose your data.

But you could try any old disk and set up a new system there. Then you have a fresh system because all settings are stored on disk. There is nothing stored in flash memory. So, if you plug in your old disk, everything is back again.

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

irootsk

Anfänger

Beiträge: 20

Wohnort: Slovakia

3

Mittwoch, 9. Juli 2008, 08:59

It was working normaly, i could access it from internet without any trouble. but one week ago it's changed.
I am ubable to connect to system from internet. Only Web interface is accessible.

Network configuration is:

Cable modem(without firewall) =>wirelles router (Linksys wrt54gl - firewall is off) with 4port LAN swich => NAS
NAS is open to internet in DMZ.
I've got also set up portforwarding.
Config is same as it was before, when everything worked ok.

I'll try wireshark later, need to get some sleep after night shift :sleeping:
Anyway thaks so far ;)
IcyBox NAS1000 revision B, FW 2.3.2.IB.2.RS.1, 500GB U-ATA - ext3

I have to say big THANK YOU to HWguru for his patiance with me :thumbup:

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

4

Mittwoch, 9. Juli 2008, 09:22

Ahh, interesting that it was working normally before.

Silly question: has the IP address of your NAS changed?
Your IP seems to be correct because you can access the Web interface.
ftp "Connect call failed." is no message coming from the NAS I think.

P.S. don't put your NAS in DMZ! A lot of people will try to hack it ;( Change your root password to a good one!
If you send me your IP (Skype?) I can try to log in with ftp.

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

irootsk

Anfänger

Beiträge: 20

Wohnort: Slovakia

5

Mittwoch, 9. Juli 2008, 20:59

As HWguru already know, we managed to run SHH but still no FTP.
The solution was simple. My fault - of course :rolleyes:
Few days ago i was trying to get better connection for skype, so i setup Port range forwarding for Skype on ports 0 to 65000.
And than i forgot to remove it. So all SSH atempts was routed to my notebook.
Now SSH fork fine, but there is still problem with FTP.
Port forwarding is now set up correctly. All firewalls are off.
I can establish connection from LAN but not from internet.
Any ideas? ;)
IcyBox NAS1000 revision B, FW 2.3.2.IB.2.RS.1, 500GB U-ATA - ext3

I have to say big THANK YOU to HWguru for his patiance with me :thumbup: