Freitag, 24. November 2017, 21:35 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Montag, 21. Juli 2008, 21:32

nfs mount (automounter von dbox2) dauert beim ersten Mal 20sek.

kann jemand von euch ein nfs-share per tcp mounten? bei mir gehts nur per udp. sobald ich in den mountoptionen tcp drin habe, wird nicht gemountet..... ?(
ebenso dauert ein nfs-mount (automounter von dbox2) bei mir 20sek. das ist doch sehr langsam. sobald das verzeichnis einmal gemountet ist und der timeout des automounters noch nicht gegriffen hat (und somit das verzeichnis noch nicht ungemounted wurde), geht dann jeder weitere zugriff unterhalb einer sekunde.
aber normalerweise müßte das mounten an sich doch schneller gehen, oder nicht??

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

2

Mittwoch, 23. Juli 2008, 08:21

Hallo jimpoison,
sag uns doch noch etwas über dein System oder lege dir eine Signatur zu.

Steht was in den Logfiles?
Funktioniert das Mounten woanders hin schnell?
Sieht man am Netzwerkverkehr etwas Ungewöhnliches. Wenn du zB mit Wireshark mitlauscht sieht man eventuell an an den Timestamps wer da so lange braucht.

Ich habe leider keine dbox und nutze nfs nicht. :(
lG HWguru

P.S. ich habe den Beitrag abgetrennt, weil das zum Vorigen nicht mehr so richtig passt
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

3

Mittwoch, 23. Juli 2008, 15:50

also ich habe das nas2000 mit der neuesten originalfirmware. jeder nfs-mount auf der icybox dauert 20sek. von der dbox auf andere nfs-server läuft alles normal innerhalb weniger sekunden. ebenso laufen cifs-mounts auf der icybox zügig.
wirklich das einzige, was lange dauert, sind nfs-mounts auf der icybox. in den logfiles der icybox und auch der dbox ist nicht auffälliges zu sehen....
an der dbox kanns nicht liegen, da bei einer zweiten dbox das gleiche problem auftritt. alle anderen mounts von der dbox auf die icybox außer nfs laufen normal.

wie kann ich denn wireshark für den netzwerkverkehr zwischen nas und dbox einsetzen (sind über router miteinander verbunden)? müßte man da nicht wireshark auf dem nas oder der dbox installieren? wenn ja, wie?

kann man auf dem nas evtl. einstellungen für nfs ändern, ähnlich wie für ftp bei der proftpd.conf oder für samba in der smb.conf? hab da nichts in der richtung gefunden

4

Mittwoch, 23. Juli 2008, 16:14

Ich mounte per NFS ein Share mit meiner Dreambox und kann mir nur vorstellen daß die 20 Sek evtl. durch das Anlaufen der "schlafenden" Platte kommen.

5

Mittwoch, 23. Juli 2008, 16:27

nee das ist es definitiv nicht. es dauert ebenso lange, wenn die platte bereits auf vollen touren läuft.
interessant in dem zusammenhang: wenn die platte schläft und ein verzeichnis gemountet wird, passiert erstmal 20sek lang gar nichts und dann hört man wie die platte anläuft und dann nach weiteren 5sek das verzeichnis da ist.
also man hat immer diese 20sek denkpause bei nfs....warum auch immer

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

6

Mittwoch, 23. Juli 2008, 16:39

Wireshark: ja, da hast du recht. Ich habe für solche Zwecke einen alten Hub. Da kann ich dann parallel mithorchen.
Manche Switches oder Router kann man umkonfigurieren.

zur Konfig: gute Frage - das Skript zum starten/stoppen ist S85nfs.sh unter /usr/hddapp/etc/rc.d
Damit habe ich mich noch nicht auseinender gesetzt. Was sagt denn Google dazu?

Nä Woche habe ich wieder etwas mehr Zeit...

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

7

Mittwoch, 23. Juli 2008, 17:28

@Jimpoisen

Was für ein Image hast Du auf der DBox?
Bitte poste mal deine Mount Optionen der DBox ..

.. Gruß .. Twix ..

P.s. Bei mir wird nur bei Bedarf gemountet und es dauert dann 2sec bis die Aufnahme beginnt.
mv dau /dev/null

8

Donnerstag, 24. Juli 2008, 01:19

im momnet hab ich das aktuelle novatux-image drauf vom developer dbt.
wollte das ganze morgen nochmal mit nem jtg.image testen.

also bei den mountoptionen hab ich eigentlich nur die standardsaachen drin:
rw,udp,nolock,async,soft,rsize=8192,wsize=32768

habe aber auch schon mit verschiedenen rsizes und wsizes getestet, ebenso mit und ohne async, rw und ro.
ändert aber alles nix. fehler ist immer der gleiche

9

Dienstag, 29. Juli 2008, 23:33

so nach mehrmaligem zurücksetzen auf werkseinstellungen (sowohl im webif als auch per reset-knopf) und formatieren der festplatte hab ich die verzögerung jetzt dauerhaft auf 10sek reduzieren können. nachdem ich da jetzt schon fast ne woche jeden abend dran rum gebastelt habe und so langsam auch keinen bock mehr habe, kann ich damit leben und werds erstmal so lassen.
wenn die box ganz jungfräulich ist klappt der mount sogar in unter einer sekunde, aber spätestens wenn ich mal alle meine einstellungen wieder komplett habe sinds wieder 10sek.
bin schon alle einstellungen einzeln durchgegangen, aber das läßt sich nicht auf eine bestimmte festlegen. es tritt jedesmal (nach erneutem reset) nach einer anderen änderung einer einstellung auf.
nach gefühlten 1000 resets reichts mir jetzt aber auch langsam.....
wenn da jetzt keiner mehr ein patentrezept hat werd ichs dauerhaft so lassen, immerhin hat sich die wartezeit schon halbiert :D

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

10

Freitag, 1. August 2008, 15:21

Moin,

hab den threat verfolgt und sehe hier den fehler ausnahmsweise 8) mal nicht nur beim NAS sondern auch bei der DBox. Warum? Schreibst Du quasi schon selbst. wenn die platte im NAS schläft dauert es die 20 Sek. bis zum Anlaufen. Nun habe ich selbst (noch) keine DBox, aber eben mal in ein paar der diversen DBOX Foren geschaut und erkenne hier eine Art Handshake-Prozedur zwischen Box und NAS. Bitte selbst mal googeln zum Nachlesen. Die kann man beiderseits (NFS conf auf dem NAS und conf auf der DBOX - läuft ja auch nur ein Linux drauf) auf das nötigste Beschränken, weil ja beide im lokalen Netzwerk. Dazu mal nach den confs suchen, anschauen und am besten mal eben posten. Solche Einträge wie lookup, ident o.ä. sind m.E. die echten Zeitfresser.

Greetz. Snoopy

:coffee:
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

11

Freitag, 1. August 2008, 19:49

das problem ist, daß die sache bei anderen mit gleichem bzw. sehr ähnlichem nas (icybox nas4220) und auch mit dbox einwandfrei funktioniert. wenns dich weiter interessiert, leg ich dir auch mal diesen thread http://tuxbox-forum.dreambox-fan.de/foru…php?f=2&t=48062 (ich hab da den gleichen usernamen wie hier) aus dem wenn man so will offiziellen dbox-linux-forum ans herz, wo ich mein problem zuerst geschildert habe und wo man auch sehen kann, was ich schon alles versucht habe. und das war einiges.... :D bloß ohne erfolg ;(

da sieht man auch, daß ich schon alle möglichen konfigurationen durch habe. aber die möglcihkeiten, da groß was an den einstellungen zu verändern, sind auch sowohl auf dem nas als auch auf der dbox beschränkt. bei der dbox zum beispiel kann man eigentlich nur an den mountoptionen was drehen, und da hab ich wirklich schon alles durch.

und beim nas gibts ja anscheinend nicht so ne conf-datei wie für proftpd oder smb. da hab ich mich an der exports versucht, aber auch da bringen alle versuche das gleiche ergebnis: nämlich keins!

egal ob mit so wenig oder so viel optionen wie möglich gemountet wird oder welche paramter auch immer man verwendet, es dauert beim erstmaligen mount immer 10sek. ich bin ja schon sehr froh, daß es inzwischen nur 10sek sind, war ja am anfang das doppelte. da ich das durch reset des nas hinbekommen habe, war ich davon ausgegangen, daß der fehler auch nur beim nas liegt und das ich die anderen 10sek auch noch irgendwie beseitigen könnte. sah ja auch erst so aus (wenn das nas ganz jungfräulcih ist und man nur nfs konfiguriert. aber wenn man dann mal alles wieder einrichtet, kommt immer irgendwann der punkt, ab dem es wieder 10sek dauert. dieser punkt läßt sich aber leider nicht auf eine bestimmte einstellung festlegen, er scheint willkürlich bzw. immer bei ner anderen einstellungsänderung zu kommen

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

12

Freitag, 1. August 2008, 22:49

Hi,

nun, erstmal hut ab, Du hast zumindest schon mal einiges versucht und Dich belesen. (Kann man leider nicht immer voraussetzen, dehalb von mir die google-tipps). Mir fällt dazu (ohne in die Tiefe zu gehen und zu testen und dazu fehlt - wie gesagt noch die Dbox ... noch :D ) eigentlich nur noch der IP Bereich ein, den Du einstellen kannst am NAS (ich denke mal da hast DU auch schon alles, inkl. dem ALLOW FOR ALL Häckchen ausprobiert) oder eben der Router an dem die "Käschtle" hängen.

Eine Frage am rande: ist die DBox via Kabel oder ohne im Netz?

Greetz Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

13

Samstag, 2. August 2008, 07:30

also ja, das mit dem allow for all hatte ich auch schon ausprobiert.....hat natürlich auch nix gebracht

also ich habe sogar 2 dboxen. eine hängt per kabel am router (an dem auch die icybox hängt) und die andere dbox per dlan (also übers stromnetz).

ist auch bei beiden gleich mit den 10sek. den router würde ich als fehlerquelle ausschließen, da ich eine der dboxen auch schonmal direkt mit nem crossoverkabel mit der icybox verbunden hatte, aber du ahnst es schon: es kam das gleiche bei raus. ich seh auch gerade in deiner signatur, daß wir wohl den gleichen router haben (di524)

deswegen fällt mit inzwischen nix mehr ein......aber wissen, woran es liegt, würde ich dennoch gerne (besonders da es bei anderen mit der gleichen konfiguration zu funktionieren scheint)

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

14

Samstag, 2. August 2008, 08:53

Hi, mische mich auch wieder mal ein.
Ich komme wieder auf die Mitschnüffel Geschichte zurück.
Da das mit einem Switch nicht geht könntest du ja die 2 Geräte wieder über ein X-over Kabel verbinden, dann kannst du am Netzwerk mitschauen.
Vielleicht sieht man ja was.
In den Logfiles unter /var/log ist nichts Auffälliges zu sehen?
Interessant ist aber die Tatsache dass das mit einem "frischen" NAS geht. Also muss es doch mit der Konfiguration zusammenhängen. Der Punkt ab dem es nicht mehr schnell ist lässt sich nicht eingrenzen?

Das lösen wir auch noch,
HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

15

Samstag, 2. August 2008, 11:03

Da das mit einem Switch nicht geht könntest du ja die 2 Geräte wieder über ein X-over Kabel verbinden, dann kannst du am Netzwerk mitschauen.
Vielleicht sieht man ja was.


wie meinst du das genau mit der verkabelung? wenn ich dbox und icybox über crossover miteinander verbinde habe ich ja wieder das problem, wo ich wireshark installieren soll...


Zitat

In den Logfiles unter /var/log ist nichts Auffälliges zu sehen?


das mit den logfiles muß ichmal probieren, wußte nicht, daß man unter var/log auch logfiles findet, ich dachte die im webinterface wären die einzigen...


Zitat

Interessant ist aber die Tatsache dass das mit einem "frischen" NAS geht. Also muss es doch mit der Konfiguration zusammenhängen. Der Punkt ab dem es nicht mehr schnell ist lässt sich nicht eingrenzen?


wie gesagt, es trat bisher jedes mal an einer anderen stelle auf. einmal nachdem ich den ntp-server geändert habe, einmal beim anlegen eines samba-shares, einmal beim hinzufügen einer weiteren ip-adresse des nfs-shares, usw. also ziemlich willkürlich, kann da kein muster erkennen

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

16

Samstag, 2. August 2008, 11:51

Ähm, ich hätte wohl erst auf die Wirkung des Kaffees warten sollen :coffee:, bevor ich den Beitrag geschrieben habe.
Sorry :worthy:, so geht es natürlich nicht!
Ich hatte meine NAS/PC debug sessions im Kopf. Also NAS - PC. Aber bei dir bräuchten wir doch einen Hub.
Horche dich mal um. Vielleicht hat ja jemand so ein altes Teil für dich.
Der Wireshark läuft natürlich auf dem PC.

Die Web Oberfläche zeigt auch nicht alles aus den Logfiles an. Die werden etwas gefiltert.
Wie is den das bei der Dbox? Da muss es doch auch Logfiles geben.

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

17

Samstag, 2. August 2008, 12:09

vielleicht installiere ich mir mal nen nfs-client auf meinem pc, mounte dann mal was auf dem nas und gucke dann mal mit wireshark (wenn ich das hinkriege).

kann jemand einen einfach zu bedienenden nfs-client empfehlen (am besten freeware), der auch unter vista läuft?

bei der dbox kann man schön die telnet-console mitloggen lassen und da wird einem wirklich alles angezeigt. bloß in dieser 10sek-wartepause zeigt das dbox log auch nix an. erst den mountbefehl, dann 10sek nix und dann die meldung über das erfolgreiche mounten., aber keine fehlermeldung oder so.....

werde mir erstmal die ausgaben in var/log auf dem nas anschauen

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

18

Samstag, 2. August 2008, 12:35

vielleicht installiere ich mir mal nen nfs-client auf meinem pc, mounte dann mal was auf dem nas und gucke dann mal mit wireshark (wenn ich das hinkriege).
Das wäre sicher interessant. Wenns aber dann wieder läuft hilft es nichts.
Eine Möglichkeit wäre vielleicht eine Linux Boot CD. zB bei "Backtrack" ist auch bereits Wireshark mit dabei. Wie gut man dann aber von der Dbox mounten kann, weiß ich leider nicht.

Habe gerade im Netz gesucht und ein "NFS troubleshooting" gefunden.
Die meinen es könnte mit den Nameservern zu tun haben - schau mal in /etc/resolv.conf

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

19

Samstag, 2. August 2008, 14:44

so, ich hab das ganze hier mal nach gestellt...

NAS2000 mit Tinky
Dbox2 Nokia2I mit frisch geflashter JTG vom Juni ohne aktuellen Snapshot....

Ohne Mountparameter dauert es bei mir auch unsäglich lang, bis die Freigabe gemountet wird...

aber als ich alle optionen angegeben hab, die du auch aufgeführt hast, ging es selbst nach nem reboot unter 1sec

folgendes hab ich gemacht:

Quellcode

1
mount -t nfs --rw --udp --nolock --async --soft --rsize=8192 --wsize=32768 192.168.0.60:/mnt/IDE1/filme /mnt/hdd/


Rennt einwandfrei!
...and eternity, my friend, is a long fucking time!

20

Samstag, 2. August 2008, 21:34

Anderes Image probieren

Hi Leute,

bei meiner box ghet alles sehr schnell, die shares liegen auf der nas, ich trage die mounts in die box ein und mounte ueber die box das dauert keine 10 sec., habe das MD Image 5.30 drauf.

meine mount settings:
(nfs mount!!!)


rw,soft,udp,sync
nolock,rsize=16384,wsize=16384


mfg BadRat :beer: :happy:
Hardware Name IB-NAS 1000 Platform / IB-NAS 2000
Firmware Version 2.3.2-mu-02.2 (Tinky)
Hardware Version Rev. B
* und alles an:):)*