Sonntag, 19. November 2017, 20:41 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Mittwoch, 10. September 2008, 23:17

NAS 4220 & NAS 2000 Downloads über FTP / Internet sind Defekt

Hallo Leute,

ich habe mir die NAS-4220 gekauft und zuhause eingerichtet.

Habe aber das Problem wenn ich was von der Box per FTP Downloade sind die Dateien alle Defekt.

Downloads mit LeechFTP & Explorer sind Defekt. Wenn ich mit SmartFTP Downloade sind die Dateien OK.

Ich Arbeite schon Seit Jahren mit LeechFTP und hatte noch nie Probleme.
Wenn ich über Netzwerk die Dateien öffne sind diese alle OK.

Wurde auch an 5 weiteren Rechnern getestet und überall die gleichen Fehler.


Kennt jemand dieses Problem und hat jemand vielleicht eine Lösung?

Bei meiner ICY-Box NAS-2000 tritt der gleiche fehler auf.

-> NAS 4220-B mit 500GB, Filesystem EXT3, FW- 2.6.0.IB.1.RS.
-> PC Windows XP SP2 % PC Windows SP3
-> Netzwerk 100 Mbit
-> FTP Client "Leech FTP" und/oder den normalen Explorer

-> Dyndns.org als Statiche IP

-> Unitymedia 16000 als Internetanbindung

Danke
Dinis

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

2

Donnerstag, 11. September 2008, 12:35

Interessant! Aus 2 Gründen:

1.) Das es überhaupt auftreten kann (ich hatte bei dem 1000er mal das Phänomen, das die DL bei 99,99% hängen blieben) und
2.) Das es offensichtlich auch am Client liegt.

Versuchs mal mit filezilla, da gibts ein recht ausführliches log oder falls leechftp das hat schau dort mal nach den logs und poste mal.
Interessant wären auch mal die transfer logs der Box.

Greetz. Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

3

Donnerstag, 11. September 2008, 14:00

Also bin ich doch nicht alleine mit meinem Problem.

Habe mit einem Techniker von Raidsonic Telefoniert und die sagten das ihnen nichts bekannt ist und nach ein paar tests nichts finden können.
Ich soll einfach einen anderes Prog. benutzen.

Hier die Logfiles.
Erstmal nur von der NAS2000

Mit der vorigen FW hatte ich das Problem nicht gehabt.



LeechFTP Komando Protokoll

[13:44@11.09.08] 0x00000E30 < 220 ProFTPD 1.3.0 Server (ProFTPD) [192.168.178.2]
[13:44@11.09.08] 0x00000E30 > USER admin
[13:44@11.09.08] 0x00000E30 < 331 Password required for admin.
[13:44@11.09.08] 0x00000E30 > PASS *****
[13:44@11.09.08] 0x00000E30 < 230 User admin logged in.
[13:44@11.09.08] 0x00000E30 > REST 1
[13:44@11.09.08] 0x00000E30 < 501 REST: Resuming transfers not allowed in ASCII mode
[13:44@11.09.08] 0x00000E30 > SYST
[13:44@11.09.08] 0x00000E30 < 215 UNIX Type: L8
[13:44@11.09.08] 0x00000E30 > PWD
[13:44@11.09.08] 0x00000E30 < 257 "/mnt/IDE1/admin" is current directory.
[13:44@11.09.08] 0x00000E30 > TYPE I
[13:44@11.09.08] 0x00000E30 < 200 Type set to I
[13:44@11.09.08] 0x00000E30 > PASV
[13:44@11.09.08] 0x00000E30 < 227 Entering Passive Mode (xx,xx,xx,xx,238,122).
[13:44@11.09.08] 0x00000E30 > STOR /mnt/IDE1/admin/testfile.rar
[13:44@11.09.08] 0x00000E30 < 550 /mnt/IDE1/admin/testfile.rar: No such file or directory
[13:44@11.09.08] 0x00000E30 > TYPE I
[13:44@11.09.08] 0x00000E30 < 200 Type set to I
[13:44@11.09.08] 0x00000E30 > PASV
[13:44@11.09.08] 0x00000E30 < 227 Entering Passive Mode (xx,xx,xx,xx,4,131).
[13:44@11.09.08] 0x00000E30 > STOR /mnt/IDE1/admin/testfile.rar
[13:44@11.09.08] 0x00000E30 < 150 Opening BINARY mode data connection for /mnt/IDE1/admin/testfile.rar
[13:44@11.09.08] 0x00000B48 < 220 ProFTPD 1.3.0 Server (ProFTPD) [192.168.178.2]
[13:44@11.09.08] 0x00000B48 > USER admin
[13:44@11.09.08] 0x00000B48 < 331 Password required for admin.
[13:44@11.09.08] 0x00000B48 > PASS *****
[13:44@11.09.08] 0x00000B48 < 230 User admin logged in.
[13:44@11.09.08] 0x00000B48 > REST 1
[13:44@11.09.08] 0x00000B48 < 501 REST: Resuming transfers not allowed in ASCII mode
[13:44@11.09.08] 0x00000B48 > SYST
[13:44@11.09.08] 0x00000B48 < 215 UNIX Type: L8
[13:44@11.09.08] 0x00000B48 > PWD
[13:44@11.09.08] 0x00000B48 < 257 "/mnt/IDE1/admin" is current directory.
[13:44@11.09.08] 0x00000E30 < 226 Transfer complete.
[13:45@11.09.08] 0x0000086C < 220 ProFTPD 1.3.0 Server (ProFTPD) [192.168.178.2]
[13:45@11.09.08] 0x0000086C > USER admin
[13:45@11.09.08] 0x0000086C < 331 Password required for admin.
[13:45@11.09.08] 0x0000086C > PASS *****
[13:45@11.09.08] 0x0000086C < 230 User admin logged in.
[13:45@11.09.08] 0x0000086C > REST 1
[13:45@11.09.08] 0x0000086C < 501 REST: Resuming transfers not allowed in ASCII mode
[13:45@11.09.08] 0x0000086C > SYST
[13:45@11.09.08] 0x0000086C < 215 UNIX Type: L8
[13:45@11.09.08] 0x0000086C > PWD
[13:45@11.09.08] 0x0000086C < 257 "/mnt/IDE1/admin" is current directory.
[13:45@11.09.08] 0x0000086C > PASV
[13:45@11.09.08] 0x0000086C < 227 Entering Passive Mode (xx,xx,xx,xx,238,124).
[13:45@11.09.08] 0x0000086C > TYPE I
[13:45@11.09.08] 0x0000086C < 200 Type set to I
[13:45@11.09.08] 0x0000086C > RETR /mnt/IDE1/admin/testfile.rar
[13:45@11.09.08] 0x0000086C < 150 Opening BINARY mode data connection for /mnt/IDE1/admin/testfile.rar (1700015 bytes)
[13:45@11.09.08] 0x0000086C < 226 Transfer complete.



LeechFTP Download Protokoll
[13:45@11.09.08] F:\testfile.rar <- xxx.dyndns.org:/mnt/IDE1/admin/testfile.rar

ICY BOX NAS2000 System Log


Sep 11 07:43:15 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - notice: unable to add scoreboard entry: Invalid argument
Sep 11 07:43:15 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - error rewinding scoreboard: Invalid argument
Sep 11 07:43:15 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - FTP session opened.
Sep 11 07:43:15 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - USER admin: Login successful.
Sep 11 07:43:15 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - error rewinding scoreboard: Invalid argument
Sep 11 07:43:23 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - notice: unable to add scoreboard entry: Invalid argument
Sep 11 07:43:23 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - error rewinding scoreboard: Invalid argument
Sep 11 07:43:23 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - FTP session opened.
Sep 11 07:43:23 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - USER admin: Login successful.
Sep 11 07:43:23 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - error rewinding scoreboard: Invalid argument
Sep 11 07:43:33 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - notice: unable to add scoreboard entry: Invalid argument
Sep 11 07:43:33 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - error rewinding scoreboard: Invalid argument
Sep 11 07:43:33 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - FTP session opened.
Sep 11 07:43:33 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - USER admin: Login successful.
Sep 11 07:43:33 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - error rewinding scoreboard: Invalid argument
Sep 11 07:44:04 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - FTP session closed.
Sep 11 07:44:14 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - notice: unable to add scoreboard entry: Invalid argument
Sep 11 07:44:14 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - error rewinding scoreboard: Invalid argument
Sep 11 07:44:14 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - FTP session opened.
Sep 11 07:44:14 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - USER admin: Login successful.
Sep 11 07:44:14 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - error rewinding scoreboard: Invalid argument
Sep 11 07:44:24 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - FTP session closed.
Sep 11 07:45:07 icybox (xx.xx.xx.xx[xx.xx.xx.xx]) - FTP session closed.

ICY BOX NAS2000 FTP Log

Thu Sep 11 07:43:53 2008 xx.xx.xx.xx /mnt/IDE1/admin/testfile.rar b _ i r admin ftp 1 * c
Thu Sep 11 07:44:36 2008 xx.xx.xx.xx /mnt/IDE1/admin/testfile.rar b _ o r admin ftp 1 * c

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

4

Donnerstag, 11. September 2008, 14:19

Dass die Daten zerstört sind, scheint nur bei dir aufzutreten.

Es könnte an dem Ascii/Binary Mode liegen.
Bei ftp kann man den Übertragungsmodus wählen.

Wenn man eine binäre Datei im Ascii Mode überträgt, ist sie dann defekt.

P.S. die Warnings über das scoreboard kann man mit folgendem Eintrag im proftp.conf verhindern.

Quellcode

1
ScoreboardFile /var/run/proftpd.scoreboard


lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

5

Donnerstag, 11. September 2008, 15:02

Hallo HWguru,

Bei Leechftp ist Ascii/Binary Mode auf Auto eingestellt.
Habe aber auch schon beide manuell ausgewählt und getestet.
Unter dem Explorer kann ich ja nix einstellen.(Ascii/Binary Mode)
Ich benutze Leechftp ja noch auf anderen FTP Server und habe da keine Probleme.

Mit den Warnings werde ich mich noch beschäftigen.

Kenne mich mit dem Telenet zugang noch nicht aus.



Dinis

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

6

Donnerstag, 11. September 2008, 15:58

Es könnte auch noch am "Passive Mode" liegen.
Kannst du es mal mit "Active Mode" versuchen.
Eine prinzipielle Beschreibung gibt es bei Wikipedia.

Für den zu verwendenden Port Range gibt es auch ein Einstellung fürs proftpd.conf zB:

Quellcode

1
PassivePorts 60000 60100


Funktioniert eigentlich der Transfer im lokalen Netz?

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

7

Donnerstag, 11. September 2008, 19:16

Passivmode kann ich aber im Explorer nicht einstellen.
Mit dem Explorer müsste es aber normal klappen.

Im Netzwerk geht alles ohne Probleme.
Die Downloads über Sambazugriff & FTP (192.168.178.2) sind dort alle OK.

Nur über internet, IP oder Dyndns adresse, sind alle downloads defekt.

Bei exefiles kommt nur ein Dosfenster und schliesst sich wieder ohne was zu machen oder Meldung.

Bei rarfiles kommt die Meldung "The archive is either in unkown format or Damaged"



Dinis

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

8

Freitag, 12. September 2008, 01:03

Im Netzwerk geht alles ohne Probleme.

Für das NAS macht das keinen Unterschied ob die Zugriffe von intern oder extern kommen.

Ich würde also das Problem im Zusammenspiel mit dem Router bzw. dessen Konfiguration suchen. Es gibt Geräte (Router) wo es definitiv Probleme gibt. (Google)

Eventuell musst du auch den konfigurierten passiven Port Range zum NAS forwarden.

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

9

Freitag, 12. September 2008, 09:15

Eine Sache könntest du noch versuchen.

Die MasqueradeAddress Einstellung.
Dazu habe ich auf der proftpd Seite eine Anleitung gefunden.

Vielleicht hilft es deinem Router. Einen Versuch ist es zumindest wert.

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

10

Freitag, 12. September 2008, 10:45

Hi,

da geb ich glatt auch mal meinen senf dazu:

1.) der Eintrag: 501 REST: Resuming transfers not allowed in ASCII mode im Protokoll wundert mich, denn ein rar sollte im bin mode übertragen werden nicht im ASCII
2.) Hast Du die MTU werte angepasst? Die des Routers und die des NAS sollten übereinstimmen.

3.) Kannst Du auch im Explorer den aktiven Mode einschalten - bzw den passive ausschalten (Extras-->Internetoptionen-->erweitert-->passives ftp verwenden --> häckchen raus nehmen) unter rechtsklick "direkthilfe" steht auch nochmal kurz und bündig erklärt was, wie, warum (ich war selbst überrascht, offensichtlich ein guter tag gewesen bei Micro so oft :think: )

um die NAT- und Portthematik ausschließen zu können setz das NAS doch einfach mal kurz in die DMZ (Aber nur kurz zum Testen!)

Greetz. Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

11

Freitag, 12. September 2008, 12:45

BINGO !!!!!!!

HWguru hat´s herausgefunden.
Ich habe eine Fritzbox 7270. Die scheint die Probleme zu machen.
Nachdem ich die als "Exposed Host" für denn FTP Server konfiguriert habe geht es mit dem Explorer.

LeechFTP geht aber weiterhin nicht.



MTU werte habe ich nicht angepasst.
Ich kenne mich leider damit nicht so aus.

gibts da irgendwo eine anleitung??



Dinis

12

Samstag, 13. September 2008, 20:19

Nochmal vielen Danke an Snoopy & HWguru.

Fähige und Kompetente Leute.

Noch nicht mal der Raidsonic Support konnte mir helfen.

Die bräuchten einige leute wie euch :-))



DANKE

Dinis

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

13

Samstag, 13. September 2008, 23:58

Hi und THX für die lobenden Worte.... geht ja runter wie Öl :thumbsup:

OK, eine Frage war noch offen: Die mit den MTU Werten.
Ist eigentlich ganz einfach, das Prinzip ist, das die Paketgrößen (MTU Size) gleich groß sein sollten bei NAS und Router. Typischerweise ist das schon so voreingestellt auf 1492. Bei manchen Routern kann man den MTU Wert einstellen, das sind aber eher die Exoten, bei denen per Default ein anderer als 1492 eingestellt ist. Das lässt sich leicht im WEB Gui des routers prüfen oder einfach mal beim Support anrufen und nachfragen. Evtl. gibts auch schon ein Forum zum jeweiligen Router und Du findest dort die Antwort. Beim NAS ist das noch nicht ganz klar, ab welcher Firmware die MTU Size 1492 ist. Zumindest gibt es beim Supportbereich (treiber download) auf der Raidsonic Seite ein MTU tuning tool Paket. Tuning bedeutet eigentlich nix anderers als die Anpassung an 1492. In dem Zip ist eine entsprechende Anleitung dabei. Im wesentlichen das tgz paket in .../public/applications/new software kopieren und NAS rebooten.

Ein Hinweis aus eigener Erfahrung: Wenn Du mit der Leistung zufrieden bist und Deine Probs gelöst sind solltest Du darauf verzichten, denn: never change a running system. :thumbup:

Greetz. Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)