Dienstag, 21. November 2017, 01:28 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Montag, 29. September 2008, 01:36

installation von mediatomb

hat schonmnal jemand versucht mediatomb auf dem nas2000 zu installieren?
möchte twonky gerne loswerden bzw. nicht dafür bezahlen und bin dann auf mediatomb gestoßen. im nas4220-forum hat das auch jemand auf dem nas4220 zum laufen gebracht.
bei mir will das allerdings nicht klappen, beim starten von mediatomb kommt immer folgender fehler:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
/mnt/IDE1/public/applications/mediatomb$ ./mediatomb.sh
MediaTomb UPnP Server version 0.11.0 - http://mediatomb.cc/
===============================================================================
Copyright 2005-2008 Gena Batsyan, Sergey Bostandzhyan, Leonhard Wimmer.
MediaTomb is free software, covered by the GNU General Public License version 2
2008-09-28 23:26:57	INFO: Loading configuration from: /mnt/IDE1/public/applications/mediatomb/config/config.xml
2008-09-28 23:26:57	INFO: Checking configuration...
2008-09-28 23:26:57	INFO: Setting filesystem import charset to ASCII
2008-09-28 23:26:57	INFO: Setting metadata import charset to ASCII
2008-09-28 23:26:57	INFO: Setting playlist charset to ASCII
2008-09-28 23:26:57	INFO: Configuration check succeeded.
2008-09-28 23:26:57   ERROR: main: upnp error -117
2008-09-28 23:26:57   ERROR: upnp_cleanup: UpnpUnRegisterRootDevice failed


und dann gehts nicht weiter. kann damit jemand was anfangen?
war davon ausgegangen, daß es, wenn es auf dem nas4220 läuft, wegen der doch recht geringen hardwareunterschiede auch auf dem nas2000 laufen müßte.

habe ich mich da geirrt oder hat der fehler was anderes zu bedueten?

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

2

Montag, 29. September 2008, 07:19

:hmm:- stimmt, das NAS2000 ist sehr ähnlich. Zumindest was die Firmware betrifft.
Die Hardware ist doch recht unterschiedlich bis auf die CPU Familie.

Eventuell liegt es am Mountpoint. Der ist beim 4220 /mnt/ide1 und beim 1000/2000 /mnt/IDE1

Sonst würde ich auch sagen, dass es laufen sollte. Ich habe es selber noch nicht versucht.

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

3

Montag, 29. September 2008, 09:29

Moin,

Ich stimme HWguru zu... Root Device not fond - heißt Platte nicht gefunden. Denn root ist entweder IDE1 oder ide1

Zum fehler Nummer 117 lesen Sie bitte hier: http://icrontic.com/forum/showpost.php?s…320&postcount=1

scheint, als müsste die "mediatomb.init" editiert werden.

Wenn dann noch ein Read/ writeerror kommt mal den user auf root setzen statt mediatomb oder die Rechte anpassen.

Grretz. Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

4

Montag, 29. September 2008, 18:10

Ist denn die libupnp überhaupt vorhanden? Die wird sicherlich auch gebraucht...

Quellcode

1
2
2008-09-28 23:26:57   ERROR: main: upnp error -117
2008-09-28 23:26:57   ERROR: upnp_cleanup: UpnpUnRegisterRootDevice failed


das riecht irgendwie so ein wenig danach
...and eternity, my friend, is a long fucking time!

5

Montag, 29. September 2008, 23:16

also die mountpunkte sind überall korrekt (IDE1, ist ja das nas2000)
ob ich das ganze als root, admin oder werweißwas installiere und starte spielt keine rolle, der fehler ist immer gleich.
hab schonmal im mediatomb forum dazu gelesen, aber laut einem entwickler sind die upnp fehlercodes immer relativ unspezifisch und können vieles bedeuten bzw. weisen nicht genau immer auf einen fehler hin. so ist die diagnose und fehlerbehebung natürlich ziemlich schwierig. deswegen wollen die entwickler auch libupnp mit ner eigenen library in kürze ersetzen....

zu dem fehler 117 hatte ich aber auch trotzdem schon gegooglet, z.b. tritt der bei ubuntu bei problemen mit dem network manager und einträgen in etc/network/interfaces auf. aber diesen pfad gibts beim nas ja schonmal gar nicht

was libupnp angeht: normalerweise war das ein static binary package, wo schon alles benötigte drin ist. siehe: http://mediatomb.cc/pages/download#static

aber wie könnte man denn zum test libupnp auf dem nas installieren?


edit:
so jetzt hab ich mal in der config.xml von mediatomb ein paar parameter versucht aus der dokumentation:

wenn ich dort <ip>192.168.1.7</ip> einfüge kommt jetzt folgender fehler:

Quellcode

1
2
2008-09-29 21:45:14   ERROR: main: upnp error -205
2008-09-29 21:45:14   ERROR: upnp_cleanup: UpnpUnRegisterRootDevice failed


zur fehlermeldung 205 finde ich aber gar nix :think:

wenn ich statt der ip das interface angebe mittels <interface>eth0</interface> kommt das:

Quellcode

1
2
2008-09-29 21:42:20   ERROR: Could not create local socket
2008-09-29 21:42:20   ERROR: Could not find interface: eth0


hm wieso kann er das interface nicht finden? wenn ich ifconfig ausführe wird eth0 als interface angezeigt

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »jimpoison« (29. September 2008, 23:48)


snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

6

Dienstag, 30. September 2008, 09:58

Hola,

schon mal nicht schlecht. Gib doch mal beides an, interface und IP, denn soweit ich das hier in den sources sehe gibt es 3 parameter, auf die das main wartet:

00983 int local_socket;
00984
00985 if (!string_ok(interface))
00986 return nil;
00987
00988 local_socket = socket(AF_INET, SOCK_DGRAM, IPPROTO_UDP);
00989 if (local_socket < 0)
00990 {
00991 log_error("Could not create local socket\n");
00992 return nil;
00993 }
00994
00995 iflist = iflist_free = if_nameindex();
00996 if (iflist == NULL)
00997 {
00998 log_error("Could not get interface list\n");
00999 close(local_socket);
01000 return nil;
01001 }

Daher auch die fehlermeldung.

Scheint so, als wäre der etho als dieser noch nicht bekannt (nur ein renaming problem) - schau doch mal bitte unter /etc/network/interfaces

Das sollte eth0, eth1 und lo (für local) drinnen stehen wenn nicht einfach ergänzen:
Ich hab da schon mal was vorbereitet ... :-)

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp

Und nicht verwirren lassen, ifconfig wird eth0 evtl. richtig anzeigen. Das bedeutet aber nocht nicht, das der sock-bind passt. :happy:

Grretz. Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

7

Dienstag, 30. September 2008, 17:49

ähm bei mir gibts auf dem nas2000 kein etc/network/interfaces......also kann ich da (leider) auch nix reinschreiben. oder soll ich den pfad einfach mal anlegen??

in der config.xml von mediatomb kann man leider nur entweder den ip-parameter oder den interface-parameter angeben, beides zusammen geht nicht, es wird dann folgende fehlermeldung ausgespuckt:

Quellcode

1
2008-09-30 15:46:28   ERROR: Error in config file: you can not specify interface and ip at the same time!

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

8

Donnerstag, 2. Oktober 2008, 09:25

Moin,

sieht so aus, als wäre der server gar nicht getartet. Typischerweise wird dann die *.sock datei automatisch angelegt.

Tatsächlich ist der Pfad ein anderer, Mediatomb schreibt die Daten in /var/lib/ - vermute ich mal, genau so wie MySql. Und das ist auch schon das Stichwort. Ich bin mir nicht ganz sicher, aber so wie es ausschaut brauch Mediatomb eine SQL Datenbank. Die kannst Du einrichten unter my.cnf unter etc/... Mit [Mediatomb] kannst Du neben den globalen variablen die Mediatomb spezifischen setzen. Das 2000er schafft 3 SQL Datenbanken gleichzeitig. Mehr hab ich noch nicht getestet.

... NAch kurzem Check: Ja, SQL ist notwendig.

Hier steht wie die eth0, 1 und local einzurichten sind und wie die Sql oder sqlLite (beide im php-thttpd Paket enthalten - bitte einfach mal im Forum lunzen und installieren) konfiguriert werden müssen, damit es klappt. Dann sollte es auch rocken. Wenn Du das Mediatomb paket mit SQL installiert hast entfällt natürlich die php-thttpd Installation. Allerdings hab ich noch nicht getestet ob der phpMyAdmin (Admintool für SQL Datenbanken) funzt. Den brauchst du aber auch nicht unbedingt, wenn Du Dich an der Konsole auskennst. http://mediatomb.cc/pages/documentation#id2535736 - Punkt 4, 5 und 6

Greetz. Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

9

Donnerstag, 2. Oktober 2008, 17:43

also beim ersten start von mediatomb wird doch automatisch eine sqlite-datenbank im mediatomb-unterverzeichnis angelegt. genauso wie auch in der dokumentation (die du ja auch nochmal verlinkt hast) beschrieben.
es wird eine config.xml angelegt und eine mediatomb.db.
denke, daß das so passen müßte. wie gesagt ist das ja auch ne static binary, die extra so angepriesen wird, daß man nichts weiteres zum betrieb braucht bzw. installieren muß.

ich hatte mich grundsätzlich an die anleitung aus dem nas-portal-forum fürs nas4220 gehalten, da ist auch nichts weiteres nötig, um das zum laufen zu kriegen. hier mal der link zu der anleitung: http://forum.nas-portal.org/showthread.php?t=2822
nicht wundern: habe unter der anleitung in dem thread auch schon nach hilfe gesucht, allerdings ist da bisher auch nicht viel bei rum gekommen (zumindest nix was die probleme gelöst hätte)


was ist denn mit dieser interface-geschichte. kann man das auf dem nas2000 jetzt irgendwie bearbeiten? etc/netwotk/interfaces gibts ja nicht.

wenn ich das

Quellcode

1
2
3
4
route add -net 239.0.0.0 netmask 255.0.0.0 eth0 

ifconfig eth0 allmulti
		

in der konsole per winscp eingebe und dann versuche mediatomb zu starten kommen die wieder die gleichen fehelrmeldungen. scheint also keine auswirkungen zu haben..... ;(
oder geht das nicht über die konsole?

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

10

Donnerstag, 2. Oktober 2008, 20:56

Hola,

Schau mal unter etc/hosts

da sollte der 239.0.0.0 als local host drin stehen. Mysql will noch den 172.0.0.1 haben. Kann sein, das Du das noch eintragen musst. UDP port gibst du im mediatom.conf an

War bei mir auch das Prob.

Trotzdem sollte mediatomb beim start eine *.sock anlegen, oder auf die sql.sock unter /usr/local/mysql/tmp/mysql.sock

Der base-dir Pfad sollte auch passen: /usr/local/mysql/

Sonst fällt mir grad nix weiter ein.. ich versuch das jetzt nochmal mit der standard - grundeinstellung.

Dazu 2 Fragen: Hattest Du vorher php-webserver mit sql installiert oder das sql mit dem m-tomb packet genommen? und hast du nachträglich noch was installiert? Ich denke da an phpMyAdmin oder ä.?

Greetz. Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

11

Freitag, 3. Oktober 2008, 09:14

also was php, webserver und den ganzen sql-kram angeht: ich hab gar nix in der richtung installiert und auch nicht ausprobiert.

mein nas2000 hat die letzte original raidsonic-firmware drauf und ansonsten hab ich nur den ssh-server und das do_it-script installiert. sonst nix.

werd das jetzt nochmal mit der etc/hosts probieren und dann weiß ich auch nicht mehr.

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

12

Samstag, 4. Oktober 2008, 13:24

Hey, wir sind Helden! :rtfm:

Also, der Mediatomb- so wie im 4220 beschrieben setzt sich auf die Schnittstelle des "Twonkymedia" - hier haben die Kollegen voll getrickst. :hmm:

Also: erst den Twonky drauf packen, einmal laufen lassen, dann den ordner "Twonkymedia" umbenennen was weiß ich, alter Twonky oder so und dann nach Anleitung der Kollegen installieren. ide1 wird ersetzt durch IDE1 und schon läuft der Laden.

Und damit ist auch der Socket drauf.

Hast Du das so gemacht?

Grüße. Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

13

Samstag, 4. Oktober 2008, 13:28

tja, genauso hatte ich das gemacht. klappt bloß trotzdem nicht...
geht das denn bei dir so?

14

Donnerstag, 8. Januar 2009, 10:29

Moin,
ich habe den Mediatomb ebenfalls installiert und scheitere (wie sollte es anders sein) leider an den beiden Fehlermeldungen:

Zitat

INFO: Loading configuration from: /mnt/IDE1/public/applications/twonkymedia/config/config.xml
2009-01-08 09:06:14 INFO: Checking configuration...
2009-01-08 09:06:15 INFO: Setting filesystem import charset to ISO-8859-1
2009-01-08 09:06:15 INFO: Setting metadata import charset to ISO-8859-1
2009-01-08 09:06:15 INFO: Setting playlist charset to ASCII
2009-01-08 09:06:15 INFO: Configuration check succeeded.
2009-01-08 09:06:15 ERROR: main: upnp error -117
2009-01-08 09:06:15 ERROR: upnp_cleanup: UpnpUnRegisterRootDevice failed


Habe diesen Thread jetzt mehrere Male hoch und runter gelesen,habe in der hosts noch die 239.0.0.0 nachgetragen,die Zeilen

Zitat

route add -net 239.0.0.0 netmask 255.0.0.0 eth0

ifconfig eth0 allmulti


in der twonkymedia.sh eingefügt,aber die Meldungen kommen immer wieder.

Wie ist das jetzt,der Twonky muss deaktiviert sein,richtig?

Das Häkchen haben ich entfernt in den Einstellungen des NAS...

Verdurrich das muss doch zu schaffen sein 8o

Gruß SAM

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

15

Donnerstag, 8. Januar 2009, 10:49

Hmm, Twonky deaktivieren? Ich glaub der Mediatomb läft als Fake-Twonky-Instanz. Wenn Du den deaktivierst ziehst Du dem upnp server m.E. die Füsse weg. :think:

Die Fehlermeldung bezieht sich auf ein root device: http://mediatomb.cc/doxygen/upnp_8h.html…b6bc0170e81a50f

Vllt. hilft das weiter. Habe im Moment grad wenig Zeit, werde das aber nochmal testen. Scheinbar gibts ein prob mit der lokalen Schnittstelle eth0 oder 1.

Greetz. Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

16

Donnerstag, 8. Januar 2009, 10:57

Nachtrag:

4. Initial Installation




4.1. Network Setup
Some systems require a special setup on the network interface. If MediaTomb exits with UPnP Error -117, or if it does not respond to M-SEARCH requests from the renderer (i.e. MediaTomb is running, but your renderer device does not show it) you should try the following settings (the lines below assume that MediaTomb is running on a Linux machine, on network interface eth1):
# route add -net 239.0.0.0 netmask 255.0.0.0 eth1
# ifconfig eth1 allmulti

Those settings will be applied automatically by the init.d startup script.
You should also make sure that your firewall is not blocking port UDP port 1900 (required for SSDP) and UDP/TCP port of MediaTomb. By default MediaTomb will select a free port starting with 49152, however you can specify a port of your choice in the configuration file.




4.2. First Time Launch
When starting MediaTomb for the first time, a .mediatomb directory will be created in your home. Further, a default server configuration file, called config.xml will be generated in that directory.




4.2.1. Using Sqlite Database
If you are using sqlite - you are ready to go, the database file will be created automatically and will be located ~/.mediatomb/mediatomb.db If needed you can adjust the database file name and location in the server configuration file.




4.2.2. Using MySQL Database
If MediaTomb was compiled with support for both databases, sqlite will be chosen as default because the initial database can be created and used without any user interaction. If MediaTomb was compiled only with MySQL support, the appropriate config.xml file will be created in the ~/.mediatomb directory, but the server will then terminate, because user interaction is required.
MediaTomb has to be able to connect to the MySQL server and at least the (empty) database has to exist. To create the database and provide MediaTomb with the ability to connect to the MySQL server you need to have the appropriate permissions. Note that user names and passwords in MySQL have nothing to do with UNIX accounts, MySQL has it's own user names/passwords. Connect to the MySQL database as “root” or any other user with the appropriate permissions:
$ mysql [-u <username>] [-p]

(You'll probably need to use “-u” to specify a different MySQL user and “-p” to specify a password.)
Create a new database for MediaTomb: (substitute “<database name>” with the name of the database)
mysql> CREATE DATABASE <database name>;

(You can also use “mysqladmin” instead.)
Give MediaTomb the permissions to access the database:
mysql> GRANT ALL ON <database name>.*
TO '<user name>'@'<hostname>'
IDENTIFIED BY '<password>';

If you don't want to set a password, omit “IDENTIFIED BY ..” completely. You could also use the MySQL “root” user with MediaTomb directly, but this is not recommended.
To create a database and a user named “mediatomb” (who is only able to connect via “localhost”) without a password (the defaults) use:
mysql> CREATE DATABASE mediatomb;
mysql> GRANT ALL ON mediatomb.* TO 'mediatomb'@'localhost';

If MediaTomb was compiled with database auto creation the tables will be created automatically during the first startup. All table names have a “mt_” prefix, so you can theoretically share the database with a different application. However, this is not recommended.
If database auto creation wasn't compiled in (configure was run with the “--disable-db-autocreate” or zlib.h was not available) you have to create the tables manually:
$ mysql [-u <username>] [-p] \
<database name> < \
<install prefix>/share/mediatomb/mysql.sql

After creating the database and making the appropriate changes in your MediaTomb config file you are ready to go - launch the server, and everything should work.
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

17

Donnerstag, 8. Januar 2009, 11:11

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
#!/bin/sh
# if you want to launch this script from a different directory (for example
# from an another init script or similar, set the LAUNCHDIR variable below
# to the absolute path of the mediatomb.sh script
# HD Mountpoint
LAUNCHDIR=/mnt/IDE1/public/applications/twonkymedia
LOGFILEDIR=$LAUNCHDIR/log

export MEDIATOMB_DATADIR="$LAUNCHDIR/usr/share/mediatomb"
export MEDIATOMB_MAGIC_FILE="usr/share/file/magic"

route add -net 239.0.0.0 netmask 255.0.0.0 eth0
ifconfig eth0 allmulti


$LAUNCHDIR/usr/bin/mediatomb -m $LAUNCHDIR -f config -l $LOGFILEDIR/logfile.txt -d 


ist ja drin geht aber trotzdem nicht...


die config.xml sieht so aus,drt habe ich die Pfade bzw ide1 in IDE1 umbenannt

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
<config version="1" xmlns="http://mediatomb.cc/config/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/1 http://mediatomb.cc/config/1.xsd">
  <server>
    <port>0</port> 
      <ui enabled="yes">
      <accounts enabled="no" session-timeout="30">
        <account user="mediatomb" password="mediatomb"></account>
      </accounts>
    </ui>
    <name>MediaTomb</name>
    <udn>uuid:79209eaf-d849-4de0-92f6-c96a258f94fc</udn>
    <home>/mnt/IDE1/public/applications/twonkymedia/config</home>
    <webroot>/mnt/IDE1/public/applications/twonkymedia/usr/share/mediatomb/web</webroot>
    <storage>
      <sqlite3 enabled="yes">
        <database-file>mediatomb.db</database-file>
      </sqlite3>
    </storage>
    <protocolInfo extend="yes"></protocolInfo>
  </server>
  <import hidden-files="no">
  <filesystem-charset>ISO-8859-1</filesystem-charset>
  <metadata-charset>ISO-8859-1</metadata-charset>
    <magic-file>usr/share/file/magic</magic-file>
    <scripting script-charset="UTF-8">
      <common-script>/mnt/IDE1/public/applications/twonkymedia/usr/share/mediatomb/js/common.js</common-script>
      <playlist-script>/mnt/IDE1/public/applications/twonkymedia/usr/share/mediatomb/js/playlists.js</playlist-script>
      <virtual-layout type="builtin">
        <import-script>/mnt/IDE1/public/applications/twonkymedia/usr/share/mediatomb/js/import.js</import-script>
      </virtual-layout>
    </scripting>
    <mappings>
      <extension-mimetype ignore-unknown="no">
        <map from="mp3" to="audio/mpeg"></map>
        <map from="ogg" to="application/ogg"></map>
        <map from="asf" to="video/x-ms-asf"></map>
        <map from="asx" to="video/x-ms-asf"></map>
        <map from="wma" to="audio/x-ms-wma"></map>
        <map from="wax" to="audio/x-ms-wax"></map>
        <map from="wmv" to="video/x-ms-wmv"></map>
        <map from="wvx" to="video/x-ms-wvx"></map>
        <map from="wm" to="video/x-ms-wm"></map>
        <map from="wmx" to="video/x-ms-wmx"></map>
        <map from="m3u" to="audio/x-mpegurl"></map>
        <map from="pls" to="audio/x-scpls"></map>
        <map from="flv" to="video/x-flv"></map>
        <map from="avi" to="video/divx"></map>
       </extension-mimetype>
      <mimetype-upnpclass>
        <map from="audio/*" to="object.item.audioItem.musicTrack"></map>
        <map from="video/*" to="object.item.videoItem"></map>
        <map from="image/*" to="object.item.imageItem"></map>
      </mimetype-upnpclass>
      <mimetype-contenttype>
        <treat mimetype="audio/mpeg" as="mp3"></treat>
        <treat mimetype="application/ogg" as="ogg"></treat>
        <treat mimetype="audio/x-flac" as="flac"></treat>
        <treat mimetype="image/jpeg" as="jpg"></treat>
        <treat mimetype="audio/x-mpegurl" as="playlist"></treat>
        <treat mimetype="audio/x-scpls" as="playlist"></treat>
        <treat mimetype="audio/x-wav" as="pcm"></treat>
        <treat mimetype="audio/L16" as="pcm"></treat>
        <treat mimetype="video/x-msvideo" as="avi"></treat>
      </mimetype-contenttype>
    </mappings>
  </import>
  <transcoding enabled="no">
    <mimetype-profile-mappings>
      <transcode mimetype="video/x-flv" using="vlcmpeg"></transcode>
      <transcode mimetype="application/ogg" using="vlcmpeg"></transcode>
      <transcode mimetype="application/ogg" using="oggflac2raw"></transcode>
      <transcode mimetype="audio/x-flac" using="oggflac2raw"></transcode>
    </mimetype-profile-mappings>
    <profiles>
      <profile name="oggflac2raw" enabled="no" type="external">
        <mimetype>audio/L16</mimetype>
        <accept-url>no</accept-url>
        <first-resource>yes</first-resource>
        <accept-ogg-theora>no</accept-ogg-theora>
        <agent command="ogg123" arguments="-d raw -f %out %in"></agent>
        <buffer size="1048576" chunk-size="131072" fill-size="262144"></buffer>
      </profile>
      <profile name="vlcmpeg" enabled="no" type="external">
        <mimetype>video/mpeg</mimetype>
        <accept-url>yes</accept-url>
        <first-resource>yes</first-resource>
        <accept-ogg-theora>yes</accept-ogg-theora>
        <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"></agent>
        <buffer size="14400000" chunk-size="512000" fill-size="120000"></buffer>
      </profile>
    </profiles>
  </transcoding>
</config>

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

18

Donnerstag, 8. Januar 2009, 11:22

SQL oder SQLlite sind auch vorhanden?

Zitat

<storage>
<sqlite3 enabled="yes">
<database-file>mediatomb.db</database-file>
</sqlite3>
</storage>
Der account passt?

<port>0</port>
<ui enabled="yes">
<accounts enabled="no" session-timeout="30">
<account user="mediatomb" password="mediatomb"></account>
</accounts>

Dann sollte es funzen. :think:
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

19

Donnerstag, 8. Januar 2009, 11:23

mom
ich schau mal eben:

sqlite3.sql
mysql.sql im Ordner /mnt/IDE1/public/applications/twonkymedia/usr/share/mediatomb vorhanden

Ha der Account könnte den Fehler auslösen....ich habe die xml praktisch nur in Sachen ide1 auf IDE1 korrigiert das mit dem Account habe ich unverändert gelassen,hmm wie kann ich das jetzt überprüfen,ob es den Account gibt..also ich habe den nicht angelegt.


Moment sehe aber gerade <accounts enabled="no" session-timeout="30"> der ist ja dann gar nicht aktiv...
Gruß SAM

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »sam« (8. Januar 2009, 11:28)


20

Donnerstag, 8. Januar 2009, 11:36

und nochmal für langsame....muss der Haken bei Twonky gesetzt werden oder nicht...nicht das sich da was in die Quere kommt...dieser 117er ...macht mir da so meine Schwierigkeiten..