Dienstag, 21. November 2017, 05:19 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Sonntag, 9. November 2008, 12:57

NAS 2000 Firmwareupdate 1.x -> tinky Erfahrungsbericht

Moin,
kurz zu mir: Ich bin der Ralf, knapp über 30 und habe ein Problem.. <prost>
nein, nicht das.. mein NAS versteht mich nicht :think:

ich 'quäl' mich nun hier schon längere Zeit mit meinem NAS2000 rum, das einfach nicht so will wie ich.
————
Ausgangslage:
Mein NAS2000 wollte hin und wieder nicht so,wie ich wollte. Sie stürzte im Betrieb ab, ließ sich zeitweise nicht einschalten. Das war Zustand nach Auslieferung. Olle Zicke..
Nun gings ans schlau machen und einlesen.
Ich hatte noch die Firmware 1.x, also hab ich mir von RS das serielle Interface kommen lassen. Funktioniert prächtig (zumal es mit einem kleinen selbstgestrickten Adapterkabel auch mit dem GigaNAS läuft...), als Konsole hält ein altes Nixdorf Tema Laptop mit Telix her ;)

Den Sprung auf eine originale RS 2.x Firmware hab ich übersprungen und gleich Tinky raufgespielt. (Fehler?)

Und hier gingen die Schwierigkeiten los.
Nach erfolgtem (und erfolgreichem) Firmwareupdate (tinky) konnte ich zwar im Redboot die IP ändern, aber die MAC Adresse nicht mehr. (entry num a7457df2)
Den Schritt den ich danach gemacht habe, hab ich leider nicht mehr auf der Pfanne, ich bin der Meinung, dass ich ein komplettes Image versucht habe mit X zu flashen, offensichtlich war das ein mächtig böser Fehler, danach ging nämlich gar nichts mehr.
Nun kam das Flashtool mit dem JTAG Interface ins Spiel. Hab ja schon nen mittelschweren Horror davor gehabt, ist aber eigentlich ganz easy, wenn man weiß, an welcher Seite der Lötkolben heiß wird. An dieser Stelle nochmals ein fettes Danke an Rambo und HWGuru, die dies ermöglichten.

IP und MAC Adresse ließen sich nach aufspielen des redboot.img nicht ändern, (irgendwelche FIS Fehler, die ich nicht mehr in Erinnerung habe) daraufhin hab ich noch etwas nachgelesen und mit der Funktion "Erase Top 64k" und "Erase Boot" das Ding nochmals richtig platt gemacht und das redboot.img erneut geflasht.

Der Bootloader war wieder da, allerdings kein Image und auch keine Chance die IP zu ändern. Es kam die Fehlermeldung "FIS entry missing" bei dem Versuch die IP Adresse einzugeben.

Nun hab ich das redboot.bin von lord scaffar geflasht..gleiches Ergebnis. Ein Filecompare ergab auch, dass die Dateien bis auf ein Byte identisch sind. Das redboot(ROMRAM) für ARM von den Seiten von www.ecos.com hab ich besser nicht angefasst, die unterschiedliche Dateilänge hat mich davon abgehalten.

Als letzten Schritt hab ich kurzerhand die IP-Adressen meines Rechners auf 192.192.2.x geändert, da das Redboot ja die x.x.2.71 zurückmeldete. Damit hab ich das tinky nun raufgehauen. Die Kiste rennt nun für's erste wieder. Allerdings lässt sich die MAC nachwievor nicht ändern, entry num a7457df2 erscheint immer wieder.

Gibts eigentlich ein anderes redboot mit commandline? Der Bootloader vom GigaNAS sieht ja nun um einiges anders aus, dort lassen sich auch Applications, Ramdisk etc. einzeln flashen.

Obenstehendes ist nun ein paar Tage her, ich musste mich von den andauernden Rückschlägen erstmal moralisch erholen, heute hab ich den Versuchsaufbau nochmal angefasst und "tagebuchartig" mitgeschrieben.

Nun steht der Versuch an, das originale RS 2.x raufzuflashen.. noch tut er.. die Spannung steigt.. und *yeah*
Das redboot ist sauber da, es lässt sich die MAC _und_ die IP ändern. Die Weboberfläche meldet die 2.3.2 IB zurück.. alles bestens.
So.. nun tinky als kernel update.. und..: vergeigt... nichts ging, redboot weg, auf der Konsole nur wirre Zeichen wie bei 'ner falschen Baudrate.. :comp03:
Also per JTAG wieder das redboot.img geflasht, MAC Adresse lässt sich wieder nicht ändern.. And again wieder die 2.3.2 RS drauf..
So.. wer lesen kann ist klar im Vorteil.. jetzt kommt der Moment, wo der corley sich an die Stirn patscht.. :rtfm:

Create New Image ist das Zauberwort.. hier lassen sich Ramdisk, Application etc schön einzeln aufspielen.
Nun geht auch alles so. wie ich mir das vorgestellt hab.. :coolb: bis auf dass tinky den USB-Anschluss nicht unterstützt (hab die Buchse eh noch nicht verbaut) und dass meine Power-LED nicht geht.. aber damit kann man leben.
Die Box wird nun vermutlich als VCR-Laufwerk für die DVB-T-Box herhalten (Siemens M740 AV)


Nun ist das ganze doch mehr ein Erfahrungsbericht statt einer Problem/Lösung Fragestellung geworden. Vielleicht ist für den einen oder anderen ja was dabei, der genauso auf dem Schlauch steht, wie ich anfangs.

Schönen Sonntag noch

Ralf
Vorhandene Hardware:
RS Icybox NAS-2000 (tinky 2_3_2)
2x MRT Dual NAS Sata (original)
1x MRT Dual GigaNAS Sata (original, letzte FW)
serial & JTAG Interface

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

2

Sonntag, 9. November 2008, 17:08

RE: NAS 2000 Firmwareupdate 1.x -> tinky Erfahrungsbericht

Hallo Ralf,
vielen Dank für deinen ausführlichen Beitrag!

Ich gebe dir nachträglich noch ein paar Infos. Eventuell hättest du vorher mal eine Frage posten sollen, bevor du in alle Fettnäpfchen tappst, die es gibt.

Zitat

Nach erfolgtem (und erfolgreichem) Firmwareupdate (tinky) konnte ich zwar im Redboot die IP ändern, aber die MAC Adresse nicht mehr. (entry num a7457df2)

Dazu hätte es hier im englischen Forum eine Lösung gegeben (findet man mit Suche nach VCTL).

Zitat

IP und MAC Adresse ließen sich nach aufspielen des redboot.img nicht ändern, (irgendwelche FIS Fehler, die ich nicht mehr in Erinnerung habe) daraufhin hab ich noch etwas nachgelesen und mit der Funktion "Erase Top 64k" und "Erase Boot" das Ding nochmals richtig platt gemacht und das redboot.img erneut geflasht.

Das "Erase Top 64k" braucht man nur sehr selten. Es schlummert im Bootloader ein dummer Fehler. Wenn ein falsches Image eingespielt wird und dabei der obere 64k Bereich überschrieben wird, kann es sein, dass man überhaupt nicht mehr flashen kann. Es gibt nämlich Flashes mit Top Boot, da besteht der top 64k Bereich aus 8x8k Blöcken. Die Flash Routine löscht dann nur den 1. der 8 und die anderen 7 bleiben unberührt. Dann kommt es zu einem Verify Fehler, weil 64k überprüft werden.

Die MAC Adresse wird im VCTL Teil (oben im Flash) abgelegt und wir beim Schreiben des bootloader (unten im Flash) per JTAG nicht verändert. --> Fehler bleibt

Zitat

Gibts eigentlich ein anderes redboot mit commandline? Der Bootloader vom GigaNAS sieht ja nun um einiges anders aus, dort lassen sich auch Applications, Ramdisk etc. einzeln flashen.

Einfache Antwort - Nein.

Zum Thema - "schaltet nicht immer ein" gibt es im Wiki etwas. Das ist ein Hardware Problem.

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!