Montag, 20. November 2017, 23:57 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

zydoon

Anfänger

Beiträge: 19

Wohnort: Tunis

1

Freitag, 2. Januar 2009, 12:28

SOHO NAS original firmware

Hi,

after many attemtps, I succefully took my Verbatim SOHO NAS out of order ;(

now I do have a NAS that can boot but with no web interface, no ftp access, only telnet access.

I can telnet to redboot, it's seems dirty too, because I cannot change my MAC address.

Of course I didn't save my firmware before, so .. can somone provide with the original redboot image ?

my NAS is the Verbatim / Smartdisk SOHONAS.

kind regards,
Zydoon.
Verbatim SmartDisk SOHO NAS | Rev. D | 2.3.2-mu-02.2

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

2

Freitag, 2. Januar 2009, 13:19

If you cannot change your MAC, I am 100% sure reprogramming of the bootloader would not help. Instead there is the danger that you also loose the bootlodaer. (if you still want to do it - I warned you - look at our Database)

Do you get an error message when trying to change the MAC?

If you have telnet access your firmware seems to be intact. The web interface is copied from flash to a partition on the disk. If something becomes corrupted there, it will behave as you describe.
Unplug your disk and check if you can reach the web interface.

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

zydoon

Anfänger

Beiträge: 19

Wohnort: Tunis

3

Freitag, 2. Januar 2009, 13:59

again thank you for your prompt reply

here the error:

Quellcode

1
2
3
4
5
...
7: Setting MAC address
X:Upgrade Boot    Y:Upgrade Kernel    
=> Select: 7
entry num e7d1c5eb



and unplug my disk ??? I have to open the box, isn't ?
Verbatim SmartDisk SOHO NAS | Rev. D | 2.3.2-mu-02.2

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

4

Freitag, 2. Januar 2009, 16:25

Ahh, I know this error!

Have a look at this post.

Do not use option X in bootloader if don't know exactly what you are doing. This overwrites the bootloader and would need a flash files image with the size of exactly 8MB!

Of course you have to open it if you want to unplug the disk, unless you are no magician ;)

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

zydoon

Anfänger

Beiträge: 19

Wohnort: Tunis

5

Sonntag, 4. Januar 2009, 20:56

regained control on MAC address

Hi again,

I applied the VCTL image and regained control over the MAC address, thak you very much.

now back to web interface.
I got simply, this:

Quellcode

1
2
404 Not Found
 The requested URL '/' was not found on this server.  thttpd/2.25b 29dec2003


I will reapply Ramdisk and Application, and w'll see.

regards,
Zydoon.
Verbatim SmartDisk SOHO NAS | Rev. D | 2.3.2-mu-02.2

zydoon

Anfänger

Beiträge: 19

Wohnort: Tunis

6

Sonntag, 4. Januar 2009, 21:36

a loko at what's mounted

hi again,

I took a look at what's mounted and here what I have:
3 partitions:

Quellcode

1
2
3
4
5
6
7
8
9
10
localhost> fdisk -l

Disk /dev/hda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot	Start   	End	Blocks   Id  System
/dev/hda1           	1      	13  	104422   83  Linux
/dev/hda2          	14   	60738   487773562+  83  Linux
/dev/hda3       	60739   	60801  	506047+  82  Linux swap

and only /dev/hda1 is mounted under /mnt/IDE1, which is weird:

Quellcode

1
2
3
localhost> mount 
usbfs on /proc/bus/usb type usbfs (rw)
/dev/hda1 on /mnt/IDE1 type ext2 (usrquota,grpquota)


It has to be /dev/hda2, isn't ?

I saw on another post this mount schema:

Quellcode

1
2
3
4
root@NAS2000:~ # mount
none on /proc/bus/usb type usbfs (rw)
/dev/hda1 on /system type ext2 (rw)
/dev/hda2 on /mnt/IDE1 type ext3 (usrquota,grpquota)
Verbatim SmartDisk SOHO NAS | Rev. D | 2.3.2-mu-02.2

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

7

Montag, 5. Januar 2009, 10:36

Hi zydoon!

...fdisk looks good, but you are right that something is wrong with mount

/dev/hda1 on /system type ext2 (rw) is missing

/system holds the complete web interface and the user settings. This partition is created when you format the disk throughout the web if for the first time.
Something went wrong during boot so that the system partition is not mounted :(
You could try to mount it manually.

HWguru

Note: you should always disconnect the disk during flash operations as the pins of the CPU are shared between disk and flash.
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

zydoon

Anfänger

Beiträge: 19

Wohnort: Tunis

8

Montag, 5. Januar 2009, 10:47

So

Hi again, and thank you for your patience HWGuru,

so ... I might need to reflash my SOHO NAS (Ramdisk, Application) with the disk disconnected ?

PS: I mounted /dev/hda1 under /system and still have the "404 not found error", a check on /system/usr/webroot/ and it's empty :think:
Verbatim SmartDisk SOHO NAS | Rev. D | 2.3.2-mu-02.2

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

9

Montag, 5. Januar 2009, 11:31

Hi,
if /system is empty, you should remove it completely. Then the firmware detects you disk as a new one and wants to format it.

Attention: you user data will be lost!

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

zydoon

Anfänger

Beiträge: 19

Wohnort: Tunis

10

Montag, 5. Januar 2009, 11:40

Actually /system doesn't exist even if I create it, it's deleted upon reboot.
Verbatim SmartDisk SOHO NAS | Rev. D | 2.3.2-mu-02.2

zydoon

Anfänger

Beiträge: 19

Wohnort: Tunis

11

Montag, 5. Januar 2009, 17:14

alive again

Hi guys,

I finally applied firmware.save from http://thomas.schiex.free.fr/Files/ following HWGuru advice
and got my SOHO NAS at 2.3.2.03b alive agin.

Thank you HWguru for your help, you really helped me.

now, back to the original version means no ssh or telnet and no ipkg.

All I need is a descent file service:

I want to syncronise mirrors (fedora) via rsync and want to have public shares accessible via NFS and FTP.

kind regards,
Zydoon.
Verbatim SmartDisk SOHO NAS | Rev. D | 2.3.2-mu-02.2

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

12

Mittwoch, 7. Januar 2009, 10:05

This is a good time for closing as the original poblem is solved :closed:

For discussions about login with ssh I made a split - to be continued here

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!