Donnerstag, 23. November 2017, 12:20 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Sonntag, 5. April 2009, 02:18

Giganas mit SL3516 mit Kondensator am RS232 Anschluss

Ich habe ein Giganas (MRT NAS-R101, s. http://www.mrt-communication.com/NAS-R101.htm, Artikelbezeichnung bei Ebay: GIGABIT NAS HDD SYSTEM, FTP JBOD BITTORRENT DLNA), das sich beim heutigen Firmware-Update verabschiedet hat.
Es reagiert wie auf http://mrt.nas-central.org/index.php/The…nbricking_guide beschrieben, schaltet sich also beim Betätigen des Schiebetasters sofort aus anstatt herunterzufahren.
Es ist weder per Ping noch per Telnet noch per Weboberfläche erreichbar. Ping: Ich habe die ihm hier zugewiesene IP getestet (192.168.0.6), dann noch 192.168.1.1 und 192.168.2.71 (war im unbricking_guide genannt). Außerdem habe ich mit dem Free IP Scanner alle IPs von 192.168.0.1 bis 192.168.1.254 abgesucht.

Nun denke ich also, ich muss den Prozess mittels JTAG und anschließender serieller Console abarbeiten. Allerdings sieht die Steckerleiste, die ich als seriellen Anschluß bezeichnen würde, etwas anders aus: Zwischen Anschluss 1 und 5 (also VCC und GND) ist ein 100 µF Kondensator gelötet. Bevor ich nun also die ganze Hardware kaufe, frage ich mich, ob das überhaupt funktionieren wird, ob ich den Kondensator auslöten muss, oder es dann noch einen speziellen Trick gibt. Kennt jemand diese Konstruktion mit einem Kondensator an dieser Stelle? Ich kann auch ein Foto posten, wenn es hilft.

Wäre nett, wenn mit jemand einen Tipp geben könnte, ich will ungern 30 Euro für Hardware in den Wind pfeiffen und zwei Wochen warten, bis die Sachen hier sind, und dann geht nix...

Berthold
Es geht auch anders, aber so geht es auch.

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

2

Sonntag, 5. April 2009, 10:36

Hallo und willkommen!

- das original Giganas (DUAL-NAS-E) kann nicht per telnet erreicht werden (sollte auch im Guide stehen)
- Dein MRT NAS-R101 Nas ist vermutlich nicht baugleich mit dem Giganas.Ein Foto der Platine würde weiterhelfen.
- wenn es auch den SL3516 Chip verwendet könnte das unbricking gehen jedoch brauchst du dazu die passende Firmware
Ist die verfügbar?
- wenn zwischen VCC und GND ein Kondensator gelötet ist, stört der nicht

- kannst du das NAS nicht auch reklamieren? Obwohl um die Versandkosten bekommst du fast schon einen USB -> 232/JTAG Adapter

Bei ebay bekommst du ab 15€ (inkl. Versand) einen Adapter der die serielle Schnittstelle und JTAG bedienen kann.
Suche nach "USB to RS-232 FT232R"

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

3

Sonntag, 5. April 2009, 14:50

Bilder

Danke für die schnelle Antwort!

Ähm, ich dachte, ich könnte die Fotos hier hochladen, aber hier kann ich wohl nur auf einen Webspace verlinken. Ich habe leider keinen zur Hand, welcher ist zu empfehlen (kostenlos, Sofortanmeldung, ...)?

Ich dachte, ich hätte gestern Nacht gelesen, dass für den SL3516 was geschrieben sei, aber kann das sein, dass das nur der Boatloader war? Ich habe das Gesamtkonstrukt wohl noch nicht ganz verstanden. Also: Ich brauche JTAG, um den Bootloader redboot.bin zu installieren. Anschließend kann ich mit serieller Konsole die drei Firmware-Dateien zImage, rd.gz and hddapp.tgz einspielen. Diese drei habe ich ja, nur hat es beim letzten Mal (Firmware-Update über die Weboberfläche) eben nicht funktioniert...

Berthold
Es geht auch anders, aber so geht es auch.

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

4

Sonntag, 5. April 2009, 23:41

Hi, du solltest ein Bild hier im Beitrag auch anhängen können.
Sonst gibt es box.net oder rapidshare

Der SL3516 wird auch im DUAL-NAS-E (Giganas) verwendet, aber ich gehe mal davon aus, dass du eine andere Platine hast.

Der Bootloader ist immer vorhanden. Das ist vergleichbar mit dem Bios beim PC.
Den kann man dann mit der seriellen Konsole bedienen und die einzelnen Teile der Firmware (zImage, rd.gz and hddapp.tgz) wieder einspielen.
Nur wenn der gelöscht oder überschrieben wurde, muss man ihn wieder per JTAG in das Flash programmieren.

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

5

Montag, 6. April 2009, 00:38

Hier die Bilder

Danke HWguru für das kleine Wort "anhängen". Diese Möglichkeit hatte ich nämlich ein bißchen übersehen...
Hier also im Anhang die Bilder.

Übrigens habe ich auch an den Verkäufer geschrieben, um die Frage der Garantieleistung zu klären. Dann wäre die Hardware-Bastelei zwar überflüssig, aber auf jeden Fall: Vielen Dank für dieses Forum und den kompetenten Support, den Ihr (Du?) bietet.

Wenn an den Fotos was auffällt, bitte hier schreiben. Ansonsten warte ich nun die Verkäuferreaktion ab und würde - wenn das schwierig wird - den USB to RS-232 FT232R besorgen und mein Glück versuchen.

Schönen Gruß

Berthold
»beja7« hat folgende Dateien angehängt:
Es geht auch anders, aber so geht es auch.

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

6

Montag, 6. April 2009, 00:56

Hallo Berthold,
die Stiftleiste mit dem Elko schaut schon sehr nach der RS232 aus :)
Der Elko ist vermutlich ein notwendiger Patch und den würde ich unbedingt so lassen.

Der nicht bestückte 20 Pin Stecker dürfte der JTAG Anschluss sein.

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

7

Donnerstag, 9. April 2009, 08:52

Hallo HWguru,

Ich werde jetzt erst mal den Garantieweg gehen und hoffe, mit wenig Aufwand zu einem neuen (?) NAS zu kommen. Dennoch schon mal vielen Dank für die Unterstützung!

Eine andere Frage habe ich aber noch: Ich habe keinen root-Zugang zu dem Kästchen gekriegt (als es noch reagierte). Per Telnet konnte ich mich zwar als admin anmelden, aber als root-PW habe ich im Netz nur "admin" gefunden, was bei mir nicht funktioniert hat. Gibt es noch mehr bekannte werkseitige root-PW?

... für den Fall, dass demnächst bei mir auch wieder ein Kästchen läuft...

Danke,


Berthold
Es geht auch anders, aber so geht es auch.