Montag, 19. November 2018, 04:09 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Sonntag, 5. April 2009, 11:44

Filezilla FTP Übertragung auf Nas2000 bricht ab

Meine Uploads via Filezilla auf mein NAS 2000 brechen immer ab,sporadisch,ich übertrage im Passiv Mode,unten habe ich mal den letzten Teil des Übertragungsprotokolls angehangen.

Bin jetzt jetzt echt was überfragt was das sein kann,habe extra einen Verbindungserhaltungsbefehl eingesetzt,aber irgendwann bringt der auch nichts mehr,die Verbindung wird einfach beendet.Fehlercode 421..wie man am Ende des Protokolls lesen kann.
........

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
Antwort:	257 "/IDE1/filme" is current directory.
Status:	Sende Verbindungserhaltungs-Befehl
Befehl:	TYPE I
Antwort:	200 Type set to I
Status:	Empfange Verzeichnisinhalt...
Befehl:	PASV
Antwort:	227 Entering Passive Mode (192,168,13,29,4,6).
Befehl:	LIST
Antwort:	150 Opening ASCII mode data connection for file list
Antwort:	226 Transfer complete.
Status:	Anzeigen des Verzeichnisinhalts abgeschlossen
Status:	Sende Verbindungserhaltungs-Befehl
Befehl:	NOOP
Antwort:	200 NOOP command successful
Status:	Sende Verbindungserhaltungs-Befehl
Befehl:	PWD
Antwort:	257 "/IDE1/filme" is current directory.
Status:	Sende Verbindungserhaltungs-Befehl
Befehl:	PWD
Antwort:	257 "/IDE1/filme" is current directory.
Status:	Sende Verbindungserhaltungs-Befehl
Befehl:	PWD
Antwort:	257 "/IDE1/filme" is current directory.
Status:	Sende Verbindungserhaltungs-Befehl
Befehl:	PWD
Antwort:	257 "/IDE1/filme" is current directory.
Status:	Sende Verbindungserhaltungs-Befehl
Befehl:	NOOP
Antwort:	200 NOOP command successful
Status:	Sende Verbindungserhaltungs-Befehl
Befehl:	TYPE I
Antwort:	200 Type set to I
Status:	Sende Verbindungserhaltungs-Befehl
Befehl:	TYPE I
Antwort:	200 Type set to I
Status:	Sende Verbindungserhaltungs-Befehl
Befehl:	NOOP
Antwort:	200 NOOP command successful
Antwort:	421 No Transfer Timeout (300 seconds): closing control connection.
Fehler:	Verbindung vom Server geschlossen


Gruß Sam

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

2

Montag, 6. April 2009, 08:38

Liegt offensichtilich net am client, "Fehler:Verbindung vom Server geschlossen"

versuch mal "TimeoutIdle" in der proftpd.conf anpassen... Sollte aktuell bei 300 stehen - probier mal 3600 (ist ne stunde).

Kurzer Nachtrag: Der NOOP (no operation) nützt nicht so richtig viel. Eigentlich wird es von proftpd unterstützt aber... siehst ja selbst. :think:
Alternativ kannst du die verbindung mit nem list aufrecht halten.

Greetz.
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

3

Montag, 6. April 2009, 08:43

Moin,

danke für den Tipp ,werd das mal anpassen,weiß im Moment aber noch gar nicht wie ich an die proftpd.conf komme,sorry kann aber auch noch an der Uhrzeit liegen *gähn :-)

Oder kannst du mir da eben schnell auf die Sprünge helfen??

Auf welchen Wert soll ich die denn dann stellen,wenn ich die conf gefunden habe?

VG Sam

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

4

Montag, 6. April 2009, 08:52

die proftpd liegt unter root/usr/hddapp/etc

Wert: 3600 ist ne Stunde, 7200 2 und so weiter. Wie Du magst.

Ändern:

1.) ftp server stoppen (z.B. via Web-Gui ... ausschalten)

2.) als root auf die Box
3.) die proftpd.conf öffnen und die Timeouts eintragen / anpassen:

TimeoutIdle 600 # Inaktivitaet
TimeoutNoTransfer 3600 # keine Datenuebertragung (Listing, File, ...)
TimeoutStalled 300 # haengende Datenuebertragung
TimeoutSession 7200 # Gesamtdauer einer Session


4.) proftpd.conf speichern
5.) den ftp server wieder einschalten (via web gui oder Konsole)
Testen.
Posten. :-)
Greetz
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

5

Montag, 6. April 2009, 08:57

OK,geb später Bescheid,muss jetzt weg,vielen Dank für Deine Hilfe!!!

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »sam« (6. April 2009, 13:48)


snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

6

Montag, 6. April 2009, 09:05

Glaub schon. Oder das vom Admin. Probier einfach mal :happy: .

ich gehe erstmal :coffee: .

Gr.
Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

7

Montag, 6. April 2009, 13:21

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
ServerName "NAS FTPD"
ServerType standalone
DefaultServer on
DefaultRoot /mnt

CharsetLocal UTF-8
CharsetRemote CP950

SystemLog /var/log/messages
Port 21
Umask 006
MaxInstances 30


.........
usw

Ähm bei mir gibts da gar nichts mit Timeouts.....wie sollte das denn aussehen?

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »sam« (6. April 2009, 17:18)


8

Montag, 6. April 2009, 13:46

ist das so OK?

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
ServerName "NAS FTPD"
ServerType standalone
DefaultServer on
DefaultRoot /mnt

CharsetLocal UTF-8
CharsetRemote CP950

SystemLog /var/log/messages
Port 21
Umask 006
MaxInstances 30
TimeoutIdle 3600 # Inaktivitaet
TimeoutNoTransfer 3600 # keine Datenuebertragung (Listing, File, ...)
TimeoutStalled 300 # haengende Datenuebertragung
TimeoutSession 7200 # Gesamtdauer einer Session 

......................
...................
usw

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »sam« (6. April 2009, 17:18)


HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

9

Montag, 6. April 2009, 13:51

Hi,
schau mal auf die proftpd Homepage. Dort gibt es unter "Support" eine Liste der möglichen Direktiven.

Es kann aber sein, dass nicht alle von der Version am Nas unterstützt werden.

Mit "proftpd -l" kann man die "Compiled-in modules" herausfinden und mit "proftpd -V" sieht man mit welchen Features es kompiliert wurde.

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

10

Montag, 6. April 2009, 13:55

HI Du 8o ,

Danke für den Tipp ich habe das jetzt mal so wie o.g eingefügt ,werde das ganze gleich nochmal testen,wenn´s dann immer noch nicht funktioniert werde ich bei proftpd mal auf der HP vorbeischauen.

Geb aber auf alle Fälle Bescheid ob´s geklappt hat oder nicht.

Gruß Sam

11

Montag, 6. April 2009, 17:22

...scheint was gebracht zu haben,denn ich habe eben mal 1,7GB hochgeladen,ab und an setzte er zwar den Noop Befehl ab, und ich dachte schon ,gleich ist Schluss ,aber er hat schön alles geuppt :-)

...was mir nur aufgefallen ist,die Statussanzeige des uploads war schon bei 100% ,obwohl noch 300MB fehlten,die aber trotzdem hochgeladen wurden??!!

Damit kann ich aber leben!!!

Gruß Sam

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

12

Dienstag, 7. April 2009, 08:35

Moin Sam,

na, das sieht doch gut aus! Bei 1,7 GB sind 300 Mb dem sogenannten "Rest" zuzuschreiben - die Statusanzeige ist da bei manchen Tools zu langsam oder sonst was. Hatte ich auch schon beobachten können.

Der NOOP wird von Filezilla gesendet - den musst Du denn unter den Einstellungen einfach mal ausschalten - brauchen tust Du ihn ja nicht.

So wie das Log ausschaut sollte es passen. Die Commands sollten alle implementiert sein. Also: Freuen.

Eine Kleinigkeit am Rande: Schaltest Du das NAS aus (oder rebootest) sind die Einstellungen in der proftpd.conf weg. Am besten Du nimmst dafür das do_it und änderst da die proftpd.conf

Greetz.
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)