Freitag, 24. November 2017, 02:42 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Donnerstag, 4. Juni 2009, 11:23

NAS 2000 Frimware update

Hallo @ ALL

Das Forum ist ja ech super gewachsen. Habe aber leider trotz der Suche nichts Passendes für mein Problem gefunden.

Habe ein NAS 2000.
Format : ext2
Über ein Jahr lief das Teil mit der 2.3.3 (ja die Drei (nicht die Zwei) am Ende) FW ohne Problem durch...ich weiß leider nicht, wo ich die Firmware gefunden habe...
Letzte Woche fingen die Probleme an, dass ich zwar Ordner erstellen, aber keine Dateien mehr löschen konnte.
Die User hatten alle Schreibrechte.
Bin dann mal auf die dumme Idee gekommen, die FW2.3.2.IB.2.RS.1 von der Original-Seite drauf zu packen.
Hat auch wunderbar geklappt, ABER seitdem steht meine Version auf 1.0.0 ???????????
Ich kann nur schön im Menü rum springen und die IP verändern, das wars auch schon... kann keine User einrichten, keine Gruppe anlegen, u. u. u.

Kenn jemand vielleicht das Problem schon????

danke euch

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

2

Donnerstag, 4. Juni 2009, 13:08

Hi selk,

erstmal wilkommen im forum.

Eine 2.3.3 ist mir ehrlich gesagt noch nicht unter gekommen - wäre cool, wenn Du nochmal schaust, woher Du diese hattest. Meines Wissens gibts ne 3er nur für andere RS Produkte, nicht für das 2000er.

Zur Firmware: bei RS heißt es: Firmware Upgrade IB-NAS1000/2000 nur für Firmware größer als 2.0 (auf FW2.3.2.IB.2.RS.1) - vermute mal hier liegt der Fehler. Wenn die ursprüngliche 2.3.3 nicht als 2er FW erkannt wurde sondern als 1er klappt der FW Wechsel nicht. Meines Wissens musst Du dich erstmal wieder hoch hangeln auf ne 2er version und denn das Update auf die 2.3.2.IB.2.RS.1. Evtl. gibts noch HW Voraussetzungen, die erfüllt sein müssen (je nachdem wie alt die BOX ist kann das relevant sein). Infos dazu gibts auf der RS page.

Greetz. Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

3

Donnerstag, 4. Juni 2009, 13:23

Hallo snoopy

Vielen Dank für die rasche Antwort.

Hmmm, habe es mir schon fast gedacht.
Dann warte ich erst mal den Adapter von RS ab (für RS232 Kabel)... ohne geht es, wie ich es gelesen habe, von 1.x auf 2.x nicht....
Ich melde mich wieder, falls es zu weiteren Problemen kommt....

Vielen Dank für deine Hilfe

...selk

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

4

Donnerstag, 4. Juni 2009, 13:53

Hi,
hier noch ein paar Ergänzungen.

- Die Version 2.x hat gegenüber 1.x eine andere Aufteilung im Flash und deshalb muss der ganze Flashinhalt ersetzt werden.
Dabei wird auch der Bootloader überschrieben. Wenn du etwas falsch machst, ist der kaputt und du brauchst ein JTAG Kabel.

- Upgrade sollte auch per Netzwerk und ohne seriellem Kabel gehen Wikiartikel - aber vorher genau informieren!
Das Kabel ist aber sehr nützlich um Zugriff auf die Konsole zu erhalten und eventuelle Fehlermeldungen beim Booten zu sehen.

- Hardware Einschränkungen gibt es keine - alle NAS1000 und NAS2000 sind bis jetzt gleich

- du hast ziemlich sicher ein Problem mit der /system Partition auf der Festplatte
Die wird beim Formatieren der Platte eingerichtet, dort ist das Web If gespeichert und die Usereinstellungen werden auch dort abgelegt

Bevor du irgendetwas weiter machst, musst du ein Backup deiner Daten machen.
zB per USB und einem Linux System (eventuell von einer live CD starten).

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

5

Donnerstag, 4. Juni 2009, 14:36

Hallo HWguru

vielen Dank für deine Antwort
- du hast ziemlich sicher ein Problem mit der /system Partition auf der Festplatte
Die wird beim Formatieren der Platte eingerichtet, dort ist das Web If gespeichert und die Usereinstellungen werden auch dort abgelegt
Das Problem ist, dass sich die Festplatte über den Browser nicht mehr formatieren lässt.
Ich versuche die Platte mal über USB zu formatieren. Vielleicht geht es danach über NAS...
Schaue mir die Wiki-Seite genauer an....und versuche es aus...thx

Danke

...selk

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

6

Donnerstag, 4. Juni 2009, 15:05

Wenn du die Partitionen von der Platte löschst, sollte Formatieren wieder möglich sein.
lG
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

7

Donnerstag, 4. Juni 2009, 20:24

Hallo

Habe die Vorschläge auf der WIKI-Seite befolgt, aber leider keine Verbindung bekommen...
Die Festplatte über USB formatier.(unterschiedliche Formate ausprobiert).
Über die Weboberfläche komme ich nur bis zur Loginseite und nach eingabe sehe ich nur noch eine leere Seite, egal wie oft ich aktuallisiere....hmm
Werde erstmal mit dem Adapter ausprobiert, wenn es mal da ist.... wenn das nicht geht, dann schicke ich es am besten zurück...Hat noch ein paar Monate garantie

danke für eure Hilfe

...selk

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

8

Donnerstag, 4. Juni 2009, 20:46

Ich würde mal noch die Partitionen entfernen ....

An USB anschließen,

Windows Systemsteuerung -> Verwaltung -> Datenträgerverwaltung --> Rechtsklick auf die Plattenpartitionen und löschen.

Formatieren allein nützt wenig ;)

Greetz.
Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

9

Donnerstag, 4. Juni 2009, 20:52

doch doch...

Das hatte ich vor der Formatierung gemacht....
Ich hoffe, dass ich es nicht kaputt geflasht habe...


...selk

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

10

Donnerstag, 4. Juni 2009, 20:57

Warten wir einfach auf das Kabel ... wird schon wieder ... mit oder ohne Garantie ;)
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

11

Freitag, 5. Juni 2009, 08:14

HI,
habe ich doch glatt noch was vergessen.

Boote dein NAS ohne Festplatte. So startet das NAS in der Grundkonfiguration (zB holt sich eine IP vom DHCP Server).

Wenn dann die Web Oberfläche normal ausschaut, liegt das Problem an den Daten auf der Platte.
Wenn nicht, dann stimmt was mit der Firmware im Flash nicht.

Nachdem das NAS ja bootet, muss der bootloader per Netzwerk erreichbar sein. Am einfachsten geht das mit dem tool IcyBox_Flashstart.
Dann müsstest du ein komplettes Flash Image mit der Option X programmieren. Das funktioniert im Prinzip genau so wie im Dokument von Raidsonic für das Update von 1.x auf 2.x beschrieben steht.
Achtung: die Datei muss exakt 8MB groß sein!
Ein Image von der aktuellen Firmware findest du in der Database. Das Zip muss vorher entpackt werden. Der Vorgang dauert ca. 20 Minuten. In dieser Zeit geduldig warten bis wieder etwas am Bildschirm ausgegeben wird. Dann sofort die MAC Adresse ändern.

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

12

Freitag, 5. Juni 2009, 16:43

Hallo @ All

Habe mir die bin-Datei grad gezogen und werde es gleich ausprobieren.....

Ich danke euch für die schnelle Hilfe.... super Forum!!!!

...selk

13

Montag, 29. Juni 2009, 21:16

Hallo an alle in diesem gut sortiertem Forum. Bin leider erst heute auf euch "gestoßen". :thumbsup:
Ich habe ein Nas2000 mit der Firmware 1.3.3.IB.1.beta.2 (Nov. 7, 2006).das läuft soweit, aber es vergisst immer wieder seine Arbeitsgruppe. Warum auch immer. Nun habe ich vor einiger Zeit bei RS so ein Kabel angefordert, was leider nie ankam. Nun meine Frage, @HWguru du schreibst in diesen Beitrag weiter oben das das Update von Firmware1 zu 2 auch übers Netzwerkkabel geht und wenn ich das richtig verstehe ich das Kabel von RS gar nicht brauch. Oder habe ich einen Denkfehler? Wäre für jede Hilfe Dankbar. :worthy:

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

14

Montag, 29. Juni 2009, 23:46

Hallo und willkommen sekretär!
Ja, das geht auch ohne Kabel.
Mit IcyBox_Flashstart und dem Flash Image aus dem Raidsonic Upgrade für 1.x auf 2.x oder dem Image aus der Databse wie vorher schon beschrieben (muss exakt 8MB groß sein) und der Option X (upgrade boot).

Anschließend nicht vergessen die MAC Adresse auf die richtige zu programmieren.

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

15

Dienstag, 30. Juni 2009, 17:10

So, die Datei hab ich. Danke. Was wird mit den Daten auf der Platte. Wird da formatiert oder oder sollte ich die besser ausbauen?

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

16

Dienstag, 30. Juni 2009, 17:44

Hi,
Platte ausbauen und anschließend versuchen ohne Platte zu booten.

Ich würde dir aber ganz dringend ein Backup raten.
Das Web If ist auf der system Partition gespeichert und daher kann es sein, dass du die Platte formatieren musst.

lG
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

17

Dienstag, 30. Juni 2009, 21:24

Gibt es dafür eine Anleitung in Deutsch, welchen Befehl ich nach "IcyBox_Flashstart" und nach machen muß? Und das mit der Mac-adresse ist mir auch noch ein Rätsel. Aber ich glaube es ist so, das wenn ich die Firmware einspiele die Mac-adresse vom ersteller habe oder?

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

18

Dienstag, 30. Juni 2009, 21:49

Um etwas Englisch wirst du nicht herum kommen.
Fürs Web funktioniert die Google Übersetzung nicht schlecht und in dem Raidsonic Dokument sind ja sehr viele Bilder enthalten. Das sollte doch reichen.
Als MAC Adresse musst du die von dem Aufkleber auf deinem NAS wieder programmieren.

lG HWguru

wir haben einen Chat hier...
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

19

Dienstag, 30. Juni 2009, 22:10

Englisch mit Google geht so, nur ich finde bei RS nur die Anleitung mit dem upgrade via RS-232 adapter und Hyper Terminal. Wenn du mir noch mal helfen kannst? Ansonsten nehme ich dein Angebot mit dem Chat gern an. Aber erst morgen Abend. Muß erst alles sichern.das dauert noch. ;)

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

20

Dienstag, 30. Juni 2009, 22:34

Funktioniert per telnet exakt so wie per RS232, außer dass man während des Flashvorganges nichts sieht und die Ganze Ausgabe erst am Ende kommt. Wichtig: ca. 20 min. warten und das ganze Setup in Ruhe lassen und nichts im telnet tippen.

Du kannst eventuell auch die Usereinstellungen per Web abspeichern. Vielleicht kann man das dann wieder laden. Wobei ich nicht weiß ob 1.x mit 2.x kompatibel ist. Aber das kann man ja dann versuchen.
Sicherst du die Platte per USB? Das geht viel schneller als per Netzwerk.

lG
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!