Samstag, 25. November 2017, 01:08 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

SERV

Anfänger

Beiträge: 6

Wohnort: france

1

Sonntag, 12. Juli 2009, 22:37

Problem of unbrick of Sohonas verbatim by JTAG

hello,
I have a wiggler JTAG20 of @ebay from vitualvillage-de.
I followed the tutorials forum. (R28 shorted, J5 pin 1 or 2 connected to pin 17)

I have a problem with the software NAS_FlashTool 2.0.2.765.
I can not write the redboot.
Here is the error :

Cable type 1 detected.
Device is in debug-mode - OK

CPU-Type SL3316 detected.

Flash-Manufacturer: 0x2001
Flash-Device-ID: 227e-2210-2200
Flash type - unknown!

Some errors detected!

Erasing Flash. Please wait - done.
Write data to Flash.
0.0 / 128.0
Flash-Write error at: 0x00000002



thank you in advance for your help

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

2

Dienstag, 14. Juli 2009, 17:46

Hello and welcome!

Please could you turn on the "verbose mode" and post the result again.

The message "Flash type - unknown!" is not good :thumbdown: Either there is a hardware problem or this flash is not known by our tool.
Could you look at the chip and tell me of what type it is?

Kind regards,
HWguru.
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

SERV

Anfänger

Beiträge: 6

Wohnort: france

3

Dienstag, 14. Juli 2009, 21:08

Good evening,

The chip is a STORLINK : SL3316-G ; 0608 ; USD27C6 - 010A3
See a photo :



Here is the information requested :

Testing cabletype 1
JTAG-IDCODE: 0x00526fa1 - OK
Bypass-test: 0xaaab5554 - OK

Testing cabletype 2
JTAG-IDCODE: 0xffffffff - not OK
Expected: 0x00526fa1
Bypass-test: 0xffffffff - not OK
Expected: 0xaaab5554

Cable type 1 detected.
Device is in debug-mode - OK

Reading CPU-Type (SL3316)
CPU-ID: 0x003316 - OK
CPU-Rev.: 0xa3

Flash-Manufacturer: 0x2001
Flash-Device-ID: 227e-2210-2200
Flash type - unknown!

Some errors detected!



Erasing Flash. Please wait
Sector 0x70000000: Erase time: 80 [ms]
Sector 0x70010000: Erase time: 280 [ms]
- done.
Write data to Flash.
0.0 / 128.0
Flash-Write error at: 0x00000002
Flash-Write statistic
Number of retries: 1
Max. retry count: 9

THANKS AGAIN
;)

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

4

Mittwoch, 15. Juli 2009, 00:10

Hello,
you gave me the CPU type.
I need the flash type. This is the chip with the "Spansion" marking.

Was the nas working before? How did you loose the bootloader?
Have you checked the power. Is the 3.3V ok?

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

SERV

Anfänger

Beiträge: 6

Wohnort: france

5

Donnerstag, 16. Juli 2009, 00:13

Good evening,

The flash type : S29GL064A90TFIR4

Her, the photo :


Yes it worked before, I lost the bootloader in flash the firmware and the flash failed.

The 3.3 V what level, NAS or jtag?
NAS = OK (pin 1->20, NAS powered) = 3.3V
JTAG = which points ?


thank you again :) ;)



HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

6

Donnerstag, 16. Juli 2009, 09:01

Hi,
the flash on your board is the standard type. It has been supported from the first software releases.

FlashTool reports "Flash-Manufacturer: 0x2001" - this is wrong! It should report 0x0001 for Spansion.

Seems to be some electrical problem.
- Do you have a good GND connection?
- could you try another PC?
- cables should be as short as possible

- have you tried the older release 2.0.1.745 of FlashTool?

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

SERV

Anfänger

Beiträge: 6

Wohnort: france

7

Donnerstag, 16. Juli 2009, 23:44

Hi,

I put the GNDs together.
I tried with 3 different pc.
The JTAG is
connected directly without extension
But unfortunately nothing has
changed. ;(

Where are older versions of FLASTOOL?


Thanks

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

8

Freitag, 17. Juli 2009, 08:45

Very strange indeed :hmm:

Here you find the two mentioned versions.

Only for being sure - at leas you connected GND, TDI, TDO, TCK, TMS, VCC (3.3V) with the nas?
You could connect the 20 pin cable with both connectors directly if you add the connection 1-17.

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

SERV

Anfänger

Beiträge: 6

Wohnort: france

9

Sonntag, 19. Juli 2009, 01:34

HELLO,

Always the same with both versions and I also checked the connections.
For against, I ordered a FTDI FT232R USB, I need it for something else but I will test to see if I'm the same.

thank you for everything, until FT232.

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

10

Sonntag, 19. Juli 2009, 02:05

Ok,
normally it is not that complicated.
I am very interested if you are more lucky with the FT232 adapter. Anyway I feel the FTDI device to be very good.

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

SERV

Anfänger

Beiträge: 6

Wohnort: france

11

Sonntag, 9. August 2009, 20:58

Good evening,

I have received the FT232.
Unfortunately, it is still the same.



JTAG TEST:

Cable type 3 detected.
Device is in debug-mode - OK

CPU-Type SL3316 detected.

Flash-Manufacturer: 0x2001
Flash-Device-ID: 227e-2210-2200
Flash type - unknown!

Some errors detected!




WRITE BOOT in mode verbose output:

Erasing Flash. Please wait
Sector 0x70000000: Erase time: 20 [ms]
Sector 0x70010000: Erase time: 50 [ms]
- done.
Write data to Flash.
0.0 / 128.0
Flash-Write error at: 0x00000002
Flash-Write statistic
Number of retries: 1
Max. retry count: 9

Thank-You.