Wednesday, September 19th 2018, 11:07am UTC+2

Giriş yapmadınız.

  • Giriş
  • Kayıt

Sayın ziyaretçi, NAS Forum sitesine hoş geldiniz. Eğer buraya ilk ziyaretiniz ise lütfen Yardım bölümünü okuyunuz. Yardım bölümü bu sitenin nasıl çalıştığını açıklamaktadır. Site özelliklerinin tümünü kullanabilmeniz için öncelikle kayıt yaptırmanız gerekmektedir. Kayıt yaptırmak için kayıt formunu okuyabilir ya da kayıt işlemi hakkında daha fazla bilgi edinebilirsiniz. Eğer önceden kayıt yaptırdıysanız, buraya tıklayarak giriş yapabilirsiniz.

1

Wednesday, December 2nd 2009, 11:11pm

NAS4220 - Problem mit serieller Verbindung - keine Eingabe möglich

aloha,

durch dummheit hab ich mir leider mein nas 4220 zerballert.dank euren guides bin ich wieder soweit das ich nen booloader am laufen hab :).habe mir nen FT232R (http://cgi.ebay.com/ws/eBayISAPI.dll?Vie…E:X:AAQ:US:1123) besorgt. nun zu meinem problem wenn ich über seriell kernel usw flashen möchte kann ich den bootvorgang nicht abbrechen. ich kann strg+c drücken bis ich blasen an den fingern hab es tut sich einfach nix :(. habe es noch mit nem handydatenkabel versucht dort aber genau des selbe. einstellungen an putty helfen leider auch nicht.

danke schonmal

gruss manuel


habe noch den log vom flashtool und von putty nach flashen dranngepackt (die ausgabe von putty is ne endlosschleife)

Kaynak kod

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
Cable type 3 detected.
Device is in debug-mode - OK

CPU-Type SL3516 detected.

Flash-Manufacturer: 0x01
Flash-Device-ID: 227e-2221-2201
Flash type No bootsector - OK


Erasing Flash. Please wait - done.
Write data to Flash.
 128.0 /  128.0 - done.
Verifying Flash.
Read data from Flash.
 128.0 /  128.0 - done.
Verify: No difference found.




PUTTY:

Storlink SL351x Boot Loader [Linux], version 1.0.9
Built by linux, 17:55:15, Jul 11 2007

Processor: SL3516c2
CPU Rate: 300000000
AHB Bus Clock:150MHz	Ratio:2/1
MAC 1 Address: 00:50:C2:11:11:11
MAC 2 Address: 00:50:C2:22:22:22
inet addr: 192.168.0.200/255.255.255.0
==> enter ^C to abort booting within 3 seconds ......
Load Kern image from 0x30020000 to 0x1600000 size 3145728
Load Ramdisk image from 0x30320000 to 0x800000 size 6291456


Failed to change IP address due to illegal value
Failed to change IP Gateway due to illegal value

HWguru

NAS2000-Team

Mesajlar: 1,001

Konum: Wien

2

Thursday, December 3rd 2009, 9:34am

Hallo Manuel,
herzlich willkommen bei uns!

Der Bootloader ist einmal sicher ok, weil auch beim Schreiben ins Flash ein Verify der Daten gemacht wird.

Dass man bei der seriellen Verbindung nichts eingeben kann, habe ich schon mehrmals gelesen.
Eine richtig plausible Erklärung ist mir leider noch nicht untergekommen.
Ich glaube dass es jemand geschafft hatte indem er erst kurz nach dem Einschalten Tx des Adapters mit dem NAS verbunden hatte.

Langsam wäre es mal an der Zeit herauszufinden woran das wirklich liegt ;(

Hier noch ein Paar Dinge die zu prüfen wären:
- funktioniert der RS232 Adapter alleine (Loopback von Rx - Tx)
- GND Verbindung ok?
- Adapter richtig gejumpert und VCC verbunden?

Eventuell hat der Bootloader ja noch ein Problem mit irgendwelchen Daten im Flash.

Wir sollten uns im Chat treffen.

lG HWguru

P.S. bitte beginne auch mal eine neue Zeile und verwende Großbuchstaben, das verbessert die Lesbarkeit :whistling:
Ich habe mir erlaubt den Titel noch zu erweitern - das hilft bei der Suche im Board
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

3

Thursday, December 3rd 2009, 10:08am

danke schonmal.Sorry das mit der gross-klein schreibung hab ich mir irgendwann mal abgewöhnt.
Ähm wann bist du denn zu erreichen ? Hab zur zeit spätschicht, also von 14-22 uhr maloche.


gruss

manuel

edit.
Das Handykabel hat vorher funktioniert. Damit hab ich den Kasten ja ins Nirvana geschickt :P

Bu mesaj 1 defa düzenlendi; son düzenleyen "bepp0" (Dec 3rd 2009, 10:16am)


HWguru

NAS2000-Team

Mesajlar: 1,001

Konum: Wien

4

Thursday, December 3rd 2009, 10:27am

Das Handykabel hat vorher funktioniert. Damit hab ich den Kasten ja ins Nirvana geschickt :P

...stimmt - ist natürlich ein gutes Argument

Dann liegt es vielleicht doch an den Daten.

Es hat einmal jemand einen Bootloader gebaut, der die weiteren Firmwareteile von der Platte bootet. Wäre eventuell einen Versuch wert.
Eventuell kann man dann die Flash Tool von Elektroman verwenden.

Ich bin viel online - einfach schauen.

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

5

Thursday, December 3rd 2009, 11:05am

So ich hab jetz nochmal alles zerlegt wieder zusammengebaut. Gehe nochmal deine tips durch evtl tut sich ja was.



gruss

manuel

edit.

Problem gelöst.Die pinbelgung auf nas-wiki war falsch (GND und VCC vertauscht).Nun funzt alles wie es soll :thumbsup: .

Bu mesaj 1 defa düzenlendi; son düzenleyen "bepp0" (Dec 4th 2009, 11:55pm)


HWguru

NAS2000-Team

Mesajlar: 1,001

Konum: Wien

6

Saturday, December 5th 2009, 12:04am

Hi,
super, dass es doch keine Geister gibt!

Das Bild von der Anschlussbelegung in der NAS4220 Unbricking Anleitung im Wiki habe ich korrigiert.

Nochmal zur Sicherheit - Pin 10 (außen) ist VCC und Pin 5 (mittig) ist GND.

lG HWguru

P.S. Da unser Problem gelöst ist :closed:
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!