Samstag, 16. Dezember 2017, 15:55 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Samstag, 26. Dezember 2009, 19:33

Probleme beim Formatieren / Passwort für NAS-2000

Hallo an alle,

ich habe seit kurzem ein NAS2000 (Aktuellste Firmware von Raidsonic über Firmwareupdate aufgespielt) mit einer Hitachi HDS722020ALA (2TB, SATA).
Die Festplatte wird über das Webinterface mit der richtigen Größe erkannt und ich kann auf den Button Formatieren klicken. Über USB kann ich auch mit einer NTFS-Formatierung auf die Festplatte zugreifen (schreiben+lesen).
Jetzt zu meinem Problem:
Ich kann die Platte schlecht oder gar nicht formatieren. Selbst nach 3 Tagen Formatieren zeigt der Fortschrittsbalken 0% an.
Dies gilt für alle Formatierungsmöglichkeiten (EXT2 mit und ohne Verschlüsselung und EXT3), wobei ich schon versucht habe die Platte vorher auf NTFS,EXT2 und EXT3 zu formatieren.
Auch das Löschen aller Partitionen hat zu keinem Erfolg geführt. Im Gegensatz zu einer Formatierung über die USB-Schnittstelle leuchtet die HDD-Lampe nicht konstant, sondern nur in regelmäßigen Abständen.
Die letzte Formatierung (EXT3 vorformatieren->EXT3 Zielsystem) habe ich nach 3 vollen Tagen abgebrochen und die Box neu gestartet. Seitdem kann ich mich nicht mehr über das Standardpasswort anmelden, obwohl ich dieses nicht verstellt habe. Wenn ich die Box über USB starte, sehe ich eine korrekt formatierte Festplatte mit diversen Verzeichnissen (hddapp/lost+found/USR).

Wie kann ich das Passwort der Box über USB ändern? Brauche ich bei einer so großen Platte nur mehr Geduld beim formatieren oder ist die Hardware defekt?

Ich würde mich freuen, wenn Ihr mir hier weiter helfen könnt, da mir langsam die Ideen ausgehen.

Gruß

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

2

Sonntag, 27. Dezember 2009, 00:51

Servus,
mir kommt da was komisch vor. Welches NAS hast du wirklich?
Das Raidsonic NAS2000 hat kein SATA Interface sondern ein ATA für die Festplatte.

Einstellungen wie Username etc. werden auf der Platte in einer etwas undurchsichtigen Datenbankähnlichen Verzeichnisstruktur gespeichert.
Wenn dort etwas schief gelaufen ist, kann ich mir den Effekt erklären. Platte löschen, am besten auch den MBR.

Jedenfalls glaube ich nicht, dass das Formatieren so lange dauert.

Ein Zugang zur Konsole über die serielle Schnittstelle (mit 3.3V Adapter) würde sehr helfen.

Wie sind deine Linux Kenntnisse?

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

3

Sonntag, 27. Dezember 2009, 13:47

Danke HWguru für die schnelle Antwort!

Das heißt also, dass ich keine Chance habe, das Passwort der Box ohne Webinterface zu verändern.

Ich habe tatsächlich das NAS2000 und die SATA-Platte über einen IDE-SATA-Adapter angeschlossen.
Mich überrascht es, dass ich über USB problemlos auf die Platte schreiben kann und das selbst dann wenn sie ein NTFS-Format besitzt.

Ich besitze leider nur Linux-Grundkenntnisse und verwende wenn nötig Live-CD's. Wird beim Löschen der Partition über GParted der MBR automatisch mit gelöscht?

Zudem habe ich heute festgestellt, dass ich mit meiner alten Benutzerkennung (Benutzername/Passwort) über FTP Zugang zur Box habe.
Es ist über FTP möglich mit der alten Benutzerkennung auf ein admin- und ein public-Verzeichnis zuzugreifen.
Ist es evtl. möglich die Samba-Benutzerkennung mit der FTP-Benutzerkennung zu überschreiben?

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

4

Sonntag, 27. Dezember 2009, 16:07

Zitat

Das heißt also, dass ich keine Chance habe, das Passwort der Box ohne Webinterface zu verändern.
das würde ich nicht sagen, es ist nur schwer zu erraten in welchem Zustand deine Installation ist

Zitat

Ich habe tatsächlich das NAS2000 und die SATA-Platte über einen IDE-SATA-Adapter angeschlossen.
das hat du uns ja verschwiegen :rolleyes:

Zitat

Mich überrascht es, dass ich über USB problemlos auf die Platte schreiben kann und das selbst dann wenn sie ein NTFS-Format besitzt.
mich nicht, weil da das Betriebssystem nicht läuft und der Zugriff in Hardware passiert - wie bei einem normalem USB Gehäuse. Hatten wir als Beitrag schon irgendwann.

Zitat

Wird beim Löschen der Partition über GParted der MBR automatisch mit gelöscht?
puhh, eher nein, Partitionen löschen ginge per Windows auch. Und der MBR bei Dos/Windows mit "fdisk /mbr" Mit "hutil" von Samsung hat es auch schon jemand gemacht.

Note: seltsamerweise geht die Suche hier im Forum nach "mbr*" einfach nicht. Muss etwas mit der Datenbank zu tun haben. Normal gehen 3 Zeichen plus * schon ;(

Zitat

Es ist über FTP möglich mit der alten Benutzerkennung auf ein admin- und ein public-Verzeichnis zuzugreifen.
Ist es evtl. möglich die Samba-Benutzerkennung mit der FTP-Benutzerkennung zu überschreiben?
per ftp wird es schwierig.

Hast du die aktuellste Firmware drauf?
Eventuell könntest du per ftp das Paket zur Aktivierung des telnet drauf kopieren.
Wie schaut es mit dem Zugang zur Konsole aus? Da sieht man eventuelle Fehlermeldungen und kann sich als root anmelden. Schaut so aus als ob deine Box soweit bootet.

Hab jetzt leider keine Zeit - vielleicht abends im Chat?

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

5

Sonntag, 27. Dezember 2009, 21:37

Hallo,
da ich auch gerade mit dem IDE/SATA-Problem gekämpft habe,3 verschiedene Adapter ausprobiert habe ,denke ich,es könnte auch bei Dir der Adapter die Probleme machen.Ich weis zwar nicht,welchen du eingesetzt hast,ich habe jetzt den von Ultron UAS-100 und der läuft ohne Probleme.

MFG 3306

6

Montag, 28. Dezember 2009, 15:08

Ich habe die neuste original Firmware auf die Box gespielt. Das Flashen hat problemlos funktioniert.
Würde Tinky evtl. helfen?

Der Zugang unter FTP funktioniert nur eingeschränkt, ich kann zwar die Verzeichnisstruktur lesen, aber nur kleinere Files speichern (<10MB).

Werde jetzt erstmal versuchen den MBR zu löschen. Ich hoffe das ich die Box durch diesen Schritt zum laufen bringe.

Das Anmelden über die Konsole scheint sehr aufwändig zu sein, da ich momentan kein Kabel für den entsprechenden Zugang besitze.
Bevor ich Lötübungen starte oder nochmals Geld in die Hand nehme, möchte ich gern alles andere Versuchen um die Box zum Laufen zu bringen.

Ich kann mir momentan nicht vorstellen, dass das Problem am IDE-SATA Adapter liegt, da die Platte in der korrekten Größe erkannt wird.
Wenn aber alle Stricke reißen sollten, werde ich mir den Adapter von Ultron zulegen. Vielen Dank!

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

7

Donnerstag, 31. Dezember 2009, 11:55

Moin,

na, so wie es ausschaut funzt das NAS (Firmwareupdate hat ja geklappt).

Versuch mal: eine alte IDE Platte (die sollte perfekt laufen) und / oder einen anderen Adapter, dazu hatten wir hier schon ein paar Beiträge.

Greetz
Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

8

Montag, 4. Januar 2010, 13:20

Ich kann jetzt normal auf das NAS zugreifen.

Um das zu erreichen bin ich folgendermaßen vorgegangen:

0 Ausgangszustand: 1 Partition NTFS

Schritt 1: Vorformatieren 3 Partitionen über USB (Ubuntu->Gparted)
Partition 1: 160MB EXT2
Partition 2: ca 1,9TB EXT2
Partition 3: 600MB Linux Swap

Schritt 2: Formatieren über die NAS-Benutzeroberfläche. Dabei wurde die Platte nicht wirklich formatiert, aber das NAS hat die für das System wichtigen Dateien auf die Festplatte geschrieben.
Das Formatieren hat weniger als 2min gedauert und wurde anders als bei den bisherigen Versuchen abgeschlossen. Nach dem Reboot des NAS konnte ich aber nicht mehr auf die Festplatte zugreifen, da mein Benutzername und mein Passwort nicht erkannt wurden.

Schritt 3: Erneutes Formatieren der Partition 2 (Ubuntu->Gparted). Beim Öffnen des NAS über USB wurde die 2.Partition als ungültiges Dateisystem angezeigt.

Schritt 4: Löschen des MBR der Festplatte (Ubuntu->Terminal->dd)

Erst nachdem ich diese Schritte durchgeführt hatte, konnte ich voll auf das NAS zugreifen und z.B. Benutzer anlegen.

Trotzdem bin ich mit dem NAS noch nicht zufrieden. Wenn ich über einen Laptop mit WLan auf das NAS zugreife, wird die Verbindung um NAS regelmäßig abgebrochen. Ein Upload von großen Datenmengen auf das NAS ist weder über FTP, noch über Samba möglich. Habt ihr ähnliche Erfahrungen gemacht?

Vielen Dank an alle, besonders an HWguru, für die hervorragende Unterstützung!

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

9

Dienstag, 5. Januar 2010, 18:01

Hi,

gehört nun eigentlich in ein anderes Thema. DAzu gabs auch schon Fragen und Antworten:

SAMBA = Bricht ab bei grossen Datenmengen

und ftp = ftp-server und passiv-mode

(eigentlich nur in der proftpd.conf die werte setzen:

UseReverseDNS off
IdentLookups off

<IfModule mod_delay.c>
DelayEngine off
</IfModule>

UseSendfile off

Möge es nützen!

Greetz snoopy

PS: www.gidf.de ;)
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)