Samstag, 25. November 2017, 06:54 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Montag, 28. Dezember 2009, 22:26

(gelöst) NAS 2000, wie einen seriellen Log erstellen?

Hallo,
Da ich blutiger Anfänger hiermit bin,bräuchte ich noch ein bisschen
Hilfe.Ich habe mir nun hier schon so vieles durchgelesen und sehe noch nicht richtig durch.

Ich benutze das NAS bis jetzt nur als reinen Datenspeicher in meinem Heimnetzwerk für DBox,Win XP-Rechner.

Laut der Anleitung von HWguru habe ich auf die CN6 -Buchse ein altes CD-Rom Audio-Kabel
aufgesteckt und aus dem NAS-Gehäuse rausgeführt.(Natürlich vorher
RX,TX,GND gekennzeichnet)Es ist ein ca. 50 cm langes abgeschirmtes
Kabel.Ich hoffe, dass das keine Probleme macht?

Dann habe ich mir noch so einen USB/RS232 -Adapter zugelegt,wie von HWguru empfohlen.

1. wie und mit welchem Programm kann ich nun so ein serielles Log erstellen?

2. Was kann man noch so mit der seriellen Schnittstelle machen?

3. Was hat das mit der Jtag-Schnittstelle auf sich und was kann man damit alles machen?


MFG 3306

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »3306« (28. Dezember 2009, 22:37)


HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

2

Dienstag, 29. Dezember 2009, 01:05

Hi,
schau' doch mal in die FAQ

Habe ich doch gestern schon etwas zusammengetragen...

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

3

Dienstag, 29. Dezember 2009, 23:22

Hallo HWguru,
in den FAQ`s ist schon mal Software-seitig einiges beschrieben,ich bräuchte aber Hardware- seitig noch ein bisschen Hilfe.Wie schon gesagt habe ich folgenden USB-Adapter:
[attach]220[/attach]

1.Ich habe aus dem NAS RX,TX,GND herausgezogen und am Adapter angeschlossen muß ich VCC 3,3 V auch herrausziehen oder kommt die Versorgungsspannung des Adapters vom USB-Anschluß?
2.Ich verbinde PC mit dem Adapter über USB, Putty greift doch aber per Com 1 Schnittstelle zu ,wie geht jetzt die Verknüpfung USB zu Com1 oder muß ich zusätzlich noch eine serielle Verbindung zwischen PC und Adapter herstellen?

MFG 3306

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

4

Mittwoch, 30. Dezember 2009, 08:08

Zitat

1.Ich habe aus dem NAS RX,TX,GND herausgezogen und am Adapter angeschlossen
passt, das ist immer notwendig

Zitat

muß ich VCC 3,3 V auch herrausziehen oder kommt die Versorgungsspannung des Adapters vom USB-Anschluß?
Das ist Adapterabhängig.

Bei diesem hat man per VCCIO Jumper 3 Möglichkeiten. Wobei der USB Chip selbst, immer durch den USB Port versorgt wird.
VCCIO ist nur für den Ausgang zuständig, damit kann er mit verschiedenen Spannungen betrieben werden. Das kann man aus der Dokumentation des Adapters entnehmen. Ich gebe zu, die Schaltung ist aber unübersichtlich.

1. kein Jumper - VCCIO muss mit VCC des NAS verbunden sein. Das ist die beste Option.

2. VCCIO-3VOUT gesteckt - VCCIO wird vom Chip internen 3.3V Regler versorgt. VCCIO darf nicht mit dem NAS verbunden sein.
3. VCCIO-VCC gesteckt - VCCIO wird vom USB Port versorgt. Für das NAS nicht erlaubt, weil dann die Ausgänge mit 5V betrieben werden.

Zitat

Ich verbinde PC mit dem Adapter über USB, Putty greift doch aber per Com 1 Schnittstelle zu ,wie geht jetzt die Verknüpfung USB zu Com1 oder muß ich zusätzlich noch eine serielle Verbindung zwischen PC und Adapter herstellen?
Wenn der Treiber installiert ist, wird der Adapter als neue COM Schnittstelle angezeigt.
Dann kann man in den Geräte-Manager nachschauen welcher COM Port verwendet wird und ihn auch eventuell umkonfigurieren - zB COM3.
Diese COM stellt man dann bei putty ein.

Zusätzlich muss die Lötbrücke bei RXD.JMP entfernt werden.
Sonst arbeitet der TX vom NAS gegen den TX von dem MAX232 Chip des Adapters.

Ich habe mir dort 4 einen kleinen Jumperblock aufgelötet.

Das ist die ganze Hexerei.

lG HWguru
»HWguru« hat folgende Datei angehängt:
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

5

Mittwoch, 30. Dezember 2009, 09:35

Hallo HWguru,
wenn ich das jetzt richtig verstanden habe muß ich :
1.
2. VCCIO-3VOUT gesteckt - VCCIO wird vom Chip internen 3.3V Regler versorgt. VCCIO darf nicht mit dem NAS verbunden sein.
2.
1.Ich habe aus dem NAS RX,TX,GND herausgezogen und am Adapter angeschlossen
..... und es müßte so gehen?
Zusätzlich muss die Lötbrücke bei RXD.JMP entfernt werden.
Sonst arbeitet der TX vom NAS gegen den TX von dem MAX232 Chip des Adapters.

Ich habe mir dort 4 einen kleinen Jumperblock aufgelötet.
Dann noch eine Frage,muß ich nur die Lötbrücke vom RXD auflöten oder auch TXD?
Wenn der Treiber installiert ist, wird der Adapter als neue COM Schnittstelle angezeigt.
Dann kann man in den Geräte-Manager nachschauen welcher COM Port verwendet wird und ihn auch eventuell umkonfigurieren - zB COM3.
Diese COM stellt man dann bei putty ein.
Das alles war für mich noch Neuland,Danke schon mal. :worthy:

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

6

Mittwoch, 30. Dezember 2009, 09:51

Zitat

Dann noch eine Frage,muß ich nur die Lötbrücke vom RXD auflöten oder auch TXD?
RXD genügt.

So kommen die gesendeten Zeichen bei TX und bei dem 9 poligen DSUB Stecker heraus.

Nur als Erklärung...
Zwei Eingänge (NAS und der MAX Chip) auf einem Ausgang (FTDI Chip) geht.
Zwei Ausgänge geht nicht, weil die sonst gegeneinander treiben.

Hwguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

7

Mittwoch, 30. Dezember 2009, 10:19

Hallo,
werde ich jetzt mal versuchen,melde mich wieder

MFG 3306

8

Mittwoch, 30. Dezember 2009, 12:18

Hallo,
habe nun alles miteinander verbunden,Putty gestartet, NAS eingeschaltet und nichts ist passiert.Habe dann alles noch mal geprüft und wieder abgeschlossen,dann nur wieder per Netzwerkkabel angeschlossen und nun ist das NAS nicht mehr erreichbar,auch per Icy Box searchNAS nicht.
Da habe ich wohl jetzt den Hauptgewinn?
Gute Frage,was habe ich jetzt verkehrt gemacht?
vielleicht verkehrt am Adapter angeschlossen,ich habe die untere Anschlußleiste mit den Anschlüssen GND,TXD,RXD,RTS# usw. genommen.
folgendes Erscheinungsbild:
-eigentlich alles normal,Festplatte fährt hoch,Netzwerk-Leds leuchten beide,die grüne flackert öfters.

Bitte um Hilfe

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

9

Mittwoch, 30. Dezember 2009, 13:21

Zitat

vielleicht verkehrt am Adapter angeschlossen,ich habe die untere Anschlußleiste mit den Anschlüssen GND,TXD,RXD,RTS# usw. genommen
nein, stimmt soweit.
Wenn keine Ausgabe kommt, kann Rx-Tx vertauscht sein.

Tx vom NAS gehört auf Rx vom Adapter und umgekehrt. (Weil: Sender --> Empfänger)
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

10

Mittwoch, 30. Dezember 2009, 22:52

Wenn keine Ausgabe kommt, kann Rx-Tx vertauscht sein.

Tx vom NAS gehört auf Rx vom Adapter und umgekehrt. (Weil: Sender --> Empfänger)
Habe ich definitiv verkehrt gemacht,kann dadurch mein NAS gestorben sein?(Da ich ja kein Netzwerkzugang mehr erhalte)

MFG 3306

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

11

Donnerstag, 31. Dezember 2009, 02:44

kann dadurch mein NAS gestorben sein
nein, eher nicht.

Bekommst du keine Ausgabe?
Prüfe noch die Einstellungen bei putty. Eventuell Rx mit Tx des Adapters verbinden (ohne NAS) und schauen ob du ein Echo bekommst.
19200 N 8 1, kein Hardware Handshake

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

12

Samstag, 2. Januar 2010, 22:13

Bekommst du keine Ausgabe?
Prüfe noch die Einstellungen bei putty. Eventuell Rx mit Tx des Adapters verbinden (ohne NAS) und schauen ob du ein Echo bekommst.
19200 N 8 1, kein Hardware Handshake

wie mache ich das jetzt?RXD-TXD direkt am Adapter überbrücken?wie muß ich putty überhaupt so einstellen?Wie mache ich das so mit dem Echo prüfen?Ich habe noch nie mit putty gearbeitet und möchte jetzt nicht noch mehr kaputt machen.

habe jetzt mein NAS noch mal auseinandergebaut und zur Probe die SATA-Festplatte mit Adapter ausgebaut und dann noch mal per LAN angeschlossen und siehe da,WEB-Oberfläche ist wieder da ,dann noch mal meine alte IDE-Festplatte eingebaut und auch die ist wieder verfügbar. Also, denke ich, sind die Start-Dateien auf meiner Sata-Platte defekt.Wie bekomme ich das wieder hin?

MFG 3306

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »3306« (3. Januar 2010, 00:17)


snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

13

Sonntag, 3. Januar 2010, 15:17

Moin,

scheinbar ist etwas in den user settings auf der platte defekt. Hatte ich auch schon. Stromausfall beim Hoch oder runterfahren und ... e voilla. Ich gehe mal davon aus, das du eine sicherung deiner einstellungen VORHER gemacht hast? (Web-Conf. -> control panel -> maintance -> save configuration).

wenn du das gemacht hast dann gehe wie folgt vor:

1.) Sichere deine Nutzerdaten (Backup für alle fälle) via USB (wenn du ext2 oder 2 hast nutze einen ext3 oder 2 treiber für windows) -> die daten liegen auf der mittleren (großen) der 3 Partitionen

2.) häge eine jungfräuliche Platte ins Nas (eine kleine reicht) und spiele dort die "config.tar" übers web gui auf (auch unter control panel -> maintance)

3.) kopiere die 2 Systempartitionen auf die platte mit den def. user datas

wieder rein und nas anwerfen

wenn du ssh hast kannst du auch erstmal versuchen dich einzuloggen. Das ersprt die Festplattenumbauerei und du kannst gezielt user settings wiederherstellen (mehr kontrolle für dich)

Im wesentlichen dreht es sich ja um die user, groups und shares. Zur not musst du die daten wieder händisch eingeben und hoffen, dass es klappt. Da hab ich allerdings noch keine erfahrungen.

Greetz
Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

14

Sonntag, 3. Januar 2010, 17:57

wie mache ich das jetzt?RXD-TXD direkt am Adapter überbrücken?wie muß ich putty überhaupt so einstellen?Wie mache ich das so mit dem Echo prüfen?Ich habe noch nie mit putty gearbeitet und möchte jetzt nicht noch mehr kaputt machen.

Ja, einfach Rx mit TX am Adapter verbinden.
Dann müssen die Zeichen so wieder zurück kommen, wie du sie eingibst (Echo).

Mit putty kann man nichts kaputt machen, das ist nur ein Programm um eine Verbindung per serieller Verbindung, telnet oder ssh herzustellen.
Erst mit linux Kommandos kann man was "kaputt" machen.

Putty Einstellungen für die serielle Verindung (hier über COM2):
Links im Menü: Connection-Serial[attach]222[/attach]
lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

15

Montag, 4. Januar 2010, 22:52

scheinbar ist etwas in den user settings auf der platte defekt. Hatte ich auch schon. Stromausfall beim Hoch oder runterfahren und ... e voilla. Ich gehe mal davon aus, das du eine sicherung deiner einstellungen VORHER gemacht hast? (Web-Conf. -> control panel -> maintance -> save configuration).
Hallo,snoopy
Sicherung habe ich natürlich gemacht,ist noch gar nicht so lange her.
wenn du ssh hast kannst du auch erstmal versuchen dich einzuloggen. Das ersprt die Festplattenumbauerei und du kannst gezielt user settings wiederherstellen (mehr kontrolle für dich)
was ist ssh, hat das auch was mit dem seriellen Zugang zu tun,da habe ich nämlich jetzt auch fortschritte durch Hilfe von HWguru erreicht,siehe weiter unten. :?:


Ja, einfach Rx mit TX am Adapter verbinden.
Dann müssen die Zeichen so wieder zurück kommen, wie du sie eingibst (Echo).
Hallo,HWguru,
jetzt macht das wieder mehr Spaß,Echo ist gekommen ,war gar nicht schwer,nur man muß wissen, wie es geht.
Putty Einstellungen für die serielle Verindung (hier über COM2):
Jetzt habe ich versucht mit verändertem RX-TX- Anschluß noch mal ein
LOG vom NAS zu machen und es hat geklappt,da kamen jede Menge Daten
nach dem Start.Wie und mit welchem Programm kann ich diese jetzt
speichern und hier mal hochladen damit Ihr hier mal rüberschauen könnt?
:?:


MFG 3306

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

16

Montag, 4. Januar 2010, 23:24

Jetzt habe ich versucht mit verändertem RX-TX- Anschluß noch mal ein
LOG vom NAS zu machen und es hat geklappt,da kamen jede Menge Daten
nach dem Start.Wie und mit welchem Programm kann ich diese jetzt
speichern und hier mal hochladen damit Ihr hier mal rüberschauen könnt?
Hmm, dir fehlen grundlegende Kenntnisse. Das kann man nicht so einfach erklären. Ich habe jedenfalls nicht die Zeit dazu. Aber es gibt doch noch User hier, oder??

Die Kollegen im nas-portal haben einen schönen Beitrag für Einsteiger im Wiki.

Beim putty kann man ein Logfile mitschreiben lassen. Das kannst du in einem Beitrag als txt Datei anhängen.

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

17

Dienstag, 5. Januar 2010, 18:21

Hola,

ssh ist ein serverpaket (ähnlich sftp) mit dem du dich als root mit einer verschlüsselten Verbindung einloggen kannst. Und zwar als root (nicht als user). Das ist Vorraussetzung um die systemdateien zu ändern. Wie die configs z.B.

Du findest es bei Raidsonic unter "support". In dem Zip ist eine ausführliche Anleitung.

Für die grundlegen Basiskenntnisse empfehle ich Wikipedia oder google.

Die können wir hier tatsächlich nicht vermitteln.

Greetz.
Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)

18

Dienstag, 5. Januar 2010, 22:13

Hmm, dir fehlen grundlegende Kenntnisse. Das kann man nicht so einfach erklären. Ich habe jedenfalls nicht die Zeit dazu.
hallo HWguru,
hiermit kenne ich mich noch nicht so aus,ich bin einer ,der lieber einmal mehr fragt,mit dem richtigen Anstoß kriege ich das aber meistens hin.Tut mir Leid,wenn ich schon nerve.
Beim putty kann man ein Logfile mitschreiben lassen. Das kannst du in einem Beitrag als txt Datei anhängen.
habe jetzt mit Putty das Logfile mitgeschrieben und als Textfile gespeichert,vielleicht wollt Ihr mal rüberschauen:

[attach]223[/attach]
ssh ist ein serverpaket (ähnlich sftp) mit dem du dich als root mit einer verschlüsselten Verbindung einloggen kannst. Und zwar als root (nicht als user). Das ist Vorraussetzung um die systemdateien zu ändern. Wie die configs z.B.

Du findest es bei Raidsonic unter "support". In dem Zip ist eine ausführliche Anleitung.
hallo snoopy,
habe ich schon mal bei RS runtergeladen ,dass ist der ssh-Server,richtig?
Was bringt es mir, die Systemdateien zu ändern?...oder anders gefragt, was kann ich mit meinem NAS noch so machen,außer es als Datenspeicher im heimmischen Netzwerk anzuwenden?Hier wird speziell auf bestimmte Probleme super eingegangen,aber ich weis damit teilweise nichts anzufangen.Wäre nicht schlecht,wenn Ihr mir mal so ein bisschen auf die Sprünge helfen könntet,vielleicht hilft das ja auch anderen Anfängern so wie mir.

übrigens der Tip mit dem HDD-Ausbau war super.
Ich habe die hdd aber gar nicht erst ausgebaut,nur per USB-Kabel angeschlossen,IFS Driver für EXT2 auf Win xp installiert,die eine Partion mit den Systemdateien auf dem NAS gelöscht(sozusagen Jungfreulichkeit wieder hergestellt),NAS wieder per Netzwerk angeschlossen und siehe da,Web-Oberfläche war wieder da,diese meldete eine neue HDD erkannt,diese dann neu formatiert und im Anschluß einfach meine gesicherten Usereinstellungen über die Web-Oberfläche zurückgeladen.Jetzt nur noch meine Daten wieder drauf und der alte Zustand ist wieder da. War aber erst mal ganz schon anstrengend.

MFG 3306

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

19

Dienstag, 5. Januar 2010, 22:34

Was bringt es mir, die Systemdateien zu ändern?...oder anders gefragt, was kann ich mit meinem NAS noch so machen...
Immer gilt: never touch a running system :whistling:
Wenn dein NAS tut, was es soll, macht es auch keinen Sinn am System herumzufummeln.

Das NAS ist ein kleiner linux Rechner, nur dass nicht alle Funktionen vorhanden sind. Teilweise kann man sie nachrüsten (optware,...).
Wenn dir keine Funktion abgeht, würde ich nicht daran basteln.

Das Log ist soweit nicht auffällig. Irgendwo im Forum oder Wiki gibt es auch eine Art Referenz als Vergleich, glaube ich.

Zitat

War aber erst mal ganz schon anstrengend
dazulernen ist eben nicht einfach.
Schau mal hier wie es uns erging. So lange kenne ich mich auch noch nicht damit aus...

Zu einigen deiner Fragen gibt es schon Antworten hier. Lese dich noch ein wenig durch...

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

snoopy

NAS2000-Team

Beiträge: 467

Wohnort: Zu Hause

20

Samstag, 9. Januar 2010, 03:42

Moin moin und...

Okay, ich werd mal noch die letzte offene Frage beantworten, auch wenns schon lange nicht mehr zum ursprünglichen Thema passt ;)

Was kann man sonst noch mit dem NAS?

Soweit ich sehe nutzt du es als Netzlaufwerk im LokalAreaNetwork (LAN). Damit Du die Daten hinund herschieben kannst wie einen normalen WINDOWS Ordner stellt der Samba Server auf dem NAS die Basis dar.

Wenn du nun Daten austauschen willst mit Freunden, die weiter weg wohnen (also über das Internet) nutzt Du den ftp server.

MAgst Du eine Webseite ins Internet stellen? Dann tut das der http server.

Systemdateien ändern (nur wenn es nötig ist!!! und du weißt was Du tust) kannst Du mit dem ssh server.

Daneben gibts noch einen Mediaserver (heißt Twonky... bitte googeln), der Dir Musik, Bilder und Videos komfortabel im LAN zur Verfügung stellt.

Itunes wird auch unterstützt. Das tut dann der Bonjour server.

Und wenn das immer noch nicht reicht gibt es so einige Ideen hier im Forum zu weiteren Diensten. Dienste ist das richtige Stichwort, denn nix anderes macht das NAS. Genauer: Dateidienste.

Und nun empfehle ich mal das Handbuch zum NAs und www.gidf.de ;)

Ich schlage vor wir schließen den threat an dieser Stelle. Einwände?

Greetz
Snoopy
--------------------------------------------------------------------------
Der Mensch ist das wichtigste und kostbarste Peripheriegerät einer Computeranlage.

myStuff: NAS2001+4220(1000Gb-ext3)+Dlink524+KabelD. (120 Mbit)