Saturday, November 25th 2017, 4:39am UTC+1

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to NAS Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

towge

Beginner

1

Friday, June 10th 2011, 7:38am

nas01sg - JTAG access problem, NOT in debug-mode

i need to jtag my box
but i can not set debug mode
i short nas pin 1 and 2 with Pin 17
NAS_FlashTool show

Cable type 4 detected.
Error: Device is NOT in debug-mode.

Some errors detected!

so next steep?
ths any help :P

HWguru

NAS2000-Team

Posts: 1,001

Location: Wien

2

Friday, June 10th 2011, 9:35am

Hi,
you did it well. If you get the message "Cable type 4 detected" you adapter seems to work.

You have to make this connection before you power on the nas.
Can you measure the voltage on this connection to GND?

Please turn on "Verbose Output" in NAS_FlashTool and post the result here - use the code button "#"
You may copy/paste the text from the tool's window.

Regards,
HWguru

P.S. I changed the thread title (most of the users need help :rolleyes: ) and the thread will be moved later
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

towge

Beginner

3

Friday, June 10th 2011, 12:49pm

thks you help.
NAS_FlashTool show:


Testing cabletype 3
JTAG-IDCODE: 0xf0000000 - not OK
Expected: 0x00526fa1
Bypass-test: 0xfc000000 - not OK
Expected: 0xaaab5554

Testing cabletype 4
JTAG-IDCODE: 0x00526fa1 - OK
Bypass-test: 0xaaab5554 - OK

Cable type 4 detected.
Error: Device is NOT in debug-mode.

Some errors detected!


I chk NAS VCC PIN and GND PIN 2.2V-2.5V
cpu is work?
soryy my bad english :D

HWguru

NAS2000-Team

Posts: 1,001

Location: Wien

4

Friday, June 10th 2011, 1:44pm

Hi,
VCC must be about 3.3V!
2.5 is too low. Check the power supply.
What happened to the nas, why do you need JTAG?

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

towge

Beginner

5

Saturday, June 11th 2011, 11:38am

i add atx power 3.3V to NAS VCC and GND PIN
BUT

NAS_FlashTool show

Testing cabletype 3
JTAG-IDCODE: 0xf0000000 - not OK
Expected: 0x00526fa1
Bypass-test: 0xfd000000 - not OK
Expected: 0xaaab5554

Testing cabletype 4
JTAG-IDCODE: 0x000149b8 - not OK
Expected: 0x00526fa1
Bypass-test: 0xff800000 - not OK
Expected: 0xaaab5554

Error:
- No cable detected
- Testdevice not connected

Some errors detected!
:think:

towge

Beginner

6

Saturday, June 11th 2011, 12:05pm

if power on nas
comm usb cable
nas power off
Press "JTAG test" show


Testing cabletype 3
JTAG-IDCODE: 0xffc00000 - not OK
Expected: 0x00526fa1
Bypass-test: 0xffd00000 - not OK
Expected: 0xaaab5554

Testing cabletype 4
JTAG-IDCODE: 0x00526fa1 - OK
Bypass-test: 0xaaab5554 - OK

Cable type 4 detected.
Device is in debug-mode - OK

Reading CPU-Type (SL3516)
CPU-ID: 0x000000 - not OK
Expected: 0x00003516 or 0x00003512
CPU-Rev.: 0x00

Reading CPU-Type (SL3316)
CPU-ID: 0x000000 - not OK
Expected: 0x00003316
CPU-Rev.: 0x00


Some errors detected!

:comp01:

towge

Beginner

7

Wednesday, June 15th 2011, 10:34am

No one can help me? :S

HWguru

NAS2000-Team

Posts: 1,001

Location: Wien

8

Wednesday, June 15th 2011, 10:45am

No,
if you power off it will not work!

There is an electrical problem with your setup or the power supply is defective.

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

towge

Beginner

9

Wednesday, June 15th 2011, 10:53am

so...It can not be restored? :(