venerdì, 24 novembre 2017, 10:15 UTC+1

Non risulti loggato.

  • Login
  • Registrazione

Gentile visitatore,
Benvenuto su NAS Forum. Se questa è la tua prima visita, ti chiediamo di leggere la sezione Aiuto. Questa guida ti spiegherà il funzionamento di questa pagina. Prima di poter utilizzare tutte le funzioni di questo software dovrai registrarti. Usa la form di registrazione per registrarti adesso, oppure visualizza maggiori informazioni sul processo di registrazione. Se sei già un utente registrato, allora dovrai solamente procedere con il login da qui.

towge

Principiante

1

venerdì, 10 giugno 2011, 07:38

nas01sg - JTAG access problem, NOT in debug-mode

i need to jtag my box
but i can not set debug mode
i short nas pin 1 and 2 with Pin 17
NAS_FlashTool show

Cable type 4 detected.
Error: Device is NOT in debug-mode.

Some errors detected!

so next steep?
ths any help :P

HWguru

NAS2000-Team

Posts: 1.001

Località: Wien

2

venerdì, 10 giugno 2011, 09:35

Hi,
you did it well. If you get the message "Cable type 4 detected" you adapter seems to work.

You have to make this connection before you power on the nas.
Can you measure the voltage on this connection to GND?

Please turn on "Verbose Output" in NAS_FlashTool and post the result here - use the code button "#"
You may copy/paste the text from the tool's window.

Regards,
HWguru

P.S. I changed the thread title (most of the users need help :rolleyes: ) and the thread will be moved later
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

towge

Principiante

3

venerdì, 10 giugno 2011, 12:49

thks you help.
NAS_FlashTool show:


Testing cabletype 3
JTAG-IDCODE: 0xf0000000 - not OK
Expected: 0x00526fa1
Bypass-test: 0xfc000000 - not OK
Expected: 0xaaab5554

Testing cabletype 4
JTAG-IDCODE: 0x00526fa1 - OK
Bypass-test: 0xaaab5554 - OK

Cable type 4 detected.
Error: Device is NOT in debug-mode.

Some errors detected!


I chk NAS VCC PIN and GND PIN 2.2V-2.5V
cpu is work?
soryy my bad english :D

HWguru

NAS2000-Team

Posts: 1.001

Località: Wien

4

venerdì, 10 giugno 2011, 13:44

Hi,
VCC must be about 3.3V!
2.5 is too low. Check the power supply.
What happened to the nas, why do you need JTAG?

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

towge

Principiante

5

sabato, 11 giugno 2011, 11:38

i add atx power 3.3V to NAS VCC and GND PIN
BUT

NAS_FlashTool show

Testing cabletype 3
JTAG-IDCODE: 0xf0000000 - not OK
Expected: 0x00526fa1
Bypass-test: 0xfd000000 - not OK
Expected: 0xaaab5554

Testing cabletype 4
JTAG-IDCODE: 0x000149b8 - not OK
Expected: 0x00526fa1
Bypass-test: 0xff800000 - not OK
Expected: 0xaaab5554

Error:
- No cable detected
- Testdevice not connected

Some errors detected!
:think:

towge

Principiante

6

sabato, 11 giugno 2011, 12:05

if power on nas
comm usb cable
nas power off
Press "JTAG test" show


Testing cabletype 3
JTAG-IDCODE: 0xffc00000 - not OK
Expected: 0x00526fa1
Bypass-test: 0xffd00000 - not OK
Expected: 0xaaab5554

Testing cabletype 4
JTAG-IDCODE: 0x00526fa1 - OK
Bypass-test: 0xaaab5554 - OK

Cable type 4 detected.
Device is in debug-mode - OK

Reading CPU-Type (SL3516)
CPU-ID: 0x000000 - not OK
Expected: 0x00003516 or 0x00003512
CPU-Rev.: 0x00

Reading CPU-Type (SL3316)
CPU-ID: 0x000000 - not OK
Expected: 0x00003316
CPU-Rev.: 0x00


Some errors detected!

:comp01:

towge

Principiante

7

mercoledì, 15 giugno 2011, 10:34

No one can help me? :S

HWguru

NAS2000-Team

Posts: 1.001

Località: Wien

8

mercoledì, 15 giugno 2011, 10:45

No,
if you power off it will not work!

There is an electrical problem with your setup or the power supply is defective.

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

towge

Principiante

9

mercoledì, 15 giugno 2011, 10:53

so...It can not be restored? :(