Freitag, 24. November 2017, 23:25 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Dienstag, 22. Januar 2008, 07:27

Performance mit NFS

Hallo Zusammen,
ich habe jetzt schon einiges gelesen wegen Performance des NAS, aber immer geht der Thread wieder ohne Ergebnis zu Ende.
Momentan habe ich das Problem, dass ich meine Dreambox via NFS in mein NAS-1000 mounte und von dort aus via rsync eine Sicherung der dort aufgenommenen Filme anstosse. Dabei habe ich Transferraten von ca. 1,5MB/s. :(
Kopiere ich vom NAS mit meiner Linux-Kiste Dateien herunter, dann bekomme ich mittels Samba ca. 2MB/s und mit NFS auch ca. 1,5 MB/s.
Haben andere nicht das gleiche Problem? ?(
Momentan verwende ich tinky-2_3_2-mu-02.2 und beide Geräte hängen an einem Linksys WRT54G.
Bin für jede Tipps dankbar.

Güsse
OnkelTom

2

Freitag, 25. Januar 2008, 15:29

Hallo,
bin ich der Einzige mit so schlechter Performance?
Mich würden auch die Transferraten von Euch interessieren, ob ich das Problem bei meiner Installation suchen muss oder ob es ein generelles Problem ist!

Grüsse
OnkelTom

3

Mittwoch, 9. April 2008, 19:33

RE: Performance mit NFS

Zitat

Original von OnkelTom
Hallo Zusammen,
ich habe jetzt schon einiges gelesen wegen Performance des NAS, aber immer geht der Thread wieder ohne Ergebnis zu Ende.
Momentan habe ich das Problem, dass ich meine Dreambox via NFS in mein NAS-1000 mounte und von dort aus via rsync eine Sicherung der dort aufgenommenen Filme anstosse. Dabei habe ich Transferraten von ca. 1,5MB/s. :(
Kopiere ich vom NAS mit meiner Linux-Kiste Dateien herunter, dann bekomme ich mittels Samba ca. 2MB/s und mit NFS auch ca. 1,5 MB/s.
Haben andere nicht das gleiche Problem? ?(
Momentan verwende ich tinky-2_3_2-mu-02.2 und beide Geräte hängen an einem Linksys WRT54G.
Bin für jede Tipps dankbar.

Ein Tipp habe ich dazu nicht, aber ich kann die schlechtern Performancewerte (leider) nur allzu sehr bestätigen.

Bei mir sieht es in etwa so aus:
1x Nas-2000 mit rsync im Daemon Mode
1x Nas-2000 mit rsync als Client
dazwischen ein Linksys WRT54GL

vor ~ 24 Stunden Rsync angestossen und seitdem ca. 20 GB übertragen :( Wenn das so weiter geht, dann ist der Rsync Vorgang am Ende des Monats durch.

Die beiden NAS sind wirklich nur mit Rsync beschäftigt...ich versuche nicht zwischenzeitlich auf Daten zuzugreifen.

BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

4

Mittwoch, 9. April 2008, 19:48

hallo...
also ich habe auch sehr, sehr schlechte werte via nfs erzielt,
darueber geschrieben hatte ich auch schonmal
siehe:
LINK
und hier eher unten:
LINK
ich denke das es einfach an der "schwachen hardware der box liegt,
falls nicht und falls ihr, oder wir da noch ein bischen was erreichen koennen, bin ich natuerlich nicht abgeneigt.
ich weiss nur nicht mehr weiter..
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

5

Donnerstag, 10. April 2008, 22:04

RE: Performance mit NFS

So und nun kann ich etwas Entwarnung geben bezgl. der Performance. Ich habe nach wie vor 2x NAS-2000 wobei auf einem Rsync als Daemon gestartet ist und auf dem anderen mit RSync als Client, die Daten gezogen werden. Ich habe mit den Parametern rumgespielt und Kompression abgeschaltet (OK, das war mein Fehler, hatte einfach etwas zuwenig angepasst bei den Parametern, von meiner alten Serverlösung). Die im Forum bereits beschriebenen Auffälligkeiten beim NFS Zugriff kann ich aber auch weiterhin bestätigen (Rennt erst los, und bleibt dann minutenlang hängen, so das der Eindruck entsteht, das der Rechner sich aufgehängt hat) Ich habe jetzmal auf SMB umgestellt und werde mal beobachten wie sich das auswirkt.

Nebenbei gefragt, weiss jemand eine Quelle für tune2fs? Grund: Damit kann man den Wert für die reservierten Blöcke (ext2/3) prozentual verändern. Wenn man mit dem Webfrontend die Festplatte formatiert hat, werden automatisch 5 Prozent der Kapazität verwendet. Das halte ich für mich etwas viel ;)

6

Sonntag, 13. April 2008, 13:27

Die Sache mit der üblen Performance scheint ein allgemeines Problem von den NAS
Speichern zu sein.Richtig schnell sind hier nur Profilösungen mit Glasfaseranbindung und dicken Prozessoren.
Meine NAS2001 schafft gerade mal 2,7MB/Sek.und die nicht mal flüssig.Befüllen geht deshalb nur über USB und passendes Betriebssystem(nehme immer SIDUX live wegen ext3 Filesystem)Selbst das einfache Abspielen eins divx Streams wird hiermit zur Ruckelorgie.Komisch ist nur,daß ich über meinen Router Siemens 141
welcher auch nur 100Mbit Lan beherrscht im reinen Rechner-Rechner Betrieb auf
ca 11MB/Sek Übertragungs Geschwindigkeit komme.

ted.striker

Anfänger

Beiträge: 29

Wohnort: Oldenburg

7

Sonntag, 13. April 2008, 16:04

Moin auch!
Zur Frage oben: Die "Begrenzung" ist halt das NAS, der Chipsatz und die Architektur. Klar, dass du mit einem normalen Router, der ja wirklich nur "durchrouten" muss, auf fixere Werte kommst. Beim NAS macht dies halt ein flotterer Chipsatz, nur da werden die NASes gleich riiichtig teuer (leider). Ich kann nur sagen, dass ich mit dem alten NAS900 immer Werte von ca. 800 kB/Sek. (schreiben) und ca. 1,2 MB/Sek. (lesen) über Samba hatte.

Mal zur Info: mit der nagelneuen Samba-config von Snoopy (das do_it-Paket) habe ich gerade einen ersten Test auf meinem 2000er gemacht:

Über Samba komme ich mit Win Vista SP1 auf folgenden Wert (Testdatei = 100 MB):
Schreiben auf die Box: ~ 2,67 MB/Sek.
Lesen von der Box: ~ 3,42 MB/Sek

Ist zumindest etwas schneller als vorher, uuuuhuund läuft nun auch bei großen Dateien sauber durch, also würde die angesprochene 20-GB-Datei von oben in knapp 128 Minuten durch sein.



Gruß,
Sebastian

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »ted.striker« (13. April 2008, 16:09)


BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

8

Sonntag, 13. April 2008, 16:09

hallo,
ich habe bezueglich samba noch ein paar versuche gemacht:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
#NFS
Nas nach AndreasLinux 1024MB  4:00min
AndreasLinux nach Nas 1024MB  6:50min
AndreasLinux nach VDR 1024MB  1:47min
VDR nach AndreasLinux 1024MB  1:33min
VDR nach NAS	      1024MB  7:02min
NAS nach VDR	      1024MB  4:15min

#Samba
Nas nach AndreasLinux 1024MB  9:19min
AndreasLinux nach Nas 1024MB  < 10min


also ist samba noch langsamer als nfs, dafuer aber 'konstant'.

also werden wir uns wohl damit abfinden muessen, das die datenuebertragungen sehr langsam sind.
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »BooStar« (13. April 2008, 16:12)


HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

9

Sonntag, 13. April 2008, 16:21

Hi,
da muss es noch eine Bremse geben.
Ich habe die standard RS Firmware RS1 laufen und habe bei Samba 30Mbit write und 50Mbit read konstant. Un das ohne Tuning.

XP PC - Gbit Switch - Router - NAS

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

10

Sonntag, 13. April 2008, 16:33

also ich kann mir irgendwie nicht vorstellen das nfs die bremse ist,
und ide kanns wohl auch nicht sein.
die box macht ja:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
root@icybox:~ # mount
none on /proc/bus/usb type usbfs (rw)
/dev/hda1 on /system type ext2 (rw)
/dev/hda2 on /mnt/IDE1 type ext3 (usrquota,grpquota)
root@icybox:~ # hdparm -t /dev/hda

/dev/hda:
 Timing buffered disk reads:   40 MB in  3.06 seconds =  13.07 MB/sec
root@icybox:~ # hdparm -t /dev/hda1

/dev/hda1:
 Timing buffered disk reads:   26 MB in  3.00 seconds =   8.67 MB/sec
root@icybox:~ # hdparm -t /dev/hda2

/dev/hda2:
 Timing buffered disk reads:   40 MB in  3.13 seconds =  12.78 MB/sec
root@icybox:~ #             
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

11

Sonntag, 13. April 2008, 16:51

Hab's gerade noch mal mit einer 1024MB Datei über Samba getestet.

PC -> NAS 3,3MB/sec (5:15)
NAS -> PC 5,5MB/sec (3:05)

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

ted.striker

Anfänger

Beiträge: 29

Wohnort: Oldenburg

12

Sonntag, 13. April 2008, 17:45

Moin auch!
Einen evtl. Grund für den Performance-Abfall bei mir hätte ich: ich bin mit dem Vista-PC über WLAN online, allerdings mit einem 95%-Signal bei 108 Mbit/s, also kann es das (eigentlich und nach meinem Verständnis) nicht sein.
Aber Vista selbst wird sicherlich an der Performance nuckeln, da ist ein kommandozeilenbasiertes Copy über Linux sicherlich fixer.

Gruß,
Sebastian

13

Sonntag, 13. April 2008, 19:43

Wlan hat ständige dropouts.. das liegt an vielen verschiedenen Faktoren, wie Wellenlänge, Störfaktoren, Frequenz usw...

Konstanter ist da der 802.11a Standard, der mit 5Ghz, und einer Wellenlänge von 25cm arbeitet...
...and eternity, my friend, is a long fucking time!

BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

14

Samstag, 26. April 2008, 23:30

hallo zusammen,
ich habe letzten eine interessante entdeckung gemacht.
und zwar habe ich daten, ca. 4Gb von einer DVD direkt auf das nas gespielt,
dabei hatte ich eine ziemlich konstante uebertragungsrate von ca. 5MB/s,
koennte es also sein, das wenn ich von meiner hard disk aufs nas kopiere, es einfach "zu schnell"
ist.
das verhalten waehrend des kopierens von eine hard disk aufs nas ist ja folgendes:

hohe uebertragungsraten am anfang ( ca 30-50 MB/s )
dann sinkende raten bis hin zum "verzoegern"
dann wieder hohe raten bis hin zum verzoegern.

ich stelle mir das also mal so vor(bitte berichtigen, falls ich falsch liege)

eine hd erreicht lesegeschwindigkeiten > 50MB/s
damit werden daten an das nas geschickt und irgendwo (ram?(wohl kaum) / hd chash) gepuffert,
dieser laeuft auf grund der großen datenmenge die schnell geschickt wird schnell voll und das verzoegern setzt ein, dann muss der puffer wieder geleert werden um neue daten zu puffern.
das entleeren des puffers kostet natuerlich zeit, was eine moegliche ursache fuer die schlechte uebertragungsrate sein koennte.

drauf gekommen bin ich, wie gesagt als ich von einer DVD aufs nas kopiert habe, wo die lesegeschwindigkeit ja eh sehr viel geringer ist als bei einer hd. darum koennte der puffer nicht so schnell voll laufen und muss erst spaeter entleert werden, wodurch natuerlich zeit gespart wird.

ich werde das morgen nocheinmal genauer unter die lupe nehmen und mal testen wie die lesegeschindigkeit einer dvd so ist.

in diesem sinne...
bis morgen ...

Boo
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

15

Mittwoch, 30. April 2008, 11:06

hallo nochmal..

Zitat

und zwar habe ich daten, ca. 4Gb von einer DVD direkt auf das nas gespielt,
dabei hatte ich eine ziemlich konstante uebertragungsrate von ca. 5MB/s,

dem ist leider nicht so.. ich weiss auch nicht was ich da gesehen habe...
schade eigentlich..

was mir aber noch aufgefallen ist, das dieses verzoegern immer nach 50 kopierten MB einsetzt..
vllt ist das ja nochmal ein ansatzpunkt?

__
Boo
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

16

Mittwoch, 30. April 2008, 11:53

hmm, guter Tipp.
Vielleicht hat das mit dem Speicher zu tun. Wenn das System keinen Speicher zum Buffern hat und die Daten auf die Platte müssen.
Ev. tut sich das System mit deiner HD schwer?
Schon mal versucht mit hdparm was zu tunen?

HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!