Tuesday, September 25th 2018, 3:19am UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to NAS Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Sunday, February 10th 2008, 7:22pm

[solved] NAS HDD DUAL SATA dead after upgrade

Hello everybody ,
I had a problem during the upgrade procedure of my DUAL HDD NAS SATA
(you can find info of product at: http://mrt.nas-central.org/index.php/Category:35HD-DUAL-NAS)

It is based on Centroid SL3316-G chipset.

I tried to upgrade from original firmware 2.2.3 to tinky-ls but it hanged.
Then the fatal problem arised with a bad later bootloader procedure during redboot recovery followed at:

http://mrt.nas-central.org/index.php/Tinky-LS_installation

In fact I probably select a wrong file for bootloader recovery and now my NAS is dead at reboot...nor telnet possible at 192.168.2.71:9000 .

From pics of the pcb, I see serial port is available but not jtag information.
More pics could be found at :

http://www.flickr.com/photos/23185479@N08/

they were not shot by me but useful too.

May you help me in how to recover from this situation ? :(

Thanks a lot in advance!!!

HWguru

NAS2000-Team

Posts: 1,001

Location: Wien

2

Sunday, February 10th 2008, 7:39pm

RE: NAS HDD DUAL SATA dead after upgrade

Hello,
seems that DUAL HDD NAS SATA uses the same CPU as NAS1000/2000.
The first photo "pcb IDE version" shows the JTAG connector on top left.

- Verify if VCC and GND can be found as described here
- check some JTAG adapter (buffered is preferred, but unbuffered is OK too)
- verify if flashtool works (without NAS hardware)
- solder some connector to your NAS (VCC, GND, TCK, TMS, TDI, TDO and is needed)
- connect to adapter and run JTAG_TEST
- let us check the result together
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

sj29fr

Beginner

Posts: 10

Location: France

3

Wednesday, February 13th 2008, 12:42pm

RE: NAS HDD DUAL SATA dead after upgrade

Hello,
I bricked my mrt NAS. I get redboot.bin firmware to flash it again with a JTAG pod.
I tried to connect a BDI2000 to this board but the JTAG chain scan fails.
I connected pin 17 to pin 1 on JTAG port, but the problem is the same.
Is there a special resistor as for NAS2000 to solder to enable JTAG access ?
Thanks,
Sebastien

HWguru

NAS2000-Team

Posts: 1,001

Location: Wien

4

Wednesday, February 13th 2008, 1:39pm

RE: NAS HDD DUAL SATA dead after upgrade

Hi, please read the Wiki about Bootloader Programming

Pin 1 - 17 is needed for debug mode of the CPU, R160 is needed for JTAG mode.
There is no boundary scan chain available. It is only a JTAG debug port.
So you need a special software (like ours) to access the Flash through memory and CPU register accesses.
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

sj29fr

Beginner

Posts: 10

Location: France

5

Wednesday, February 13th 2008, 9:42pm

RE: NAS HDD DUAL SATA dead after upgrade

Hi,
I already read the link.
The Abatron BDI2000 can debug ARM processors, access to memory and flash. It can also program the flash.
So I shorted pin1 and 17, but the BDI2000 can't find the SL3316 ID. So I think that I need to enable JTAG. The problem is to find how because MRT 35HD-DUAL-NAS doesn't have the same PCB than the NAS2000.
Do you have any idea to find where to solder this resistor ?
Is it a pull up or a pull down ?
Regards,
Sebastien

sj29fr

Beginner

Posts: 10

Location: France

6

Wednesday, February 13th 2008, 9:54pm

RE: NAS HDD DUAL SATA dead after upgrade

I attached the top and bottom side photos
sj29fr has attached the following files:
  • 004_.jpg (95.45 kB - 1,410 times downloaded - Last download: Oct 17th 2016, 8:28pm)
  • 005_.jpg (173.88 kB - 1,323 times downloaded - Last download: Oct 17th 2016, 8:29pm)

HWguru

NAS2000-Team

Posts: 1,001

Location: Wien

7

Wednesday, February 13th 2008, 10:04pm

RE: NAS HDD DUAL SATA dead after upgrade

The resistor is connected to Pin A7 of the CPU.
It is a Pullup (4k7?) and should be connected to GND.
I believe you find it on the bottom side. Probably there is a trace going to two resistors where one is not equipped.
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

sj29fr

Beginner

Posts: 10

Location: France

8

Wednesday, February 13th 2008, 10:28pm

RE: NAS HDD DUAL SATA dead after upgrade

I think that the resistor should be near the CPU.
Perhaps it's R85 near GPIO:22 ??
You said it's a pullup connected to ground ?? A pull up should be connected to VCC ?
Can you be more precise ?

Do you have a datasheet for the SL3316 and a schematic (Application Note ...) ?
Thanks
Sebastien

HWguru

NAS2000-Team

Posts: 1,001

Location: Wien

9

Wednesday, February 13th 2008, 10:38pm

RE: NAS HDD DUAL SATA dead after upgrade

It is a Pullup and the signal to that pullup should be GND.

Maybe below R36, 35??
Take 100 Ohm and try to force the Signal to GND.
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

sj29fr

Beginner

Posts: 10

Location: France

10

Wednesday, February 13th 2008, 11:02pm

RE: NAS HDD DUAL SATA dead after upgrade

I checked for JTAG pin 17 (DBGRQ) : it's connected to 3.3V via a 4.7K => so I don't need to short circuit between pin 1 and 17

For JTAG enable pin :

On the PCB you can see this :

R34 R67 R48 R36 R35
3.3 3.3 gnd gnd 3.3

--------------------------
|A1 A8 A16|
|B1 SL3316 B16|
. .
---------------------------

You are right, it can be R35.
I need to try.

Thanks for all this informations.
Sebastien

HWguru

NAS2000-Team

Posts: 1,001

Location: Wien

11

Wednesday, February 13th 2008, 11:09pm

RE: NAS HDD DUAL SATA dead after upgrade

Hmm, I can't beleieve that Pin 17/DBGRQ is connected to a Pullup.
If you assert DBGRQ, an ARM processor would do an immediate breakpoint.

Are you sure?
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

sj29fr

Beginner

Posts: 10

Location: France

12

Wednesday, February 13th 2008, 11:29pm

RE: NAS HDD DUAL SATA dead after upgrade

I checked and it's true.

If JTAG is disabled it can be possible.
You don't know if the JTAG debug pod used with the SL3316 drive this pin !

I really hope it will work.

sj29fr

Beginner

Posts: 10

Location: France

13

Friday, February 15th 2008, 1:00pm

RE: NAS HDD DUAL SATA dead after upgrade

Hi,
DGBRQ is forced to 0V by default. So I put pin 17 to pin 1.
I tried to pull down R35, R67, R34 and R115 but I can't scan JTAG.
Do you have any idea to enable JTAG ?
Do you have SL3316 datasheet to have more informations about JTAG connexion ?
Thank,
Sebastien

HWguru

NAS2000-Team

Posts: 1,001

Location: Wien

14

Friday, February 15th 2008, 1:42pm

RE: NAS HDD DUAL SATA dead after upgrade

Hello Sebastien,
DBGRQ is not required if you only want to check if the JTAG chain is working.
Does not matter if it is 0 or 1!
Have you cycled Power between the tries? I assume the mode is only checked at power up / reset. On NAS1000 there is a reset button (not fitted).
Do you have access to a microscope? Then you could see the pin as it is on the edge of the chip. Or/and you could use a very fine wire and try to measure it. Then you would know the right resistor.

Oh I am very sorry! The Pin A7 must be put to 1 not to 0.
I have just checked my documentation.
So I believe it is 0 at your hardware and should be 1...
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

sj29fr

Beginner

Posts: 10

Location: France

15

Friday, February 15th 2008, 4:52pm

RE: NAS HDD DUAL SATA dead after upgrade

Hi,
Ok for DBGRQ.
Yes I tried to remove and set power many times, but it doesn't work.
I can solder a reset button on the PCB.
No I don't have a microscope but I can look where goes A7. I hope they didn't solder it directly to VCC !
Thanks,
Sebastien

HWguru

NAS2000-Team

Posts: 1,001

Location: Wien

16

Saturday, February 23rd 2008, 9:16am

RE: NAS HDD DUAL SATA dead after upgrade

Good news, scisci found R36 being the right one.

Solder a 100 ohm resistor from the R36 pin near to the CPU to 3,3V.
R35 near to the memory should be 3,3V.
Check if connected to JTAG conn Pin 1 or 2.

With that patch applied you should get some message like:

Quoted

JTAG-IDCODE: 0x00526fa1 - OK
Bypass-test: 0xaaab5554 - OK

Don't forget connection 1 - 17 on JTAG connector. It is needed to put the CPU into "Debug Mode" what actually halts it like on a breakpoint.

We found that this could be required after power up. For scisci it did not work when done before powering the NAS.
So maybe try to connect Pin 17 to Pin 1 (3,3V) after powering the NAS.

working:

Quoted

Cable type x detected.
Device is in debug-mode - OK
CPU-ID: 0x003316 - OK

not working:

Quoted

Cable type x detected.
Error: Device is NOT in debug-mode.

There is an entry Bootloader - program Flash through JTAG at our wiki as well.

Good luck
HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

17

Sunday, February 24th 2008, 1:45pm

..Just an official thanks to HWguru for his precious support
during these days. Without him..for sure no chance to debrick my nas !
:)

sj29fr

Beginner

Posts: 10

Location: France

18

Monday, March 3rd 2008, 7:54pm

RE: NAS HDD DUAL SATA dead after upgrade

Hi,
I made the modification, and now Jtag scan works with Wiggler.
I obtain this :


Testing cabletype 1
JTAG-IDCODE: 0x00526fa1 - OK
Bypass-test: 0xaaab5554 - OK

Testing cabletype 2
JTAG-IDCODE: 0xffffffff - not OK
Expected: 0x00526fa1
Bypass-test: 0xffffffff - not OK
Expected: 0xaaab5554

Cable type 1 detected.
Device is in debug-mode - OK
CPU-ID: 0x003316 - OK
CPU-Rev.: 0xa3
Flash-Manufacturer: 0xc2
Flash-Device-ID: 22cb-0000-0008
Flash type - not OK
Expected: 227e-2210-2200 or 227e-2210-2201

Some errors detected!


The problem is that my AM29LV640D is not supported by your NAS2000FlashTool.
Can you add this flash driver ?

I found H-JTAG software but I don't know how to configure it.
Do you know another software or do you have any solution ?
Thanks
sj29fr

sj29fr

Beginner

Posts: 10

Location: France

19

Monday, March 3rd 2008, 8:06pm

RE: NAS HDD DUAL SATA dead after upgrade

I used bad version of NAS2000FlashTool.
use this one : http://forum.nas-forum.org/thread.php?threadid=23


closed by HWguru - I think we have the solution now - for new questions start a new thread please