Mittwoch, 22. November 2017, 02:46 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Montag, 3. März 2008, 18:34

"Segmentation Fault" bzw. "Speicherzugriffsfehler"

Hi,

ist jemand von euch via NAS-1000/2000 mit der Fehlermeldung

Quellcode

1
Segmentation fault
bzw.

Quellcode

1
Speicherzugriffsfehler
konfrontiert worden?

Hatte das Problem bereits bei tinky, als ich einen tar-ball erstellen wollte (ca. 20G), was durch die Fehlermeldung "Segmentation fault" immer scheiterte. Mit der deutschen Version von debian etch hatte ich nun die Fehlermeldung "Speicherzugriffsfehler". Danach tilte das System auf unterschiedlichste Weisen.

Die Suchmaschine mit einhundert Nullen hat mich gelehrt, dass dafür alles Mögliche verantwortlich sein kann: unterschiedliche Distri-Softwareversionen, Hardwareprobleme etc. Mein Verdacht richtet sich neuerdings in Richtung Überhitzung, da ich den Lüfter bisher immer aus hatte. Verwirrend ist allerdings die Tatsache, dass nano diesen Fehler auch ohne Zwischenspeicherung massiv ausgelöst hat, während der vi ganz "cool" blieb.

Ich bin ja sicher nicht der einzige, der mit seiner Box Strom und Lärm sparen möchte. Insofern frage ich mich mich, was ihr für Überhitzungsfolgen erfahren habt.

Liebe Grüße
t-rex

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

2

Montag, 3. März 2008, 19:04

RE: "Segmentation Fault" bzw. "Speicherzugriffsfehler"

Hi, versuche es doch einmal mit Lüfter auf der großen Stufe!
Wenn der Effekt weg ist, liegt es an der Temperatur.
Siehe auch wiki
Der Bereich beim linken RAM (nähe Power Stecker) wird durch die Stromversorgung in diesem Bereich besonders warm.

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

3

Freitag, 7. März 2008, 06:39

So, ich habe jetzt einige Tage die Box durchlaufen lassen. Der Überhitzungsverdacht bestätigt sich. Mit Lüfterstufe 1 lief die Box problemlos.
Ich war immer davon ausgegangen, dass die Platte gekühlt werden müsste. Dass aber der RAM überhitzt, erklärt nicht nur das Verwirrspiel mit nano und vi sondern auch die unregelmäßig misslungenen Dateispeicherungen. DANKE!
Weil mich der Lüfter aber trotzdem nervt, werde ich auf die RAM-Chips mal ein paar Kühlrippen implantieren. Ergebnis folgt ...

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

4

Freitag, 7. März 2008, 07:41

Versuche auch den Bereich der Stromversorgung zu kühlen.
Die Dioden und Spannungsregler für 3.3V und 2.5V neben dem HD Power Stecker erzeugen eine Menge Wärme, die dann das RAM daneben zusätzlich aufheizen.
Einen kleinen Kühlkörper direkt über oder/und unter dem Bereich anbringen.
Dann sollte weniger Wärme zum RAM gelangen.

keep cool,
HWguru
»HWguru« hat folgende Datei angehängt:
  • cooling_power.jpg (70,92 kB - 78 mal heruntergeladen - zuletzt: 17. Mai 2012, 19:01)
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!