Dienstag, 21. November 2017, 01:33 UTC+1

Sie sind nicht angemeldet.

  • Anmelden
  • Registrieren

Lieber Besucher, herzlich willkommen bei: NAS Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

1

Samstag, 29. März 2008, 17:10

Fragen zum Einbau einer zweiten hd (tinky)

hallo,
ich wuerde gerne ein zweite hd in mein nas bauen und habe dazu vorab einige fragen:

der einbau wird wahrschein ganz "normal" funktionieren, also IDE kabel dran, Y-Strom-Stecker und ab dafuer....

aber wie ist das mit der software, muss ich die alternative firmware dazu nochmal installieren, oder kann ich die platte einfach dazu haengen?
mein konstelation sieht folgendermaßen aus:
ich habe eine 300Gb derzeit im nas verbaut, ergo sind auf ihr auch alle daten gespeichert die von der firmware benoetigt werden, oder? also was passiert, wenn ich einfach eine platte dazu haenge? ich moechte kein raid, oder sonstiges machen ,einfach nur eine zweite platte dazu und diese dann natuerlich auch via nfs und ftp ansprechen. die persoenlichen daten die ich auf der 300Gb angelegt habe, sind nicht das problem, die sind gesichert, ich moechte tinky nur nicht nochmal intallieren muessen.

es waere schoen wenn ihr mir meine fragen beantworten koenntet... vielen dank schonmal im vorraus...
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

2

Samstag, 29. März 2008, 18:17

RE: fragen zum einbau einer zweiten hd

Hi, nutze mal die Suche und gib disk ein.
Da kommen zwei Threads die sich bereits damit befasst hatten.

- ohne Backup würde ich solche Versuche nicht machen.
- die Einstellungen sind auf der 1. Platte, das ist Ok
- Mit RS Firmware kannst du raid verwenden, Zugriff per nfs usw. geht nicht, über die Konsole schon
- Mit tinky weiß ich nur dass kein raid geht
- 2 Platten über Y-Powerkabel könnten das Netzgerät überlasten.

Das NG kann 2A bei 5V und 2A bei 12V liefern.
Das Mainboard braucht nur 5V (ca. 0.8A)

Also bleiben für die 2 Platten 1.2A 5V und 2A 12V übrig und das kann zu wenig sein.
Bei einer alten Platte habe ich gemessen:
12V: start-1.5A idle-0.2A
5V ca. 0.65A abhängig vom Zugriff.

--> besser eine größere einbauen, das funktioniert sicher und spart viel Zeit und Nerven ;)

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

3

Samstag, 29. März 2008, 20:48

Zitat

besser eine größere einbauen, das funktioniert sicher und spart viel Zeit und Nerven

und kostet viel mehr geld :D
leider ist mein budget als student ein wenig klein und eigentlich wollte ich nur meine musik zentral im netzwerk ablegen.

darum hab ichs auch einfach mal versucht, mit 2 x 3,5'' platten und einem y-stecker.
beide platten liefen ohne probleme hoch und tinky ist sauber gestartet. dann konnte ich die zweite hd via web-interface formatieren, mounten, und nach anpassung der exports auch via nfs mounten.
also eigentlich genauso wie ich mir das vorgestellt hatte...
und jetzt?
jetzt kommst du und sagst mit das mein netzgegraet zu schwach ist :( *danke fuer den hinweis*

aber ein bischen musst du mir das schon noch erklaeren,
ich nehme einmal an, das eine hd, wenn sie gestartet wird den groessten stromverbrauch hat, oder?
und ich habe beide hds erfolgreich gestartet und auch auf dem suspend geweckt, also muesste das doch eigentlich hinhauen, oder meinst du da koennen evtl, spaetschaeden an den platten, bzw am nas entstehen?

achso aufe meinen samsung platten steht folgender hinweis

Zitat

RATED: +12V / +5V, 0,5A, 0,6A


hat das irgendwas mit den von dir gemessen werten zu tun?

PS mir faellt gerade ein, das ich noch ein altes icybox-usb-gehaeuse habe, da ist das netzteil identisch mit dem vom nas, leider ist dies ein wenig kaputt(keine usb-verbindung mehr) die stomversorgung fuer die hd funktioniert jedoch tadellos.
meinst du ich koennte diese platine als reine stomversorgung fuer die andere zeite platte im nas nehmen?
und wuerde dann ggf das suspenden noch funktionieren?
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »BooStar« (29. März 2008, 21:10)


HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

4

Samstag, 29. März 2008, 23:15

Hi, das ist gut wenn es bei tinky funktioniert.
Könntest du die "anpassung der exports" für die Nachwelt erläutern?
Ich glaube viele wissen nicht wie sie das anstellen sollen.

Wenn bei deinen Platten +12V / +5V, 0,5A, 0,6A drauf steht, könnte sich das ausgehen.
Ich wollte natürlich darauf aufmerksam machen, dass das ein Problem sein kann.
Wenn jemand eine super schnelle Platte nimmt braucht die vielleicht viel mehr Strom!
Die Angaben auf den Platten oder in Datenblättern sind meist höher als in der Praxis.

Beim Starten der Platten ist natürlich der Strom auf den 12V am höchsten.
Normalerweise liefert ein Netzgerät kurzzeitig auch mehr Strom. Die angegebenen Werte beziehen sich auf Dauerleistung.

Mit zwei Netzgeräten betreiben ist natürlich möglich und man ist auf der absolut sicheren Seite.
Das "Suspend" wird durch Software und die Platte erledigt. Die Spannung zur Platte wird nicht vom NAS abgeschaltet und sollte deshalb weiterhin funktionieren.

lG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

5

Samstag, 29. März 2008, 23:30

Zitat

Hi, das ist gut wenn es bei tinky funktioniert.
Könntest du die "anpassung der exports" für die Nachwelt erläutern?
Ich glaube viele wissen nicht wie sie das anstellen sollen.


klar, das werde ich morgen mal nachliefern, im moment ist mein nas in 1000 teile zerlegt und eben nicht angeschlossen, aber es funktioniert definitiv!

was die stromversorgung angeht werde ich nochmal schauen, eigentlich muesste die elektronik des usb-gehaeuses genau ueber die vom nas passen...

kannst du mir vllt sagen wie ich am besten messen kann wieviel die platten jetzt genau verbrauchen?

ich werde morgen nochmal ein bissel basteln, evtl mal ein paar bilder von der ganzen konstruktion einstellen....
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

badwater

Anfänger

Beiträge: 3

Wohnort: Northern Territories

6

Sonntag, 30. März 2008, 10:51

Mein NAS2000 meldete sich vor 2 Wochen auf einmal nicht mehr, nach fast eienm Jahr Betrieb.
Netzteil putt! 8o
Also aufgepasst ....

BW
NAS-2000, Samsung HD400LD
NAS-4220, WD-1000FYPS

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

7

Sonntag, 30. März 2008, 13:54

Zur Strommessung brauchst du ein Messgerät mit einem 10A Bereich um nicht zu viel Spannungsabfall bei der Messung zu verursachen.

Entweder kappst du die Stromversorgungsleitung (12V=gelb, 5V=rot) und hängst das Messgerät dazwischen oder du holst den Kontakt aus dem Steckergehäuse heraus.
Jeder Kontakt hat einen kleinen Widerhaken, den man zB mit einer Büroklammer hineindrücken kann und dann nach hinten herausziehen kann.
»HWguru« hat folgende Datei angehängt:
  • stromkontakt.jpg (15,25 kB - 157 mal heruntergeladen - zuletzt: 12. Oktober 2008, 10:46)
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

8

Sonntag, 30. März 2008, 17:00

hallo zusammen...

also ich habe jetzt erstmal beide platten an einem netzteil angeschlossen, mal sehen, wie lange das gut geht ...ausserdem will ich jetzt erstmal testen, ob alles auch genauso funktioniert wie ich mir das vorstelle.
also meine vorstellungen / ansprueche sind eigentlich gar nicht so groß, ich moechte "nur" eine zweite platte in meinem netz freigeben und das moeglichst via nfs und ftp, damit der zugriff von aussen auch moeglich ist.

die zweite festplatte mit ntfs wurde eben ins nas eingebaut und siehe da, trotz ntfs wurde die platte gemountet und mit flgendem eintrag in die /etc/exports via nfs im netz freigegeben:

Quellcode

1
vi /etc/exports


Quellcode

1
2
3
/mnt/IDE1/andreasj 192.168.10.2(rw,root_squash)
/mnt/IDE1/easyvdr 192.168.10.2(rw,root_squash) 192.168.10.4(rw,root_squash)
/mnt/IDE2 192.168.10.2(rw,root_squash)


die ersten beiden eintraege geben die beiden verzeichnisse "andreasj" und "easyvdr" auf der masterplatte hda fuer die ip 192.168.10.2 frei, alternativ kann man statt der ip auch ein "*" setzen damit das verzeichnis fuer alle ips frei wird.
der dritte eintrag gibt die zweite platte (hdb) frei

die optionen, also "(rw,root_squash)" habe so aus einer anderen /etc/exports uebernommen,
aber wenn man ein wenig googlet findet man sicher erlaeuterungen und weitere freigabeoptionen.

naja gemountet wird die freigabe mit diesem befehl:

Quellcode

1
mount -t nfs -o rw,wsize=8192,rsize=8192,intr  192.168.10.3:/mnt/IDE2 /mnt/mountpiont 


da die platte im moment noch mit ntfs formatiert ist, ist der zugriff noch nicht moeglich, ich werde sie jetzt mit ext3 formatieren und dann wird sie sicher auch les/schreibbar sein.

noch kurz zur info:

Zitat

Hardware Name IB-NAS 1000 Platform
Firmware Version 2.3.2-mu-02.2
Hardware Version Rev. B
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

9

Sonntag, 30. März 2008, 17:07

was mir grade noch einfaellt...

die spindown funktion, die man im web.interface einstellen kann, basiert doch sicher auf hdparm, oder?

denn so wie es jetzt ausschaut, schlafen beide platten braf nach der eingestellten zeit ein, nur leider wachen auch beide gleichzeitig wieder auf, das muesste man doch eigentlich auch trennen koennen, oder?
also frei nach dem motto:

beide platten schlafen

zugriff auf IDE1 platte wacht auf und IDE2 schlaeft weiter..

eigentlich muesste man das doch mit hdparm einstellen koennen, oder?
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

10

Sonntag, 30. März 2008, 18:12

also wie erwartet funktioniert das lesen und schreiben via nfs nach dem umformatieren auf ext3.

jetzt noch eine kleine todo:

-share-management allgemein:
da das web-interface nur shares auf IDE1 zulaesst koennt man evtl. mal ueberlegen ob man nicht gescheite symlinks angelgt (hat jemand ideen dazu?)

-hdparm: leider kenne ich mich nicht allzugut damit aus, aber meine ueberlegungen aus dem vorherigem threat muessten doch eigentlich umzusetzen sein, oder?

-usb: wenn ich die platte via usb an einen linux-pc anschliesse werden die beiden mounts:

Quellcode

1
2
/dev/hda1 on /system type ext2 (rw)
/dev/hda2 on /mnt/IDE1 type ext3 (usrquota,grpquota)
erkannt und koennen benutzt werden, der dritte eintrag, also:

Quellcode

1
/dev/hdb1 on /mnt/IDE2 type ext3 (rw)

wird leider nicht via usb erkannt, ist das eher ein software seitiges problem oder ist es allgemein nicht moeglich, zwei festplatten ueber einen usb-port zu bedienen?

naja wenn diese software-problem noch geloest werden sollten, muss ich mal ueberlegen, ob ich nicht doch noch die alte usb-platine dazu bastel, aber das sind ja eher hardware geschichten, bzw, geht ein bissel in den modding bereich..

anyway... ich werde mal sehen was sich da noch rausholen laesst...
an dieser nochmal vielen dank fuer eure hilfe...
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

11

Sonntag, 30. März 2008, 18:47

Hallo BooStar!

Danke für deine Beschreibungen!

Zwei Platten an einem USB chip geht glaube ich nicht.
Wenn man das NAS2000 an USB anschließt, lauft der Prozessor nicht und der Zugriff auf die Platte funktioniert über den Datastor USB4500 chip direkt in Hardware.

LG HWguru
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

12

Montag, 31. März 2008, 13:38

hallo nochmal...
also ich habe mein nas1000 jetzt mit zwei festplatten am laufen.
zur vollendeten konfiguration komme ich spaeter noch, am besten in einem anderen thema.
aber die einwaende das mir irgendwann das netzgeraet abrauchen kann liegen mir noch ein wenig schwer im magen.
leider konnte ich mein altes usb-gehaeuse nicht mehr wiederfinden. aber das netzgeraet habe ich noch. ich habe geseheb das die 6 pins an dem stecker 2x5V / 2x12V und 2xGND sind. eine ide-festplatte braucht ja bekanntlich auch 1x5V(rot) / 2x GND (schwarz) und 1x 12V (gelb)
koennte ich mir da nicht einfach eine kabel fuer loeten, welches auf der einen seite eine buchse fuers ng von raidsonic hat und auf der anderen seite einen 5 1/2 zoll stecker der die platte dann direkt mit spannung und strom versorgt?
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D

HWguru

NAS2000-Team

Beiträge: 1 001

Wohnort: Wien

13

Montag, 31. März 2008, 14:06

Hi, ja sicher kannst du so ein Adapterkabel löten.
So ein Kabel habe ich mir auch schon für einen USB/IDE Adapter gebastelt.

Einziger Nachteil von zwei getrennten Netzgeräten ist, dass die Spannung zur zweiten Platte nicht abgeschaltet wird, wenn man die Box abschaltet.
Aber normalerweise lässt man das NAS eher im Dauerbetrieb laufen.

Die Abschaltung könnte man einfach mit einem Relais dazubauen.
zB mit der 5V oder 12V der 1. Platte ein Relais ansteuern und die 5V und 12V der 2. Platte schalten.
Leute ohne Laster haben oft wenige Tugenden...
NAS2000 2.3.2.IB.2.RS.1+Lüfterabschaltung+SSH+do_it+zusätzliche commandline tools+changed root password
1. suchen - lesen - Google - lesen - 1. Fragen gehören ins Forum, dann profitieren alle davon!

BooStar

Anfänger

Beiträge: 49

Wohnort: HamburgCity

14

Montag, 31. März 2008, 16:16

ahh sehr gut. das das funktioniert, ich hatte gedacht, einen normalen kippschlater zum auschalten zu nehmen, wenn man das nas dann mal ausschalten moechte gehts zwar ein wenig umstaendilicher, aber es geht...

danke HWguru
Hardware Name: IB-NAS 1000 Platform
Firmware Version: 2.3.2-mu-02.2
Hardware Version: Rev. B
:DMIT ZWEI FESTPLATTEN :D